Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Авто заполнение матрицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Авто заполнение матрицы (Формулы/Formulas)
Авто заполнение матрицы
sarxip Дата: Воскресенье, 12.11.2017, 12:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
возможно понадобится промежуточные ячейки, что-бы разъединить данные из АХ152
В 128 строке (желтым цветом) мы видим название в {} В12, В16, В20 данные берутся из клетки АХ152
они вписываются в матрицу (столбец зеленый) 0 или 1, напротив своего названия

Спасибо
К сообщению приложен файл: 0239552.xlsx(84Kb)


Сообщение отредактировал sarxip - Воскресенье, 12.11.2017, 14:32
 
Ответить
Сообщениевозможно понадобится промежуточные ячейки, что-бы разъединить данные из АХ152
В 128 строке (желтым цветом) мы видим название в {} В12, В16, В20 данные берутся из клетки АХ152
они вписываются в матрицу (столбец зеленый) 0 или 1, напротив своего названия

Спасибо

Автор - sarxip
Дата добавления - 12.11.2017 в 12:53
buchlotnik Дата: Воскресенье, 12.11.2017, 13:46 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3327
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
1)
и вам здравствуйте
Цитата
и 2й вопрос
и Правила форума


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
1)
и вам здравствуйте
Цитата
и 2й вопрос
и Правила форума

Автор - buchlotnik
Дата добавления - 12.11.2017 в 13:46
sarxip Дата: Понедельник, 13.11.2017, 11:33 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
вот что у меня получилось
некоторые позиции мне здесь помогли СПАСИБО
я дописал автозаполнение матрицы

если не трудно поправьте пожалуйста
не знаю как избавиться от #Н/Д
hands
К сообщению приложен файл: 00_A.xlsx(80Kb)


иии
 
Ответить
Сообщениевот что у меня получилось
некоторые позиции мне здесь помогли СПАСИБО
я дописал автозаполнение матрицы

если не трудно поправьте пожалуйста
не знаю как избавиться от #Н/Д
hands

Автор - sarxip
Дата добавления - 13.11.2017 в 11:33
Nic70y Дата: Понедельник, 13.11.2017, 11:55 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4185
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
некоторые позиции мне здесь помогли
а эту
http://www.excelworld.ru/forum/2-36056-236986-16-1510402793
(сообщение #9)
проигнорировали?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 13.11.2017, 11:56
 
Ответить
Сообщение
некоторые позиции мне здесь помогли
а эту
http://www.excelworld.ru/forum/2-36056-236986-16-1510402793
(сообщение #9)
проигнорировали?

Автор - Nic70y
Дата добавления - 13.11.2017 в 11:55
sarxip Дата: Понедельник, 13.11.2017, 12:17 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемый я же написал
некоторые позиции мне здесь помогли СПАСИБО
я вам лично написал + в репутацию
я не знаю что вы еще имеете виду
Меня не затруднит еще раз вам сказать СПАСИБО, вот некоторые формулы
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($AW$133:AW141=AW142);$AX$133:AX141)&", ";"")&AV27

Код
=ПРОСМОТР(;-1/($AW$133:$AW$142=AW146);$AX$133:$AX$142)

Код
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($AX$148;", ";ПОВТОР(" ";99));100*(СТРОКА(C1)-1)+1;99))

Nic70y, hands buchlotnik, и другим спасибо
Правда это только половина работы, а на остальную половину не знаю хватит сил
если кто сможет поправить
как избавиться от #Н/Д
Благодарю ВСЕХ за помощь
hands
К сообщению приложен файл: 7216939.xlsx(80Kb)


иии
 
Ответить
СообщениеУважаемый я же написал
некоторые позиции мне здесь помогли СПАСИБО
я вам лично написал + в репутацию
я не знаю что вы еще имеете виду
Меня не затруднит еще раз вам сказать СПАСИБО, вот некоторые формулы
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($AW$133:AW141=AW142);$AX$133:AX141)&", ";"")&AV27

Код
=ПРОСМОТР(;-1/($AW$133:$AW$142=AW146);$AX$133:$AX$142)

Код
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($AX$148;", ";ПОВТОР(" ";99));100*(СТРОКА(C1)-1)+1;99))

Nic70y, hands buchlotnik, и другим спасибо
Правда это только половина работы, а на остальную половину не знаю хватит сил
если кто сможет поправить
как избавиться от #Н/Д
Благодарю ВСЕХ за помощь
hands

Автор - sarxip
Дата добавления - 13.11.2017 в 12:17
buchlotnik Дата: Понедельник, 13.11.2017, 12:20 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3327
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
sarxip, вам и ссылку дали, и номер сообщения указали - что вам не ясно? кому нужно задачу решить - нам или вам?
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($BA$152;", ";ПОВТОР(" ";99));100*(СТРОКА(J1)-1)+1;99));"")
- что здесь непонятного?
К сообщению приложен файл: 5285500.xlsx(76Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениеsarxip, вам и ссылку дали, и номер сообщения указали - что вам не ясно? кому нужно задачу решить - нам или вам?
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($BA$152;", ";ПОВТОР(" ";99));100*(СТРОКА(J1)-1)+1;99));"")
- что здесь непонятного?

Автор - buchlotnik
Дата добавления - 13.11.2017 в 12:20
Nic70y Дата: Понедельник, 13.11.2017, 12:20 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4185
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($AZ$133:$AZ$142=AZ146);$BA$133:$BA$142);"")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($AZ$133:$AZ$142=AZ146);$BA$133:$BA$142);"")

Автор - Nic70y
Дата добавления - 13.11.2017 в 12:20
sarxip Дата: Понедельник, 13.11.2017, 12:41 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Я ТУПОЙ
в самой матрицы стоит формула
Код
=ЕСЛИ(AV133=$AR$129;1;ЕСЛИ(AV133=$AR$130;1;ЕСЛИ(AV133=$AR$131;1;ЕСЛИ(AV133=$AR$132;1;ЕСЛИ(AV133=$AR$133;1;0)))))

и куна я должен вписать
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($AZ$133:$AZ$142=AZ146);$BA$133:$BA$142);"")

или
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($BA$152;", ";ПОВТОР(" ";99));100*(СТРОКА(J1)-1)+1;99));"")

кто на что учился ;) :'(


иии
 
Ответить
СообщениеЯ ТУПОЙ
в самой матрицы стоит формула
Код
=ЕСЛИ(AV133=$AR$129;1;ЕСЛИ(AV133=$AR$130;1;ЕСЛИ(AV133=$AR$131;1;ЕСЛИ(AV133=$AR$132;1;ЕСЛИ(AV133=$AR$133;1;0)))))

и куна я должен вписать
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($AZ$133:$AZ$142=AZ146);$BA$133:$BA$142);"")

или
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($BA$152;", ";ПОВТОР(" ";99));100*(СТРОКА(J1)-1)+1;99));"")

кто на что учился ;) :'(

Автор - sarxip
Дата добавления - 13.11.2017 в 12:41
buchlotnik Дата: Понедельник, 13.11.2017, 12:50 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3327
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
куна куда я должен вписать
я вам файл приложил - там формула вставлена
Цитата
кто на что учился
ага - я, например, провизор


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 13.11.2017, 12:51
 
Ответить
Сообщение
Цитата
куна куда я должен вписать
я вам файл приложил - там формула вставлена
Цитата
кто на что учился
ага - я, например, провизор

Автор - buchlotnik
Дата добавления - 13.11.2017 в 12:50
sarxip Дата: Понедельник, 13.11.2017, 13:40 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемый вы можете исправить,
хотя-бы одну ячейку ячейку матрицы
я понимаю что вы УМНЕЕ МЕНЯ
yes


иии
 
Ответить
СообщениеУважаемый вы можете исправить,
хотя-бы одну ячейку ячейку матрицы
я понимаю что вы УМНЕЕ МЕНЯ
yes

Автор - sarxip
Дата добавления - 13.11.2017 в 13:40
buchlotnik Дата: Понедельник, 13.11.2017, 13:50 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3327
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
sarxip, в вашем файле были ошибки Н/Д - в одном столбце я их исправил - если вы даже этого не увидели - я пас


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениеsarxip, в вашем файле были ошибки Н/Д - в одном столбце я их исправил - если вы даже этого не увидели - я пас

Автор - buchlotnik
Дата добавления - 13.11.2017 в 13:50
sarxip Дата: Понедельник, 13.11.2017, 14:00 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik,
да не внимателен я Извините
но дело в том что это не выводится на печать
а выводится на печать матрица
я подкрасил в матрице клетку красным цветом
ВЫ можете дам исправить
БЛАГОДАРЮ ВАС
К сообщению приложен файл: 3960145.xlsx(80Kb)


иии

Сообщение отредактировал sarxip - Понедельник, 13.11.2017, 14:01
 
Ответить
Сообщениеbuchlotnik,
да не внимателен я Извините
но дело в том что это не выводится на печать
а выводится на печать матрица
я подкрасил в матрице клетку красным цветом
ВЫ можете дам исправить
БЛАГОДАРЮ ВАС

Автор - sarxip
Дата добавления - 13.11.2017 в 14:00
китин Дата: Понедельник, 13.11.2017, 14:24 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4409
Репутация: 697 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ВЫ можете дам там исправить

ну дык по аналогии же примените ЕСЛИОШИБКА в ячейках AX153: AX159
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($BA$151;", ";ПОВТОР(" ";99));100*(СТРОКА(I1)-1)+1;99));"")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 13.11.2017, 14:24
 
Ответить
Сообщение
ВЫ можете дам там исправить

ну дык по аналогии же примените ЕСЛИОШИБКА в ячейках AX153: AX159
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($BA$151;", ";ПОВТОР(" ";99));100*(СТРОКА(I1)-1)+1;99));"")

Автор - китин
Дата добавления - 13.11.2017 в 14:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Авто заполнение матрицы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!