Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Календарь без лишних дат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Календарь без лишних дат (Формулы/Formulas)
Календарь без лишних дат
YEJ Дата: Воскресенье, 12.11.2017, 18:55 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Подскажите, возможно ли сделать календарь со днями недели, чтобы лишних дат не было (по моему примеру). Т.е. в феврале 2015 года было 28 дней, соответственно нужно сделать так чтобы в ячейках: AF7, AG7 и AH7 было пусто.



П.С. Ошибки в файле исправил.
П.С.С. Прошу простить, если подобная тема была: быстро искал, подобного не нашёл.
К сообщению приложен файл: 123.xls(42Kb)


Сообщение отредактировал YEJ - Воскресенье, 12.11.2017, 19:56
 
Ответить
СообщениеЗдравствуйте!
Подскажите, возможно ли сделать календарь со днями недели, чтобы лишних дат не было (по моему примеру). Т.е. в феврале 2015 года было 28 дней, соответственно нужно сделать так чтобы в ячейках: AF7, AG7 и AH7 было пусто.



П.С. Ошибки в файле исправил.
П.С.С. Прошу простить, если подобная тема была: быстро искал, подобного не нашёл.

Автор - YEJ
Дата добавления - 12.11.2017 в 18:55
Pelena Дата: Воскресенье, 12.11.2017, 20:16 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11755
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Так подойдёт?
К сообщению приложен файл: 9257135.xlsx(15Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак подойдёт?

Автор - Pelena
Дата добавления - 12.11.2017 в 20:16
YEJ Дата: Воскресенье, 12.11.2017, 20:25 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, да, спасибо, Елена!)
За мною "+"!
 
Ответить
СообщениеPelena, да, спасибо, Елена!)
За мною "+"!

Автор - YEJ
Дата добавления - 12.11.2017 в 20:25
Che79 Дата: Воскресенье, 12.11.2017, 20:35 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 597
Репутация: 108 ±
Замечаний: 0% ±

Excel 2007, 2013
YEJ, еще вариант.
В доп. столбец формулу
Код
=ДЕНЬ(КОНМЕСЯЦА(ДАТА($D$2;$C6;D$5);0))
и формулу в УФ
Код
=D$5>$AI6
+ цвет шрифта белый.
К сообщению приложен файл: 123_1.xlsx(15Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеYEJ, еще вариант.
В доп. столбец формулу
Код
=ДЕНЬ(КОНМЕСЯЦА(ДАТА($D$2;$C6;D$5);0))
и формулу в УФ
Код
=D$5>$AI6
+ цвет шрифта белый.

Автор - Che79
Дата добавления - 12.11.2017 в 20:35
_Boroda_ Дата: Воскресенье, 12.11.2017, 23:27 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11644
Репутация: 4825 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще такой вариант формулы
Код
=ТЕКСТ(D$5&$B6&$D$2;"ДДД;;;")

===============
Перевложил файл и формулу поправил - промахнулся, вместо $B6 было $B7
К сообщению приложен файл: 9257135_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще такой вариант формулы
Код
=ТЕКСТ(D$5&$B6&$D$2;"ДДД;;;")

===============
Перевложил файл и формулу поправил - промахнулся, вместо $B6 было $B7

Автор - _Boroda_
Дата добавления - 12.11.2017 в 23:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Календарь без лишних дат (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!