Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Размещение сводных данных по ячейкам с условием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Размещение сводных данных по ячейкам с условием (Формулы/Formulas)
Размещение сводных данных по ячейкам с условием
Webbear Дата: Понедельник, 13.11.2017, 08:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 2 ±
Замечаний: 0% ±

Excel 2010
Добрый день, форумчане.
Подскажите пожалуйста, можно ли без VBA решить следующую задачу:
Имеем изменяемый список членов бригады в ячейках G8:G14, должность (необходима в некоторых случаях, в остальных пусто) - H8:H14 и группу в ячейках К8:К14
Необходимо заполнить сводными данными ячейки B12 и A14, перенося в A14 все, что не влезет в B12 после последней запятой, которая в нее влезет или последнее целое слово.
PS: Если членов бригады мало, как убрать все лишние запятые.
К сообщению приложен файл: 2962532.xlsx(32Kb)
 
Ответить
СообщениеДобрый день, форумчане.
Подскажите пожалуйста, можно ли без VBA решить следующую задачу:
Имеем изменяемый список членов бригады в ячейках G8:G14, должность (необходима в некоторых случаях, в остальных пусто) - H8:H14 и группу в ячейках К8:К14
Необходимо заполнить сводными данными ячейки B12 и A14, перенося в A14 все, что не влезет в B12 после последней запятой, которая в нее влезет или последнее целое слово.
PS: Если членов бригады мало, как убрать все лишние запятые.

Автор - Webbear
Дата добавления - 13.11.2017 в 08:47
Webbear Дата: Понедельник, 13.11.2017, 09:39 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 2 ±
Замечаний: 0% ±

Excel 2010
Частично удалось решить следующим образом:
В ячейке G15 получаем сводные данные с помощью "СЕПИТЬ()" или &
Далее:
B12:
Код
=ЕСЛИ(ДЛСТР(G15)<90;G15;ЛЕВСИМВ(G15;ПОИСК(",";G15;90)))

A14:
Код
=ЕСЛИОШИБКА(ПРАВСИМВ(G15;ДЛСТР(G15)-ПОИСК(",";G15;90));"")


С запятыми не решено!
Если на конец строки в B12 попадает должность, необходимо дополнительное условие по пробелу или "-" после 90-го знака
Как реализовать пока не придумал.


Сообщение отредактировал Webbear - Понедельник, 13.11.2017, 09:56
 
Ответить
СообщениеЧастично удалось решить следующим образом:
В ячейке G15 получаем сводные данные с помощью "СЕПИТЬ()" или &
Далее:
B12:
Код
=ЕСЛИ(ДЛСТР(G15)<90;G15;ЛЕВСИМВ(G15;ПОИСК(",";G15;90)))

A14:
Код
=ЕСЛИОШИБКА(ПРАВСИМВ(G15;ДЛСТР(G15)-ПОИСК(",";G15;90));"")


С запятыми не решено!
Если на конец строки в B12 попадает должность, необходимо дополнительное условие по пробелу или "-" после 90-го знака
Как реализовать пока не придумал.

Автор - Webbear
Дата добавления - 13.11.2017 в 09:39
_Boroda_ Дата: Понедельник, 13.11.2017, 10:27 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Webbear, Вы уж определитесь - запятая или слово?
после последней запятой, которая в нее влезет или последнее целое слово

Сделал по последней запятой
Поскольку буквы разные, то, чтобы ширина этих букв была стандартной, поставил в ячейки В12 и А14 шрифт "Consolas"
К сообщению приложен файл: 2962532_1.xlsx(30Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеWebbear, Вы уж определитесь - запятая или слово?
после последней запятой, которая в нее влезет или последнее целое слово

Сделал по последней запятой
Поскольку буквы разные, то, чтобы ширина этих букв была стандартной, поставил в ячейки В12 и А14 шрифт "Consolas"

Автор - _Boroda_
Дата добавления - 13.11.2017 в 10:27
Webbear Дата: Понедельник, 13.11.2017, 11:05 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 2 ±
Замечаний: 0% ±

Excel 2010
Спасибо, работает.
Запятая лучше. Один нюанс:
Если один член бригады, он пишется в А14 вместо В12, если 2 члена, то 1 в B12, второй в А14 соответственно.
Не критично, но как можно поправить?
 
Ответить
СообщениеСпасибо, работает.
Запятая лучше. Один нюанс:
Если один член бригады, он пишется в А14 вместо В12, если 2 члена, то 1 в B12, второй в А14 соответственно.
Не критично, но как можно поправить?

Автор - Webbear
Дата добавления - 13.11.2017 в 11:05
_Boroda_ Дата: Понедельник, 13.11.2017, 11:20 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Действительно. Не продумал этот момент
Вот так тогда
К сообщению приложен файл: 2962532_2.xlsx(30Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДействительно. Не продумал этот момент
Вот так тогда

Автор - _Boroda_
Дата добавления - 13.11.2017 в 11:20
Webbear Дата: Вторник, 14.11.2017, 05:52 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 2 ±
Замечаний: 0% ±

Excel 2010
Спасибо, так гораздо лучше:)
 
Ответить
СообщениеСпасибо, так гораздо лучше:)

Автор - Webbear
Дата добавления - 14.11.2017 в 05:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Размещение сводных данных по ячейкам с условием (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!