Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое заполнение шаблона по заданному критерию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение шаблона по заданному критерию (Формулы/Formulas)
Автоматическое заполнение шаблона по заданному критерию
Virus Дата: Понедельник, 20.11.2017, 09:34 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Есть база которая формируется автоматически и есть шаблон отчетности по каждом товару.
Необходимо сделать так чтобы при выборе товара остальные поля заполнялись автоматически и количество строк в таблице шаблона соответствовали количеству позиций
К сообщению приложен файл: 4069477.xlsx(11Kb)
 
Ответить
СообщениеЕсть база которая формируется автоматически и есть шаблон отчетности по каждом товару.
Необходимо сделать так чтобы при выборе товара остальные поля заполнялись автоматически и количество строк в таблице шаблона соответствовали количеству позиций

Автор - Virus
Дата добавления - 20.11.2017 в 09:34
китин Дата: Понедельник, 20.11.2017, 10:11 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4437
Репутация: 701 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам здравствуйте
как то так. ФОРМУЛА МАССИВА
Код
=ЕСЛИОШИБКА(ИНДЕКС(БД!$A$2:$A$18;НАИМЕНЬШИЙ(ЕСЛИ($G$7=БД!$A$2:$A$18;СТРОКА(БД!$A$2:$A$18)-1);СТРОКА(A1)));"")
К сообщению приложен файл: Virus.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи вам здравствуйте
как то так. ФОРМУЛА МАССИВА
Код
=ЕСЛИОШИБКА(ИНДЕКС(БД!$A$2:$A$18;НАИМЕНЬШИЙ(ЕСЛИ($G$7=БД!$A$2:$A$18;СТРОКА(БД!$A$2:$A$18)-1);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 20.11.2017 в 10:11
Che79 Дата: Понедельник, 20.11.2017, 10:47 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 660
Репутация: 114 ±
Замечаний: 0% ±

Excel 2007, 2013
Вариант. Если в исходной таблице разъединить объединенные ячейки, то можно сводной + срезом.
К сообщению приложен файл: Virus_1.xlsx(19Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеВариант. Если в исходной таблице разъединить объединенные ячейки, то можно сводной + срезом.

Автор - Che79
Дата добавления - 20.11.2017 в 10:47
Virus Дата: Понедельник, 20.11.2017, 11:45 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, Огромное спасибо!!! Подскажите пожалуйста это образец для понимания проблемы и БД маленькая. Каждый товар может различаться в кол-ве. Есть ли такая возможность автоматическое форматирование таблицы на кол-во записей?
 
Ответить
Сообщениекитин, Огромное спасибо!!! Подскажите пожалуйста это образец для понимания проблемы и БД маленькая. Каждый товар может различаться в кол-ве. Есть ли такая возможность автоматическое форматирование таблицы на кол-во записей?

Автор - Virus
Дата добавления - 20.11.2017 в 11:45
китин Дата: Понедельник, 20.11.2017, 11:58 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4437
Репутация: 701 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
форматирование таблицы на кол-во записей?

поясните


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
форматирование таблицы на кол-во записей?

поясните

Автор - китин
Дата добавления - 20.11.2017 в 11:58
Virus Дата: Понедельник, 20.11.2017, 12:32 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, Допустим у нас товар а был продан 4 раза, а товар б 75 раз. Есть ли возможность автоматически расширять табличку под количество записей?
 
Ответить
Сообщениекитин, Допустим у нас товар а был продан 4 раза, а товар б 75 раз. Есть ли возможность автоматически расширять табличку под количество записей?

Автор - Virus
Дата добавления - 20.11.2017 в 12:32
китин Дата: Понедельник, 20.11.2017, 12:40 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4437
Репутация: 701 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а что мешает просто расширить диапазоны? расширил до 1000 строу в листе БД
К сообщению приложен файл: Virus1.xlsx(84Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа что мешает просто расширить диапазоны? расширил до 1000 строу в листе БД

Автор - китин
Дата добавления - 20.11.2017 в 12:40
Virus Дата: Понедельник, 20.11.2017, 12:43 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, Я про карточку, расширить то можно хоть до скольки, но если товар а продали 3 раза а диапазон 1000 то будет 997 пустых ненужных строк
 
Ответить
Сообщениекитин, Я про карточку, расширить то можно хоть до скольки, но если товар а продали 3 раза а диапазон 1000 то будет 997 пустых ненужных строк

Автор - Virus
Дата добавления - 20.11.2017 в 12:43
китин Дата: Понедельник, 20.11.2017, 12:51 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4437
Репутация: 701 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну можно УФ сетку убрать. или макросом
К сообщению приложен файл: Virus2.xlsx(80Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену можно УФ сетку убрать. или макросом

Автор - китин
Дата добавления - 20.11.2017 в 12:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение шаблона по заданному критерию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!