Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/расчет по времени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » расчет по времени (Формулы/Formulas)
расчет по времени
kotena Дата: Воскресенье, 03.12.2017, 01:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Здравствуйте.
Суть проблемы такова:
есть время начала работы - А1 (13:25) и время конец работы - А2 (16:17), отработанное время будет равно: А3=А2-А1 и составит - 2:52.
В ячейке А4 нужно определить сколько раз в А3 содержится по 30 минут, т.е. в моем случае получится, что 6 раз.

Если не ошибаюсь, то копать нужно где-то тут - "=ЧАС(A1)+МИНУТЫ(A1)"?

Понимаю, что очень сумбурно, но подскажите, пожалуйста, возможно ли такое сделать?
 
Ответить
СообщениеЗдравствуйте.
Суть проблемы такова:
есть время начала работы - А1 (13:25) и время конец работы - А2 (16:17), отработанное время будет равно: А3=А2-А1 и составит - 2:52.
В ячейке А4 нужно определить сколько раз в А3 содержится по 30 минут, т.е. в моем случае получится, что 6 раз.

Если не ошибаюсь, то копать нужно где-то тут - "=ЧАС(A1)+МИНУТЫ(A1)"?

Понимаю, что очень сумбурно, но подскажите, пожалуйста, возможно ли такое сделать?

Автор - kotena
Дата добавления - 03.12.2017 в 01:12
buchlotnik Дата: Воскресенье, 03.12.2017, 01:56 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3437
Репутация: 922 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Код
=ОКРУГЛ(A3*48;)
остальное с файлом примером (округлял по правилам математики, технически там 5,7(3) раз по 30 минут)


"заступлюсь за Юрия" - публичный плевок в душу!

Сообщение отредактировал buchlotnik - Воскресенье, 03.12.2017, 01:57
 
Ответить
Сообщение
Код
=ОКРУГЛ(A3*48;)
остальное с файлом примером (округлял по правилам математики, технически там 5,7(3) раз по 30 минут)

Автор - buchlotnik
Дата добавления - 03.12.2017 в 01:56
kotena Дата: Воскресенье, 03.12.2017, 20:58 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Добавила в файл описание
К сообщению приложен файл: 6232476.xls(24Kb)
 
Ответить
СообщениеДобавила в файл описание

Автор - kotena
Дата добавления - 03.12.2017 в 20:58
Manyasha Дата: Воскресенье, 03.12.2017, 21:16 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 2028
Репутация: 843 ±
Замечаний: 0% ±

Excel 2010, 2016
kotena, здравствуйте.
Вы же сами до ОКРВВЕРХ додумались, его и используйте)
Код
=ОКРВВЕРХ(C3*48;1)

или
Код
=ОКРУГЛВВЕРХ(C3*48;)
К сообщению приложен файл: 6232476-1.xls(34Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеkotena, здравствуйте.
Вы же сами до ОКРВВЕРХ додумались, его и используйте)
Код
=ОКРВВЕРХ(C3*48;1)

или
Код
=ОКРУГЛВВЕРХ(C3*48;)

Автор - Manyasha
Дата добавления - 03.12.2017 в 21:16
kotena Дата: Воскресенье, 03.12.2017, 21:19 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Вы же сами до ОКРВВЕРХ додумались, его и используйте)

господи, точно, большое вам спасибо)
 
Ответить
Сообщение
Вы же сами до ОКРВВЕРХ додумались, его и используйте)

господи, точно, большое вам спасибо)

Автор - kotena
Дата добавления - 03.12.2017 в 21:19
_Boroda_ Дата: Воскресенье, 03.12.2017, 21:24 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ОТБР((C3-"0:0:1")/"0:30")+1

Вычитаем секунду, делим на 30 минут, оставляем целую часть и прибавляем 1
Секунду вычитаем для того, чтобы правильно отработало время, кратное получасу
Или
Код
=ОТБР((C3+"0:29:59")/"0:30")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ОТБР((C3-"0:0:1")/"0:30")+1

Вычитаем секунду, делим на 30 минут, оставляем целую часть и прибавляем 1
Секунду вычитаем для того, чтобы правильно отработало время, кратное получасу
Или
Код
=ОТБР((C3+"0:29:59")/"0:30")

Автор - _Boroda_
Дата добавления - 03.12.2017 в 21:24
kotena Дата: Воскресенье, 03.12.2017, 22:08 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
спасибо, да, тоже отлично работает)

появился еще один вопрос:
в А5 и В5 хотелось бы вводить 1234, а не 12:34, лечится форматом ячеек А5 и В5 - "00\:00", но тогда начинается проблема в С5 и D5.
Файл приложила (или этот вопрос уже отдельным постом?)
К сообщению приложен файл: example_.xls(24Kb)
 
Ответить
Сообщениеспасибо, да, тоже отлично работает)

появился еще один вопрос:
в А5 и В5 хотелось бы вводить 1234, а не 12:34, лечится форматом ячеек А5 и В5 - "00\:00", но тогда начинается проблема в С5 и D5.
Файл приложила (или этот вопрос уже отдельным постом?)

Автор - kotena
Дата добавления - 03.12.2017 в 22:08
Shylo Дата: Понедельник, 04.12.2017, 10:17 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 116
Репутация: 5 ±
Замечаний: 0% ±

Excel-2003; 2010
kotena, конечно тема должна быть новая, но уже обсуждалось тут
 
Ответить
Сообщение kotena, конечно тема должна быть новая, но уже обсуждалось тут

Автор - Shylo
Дата добавления - 04.12.2017 в 10:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » расчет по времени (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!