Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнить две ячейки, и найти 1,2, или 3 совпадение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить две ячейки, и найти 1,2, или 3 совпадение (Формулы/Formulas)
Сравнить две ячейки, и найти 1,2, или 3 совпадение
sarxip Дата: Понедельник, 04.12.2017, 23:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте, как найти хоть одно совладение из двух ячеек
К сообщению приложен файл: 5976603.xlsx(9Kb)


иии
 
Ответить
СообщениеЗдравствуйте, как найти хоть одно совладение из двух ячеек

Автор - sarxip
Дата добавления - 04.12.2017 в 23:50
Светлый Дата: Вторник, 05.12.2017, 07:53 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 304
Репутация: 74 ±
Замечаний: 0% ±

Excel 2007
Если формат элементов в ячейках такой, как в примере и не будет меняться, то можно решить такой формулой массива:
Код
=ЕСЛИОШИБКА("В"&НАИБОЛЬШИЙ(ЕСЛИ(МУМНОЖ(--ЕОШ(ПОИСК("В"&СТРОКА($1:$40)&",";$D17:$E17&","));{1:1});"";СТРОКА($1:$40));СТОЛБЕЦ(A5));"")

sarxip, ответ второго примера был ошибочный?
К сообщению приложен файл: 5976603-1.xlsx(10Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЕсли формат элементов в ячейках такой, как в примере и не будет меняться, то можно решить такой формулой массива:
Код
=ЕСЛИОШИБКА("В"&НАИБОЛЬШИЙ(ЕСЛИ(МУМНОЖ(--ЕОШ(ПОИСК("В"&СТРОКА($1:$40)&",";$D17:$E17&","));{1:1});"";СТРОКА($1:$40));СТОЛБЕЦ(A5));"")

sarxip, ответ второго примера был ошибочный?

Автор - Светлый
Дата добавления - 05.12.2017 в 07:53
ВладимирG Дата: Вторник, 05.12.2017, 16:22 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 131
Репутация: 21 ±
Замечаний: 0% ±

2007
Код
=ЕСЛИ(ЕНД(СУММ(ПОИСКПОЗ({1:2:3:4:5};НАЙТИ(ПСТР(D15&", ";СТРОКА($A$1:$A$100);3);E15&", ");)));;E15)
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕНД(СУММ(ПОИСКПОЗ({1:2:3:4:5};НАЙТИ(ПСТР(D15&", ";СТРОКА($A$1:$A$100);3);E15&", ");)));;E15)

Автор - ВладимирG
Дата добавления - 05.12.2017 в 16:22
sboy Дата: Вторник, 05.12.2017, 16:36 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1166
Репутация: 294 ±
Замечаний: 0% ±

Excel 2010
Добавлю вариант UDFкой
[vba]
Код
Function sovpad(ByVal t1 As String, ByVal t2 As String) As String
    arr1 = Split(t1, ",")
    arr2 = Split(t2, ",")
        For x = 0 To UBound(arr1)
            For y = 0 To UBound(arr2)
                If WorksheetFunction.Trim(arr1(x)) = WorksheetFunction.Trim(arr2(y)) Then
                    sovpad = t2
                    Exit Function
                End If
            Next y
        Next x
    sovpad = "0 (решений нет)"
End Function
[/vba]
К сообщению приложен файл: 5976603.xlsm(16Kb)
 
Ответить
СообщениеДобавлю вариант UDFкой
[vba]
Код
Function sovpad(ByVal t1 As String, ByVal t2 As String) As String
    arr1 = Split(t1, ",")
    arr2 = Split(t2, ",")
        For x = 0 To UBound(arr1)
            For y = 0 To UBound(arr2)
                If WorksheetFunction.Trim(arr1(x)) = WorksheetFunction.Trim(arr2(y)) Then
                    sovpad = t2
                    Exit Function
                End If
            Next y
        Next x
    sovpad = "0 (решений нет)"
End Function
[/vba]

Автор - sboy
Дата добавления - 05.12.2017 в 16:36
sarxip Дата: Вторник, 05.12.2017, 22:53 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемые.
макрос классно работает, но я не умею с ним работать, я попытался его вставить , не вышло.
Код
=ЕСЛИОШИБКА("В"&НАИБОЛЬШИЙ(ЕСЛИ(МУМНОЖ(--ЕОШ(ПОИСК("В"&СТРОКА($1:$40)&",";$D17:$E17&","));{1:1});"";СТРОКА($1:$40));СТОЛБЕЦ(A5));"")

она работает, но мне не надо разбивать на элементы, а нужно чтобы вся строка вставилась, а если нет хоть одного совпадения то выводится надпись 0 (нет решения)

Код
=ЕСЛИ(ЕНД(СУММ(ПОИСКПОЗ({1:2:3:4:5};НАЙТИ(ПСТР(D15&", ";СТРОКА($A$1:$A$100);3);E15&", ");)));;E15)
я не понял, какая первая ячейка и какая вторая
Благодарю вас всех, что написали мне.
hands


иии

Сообщение отредактировал sarxip - Вторник, 05.12.2017, 22:57
 
Ответить
СообщениеУважаемые.
макрос классно работает, но я не умею с ним работать, я попытался его вставить , не вышло.
Код
=ЕСЛИОШИБКА("В"&НАИБОЛЬШИЙ(ЕСЛИ(МУМНОЖ(--ЕОШ(ПОИСК("В"&СТРОКА($1:$40)&",";$D17:$E17&","));{1:1});"";СТРОКА($1:$40));СТОЛБЕЦ(A5));"")

она работает, но мне не надо разбивать на элементы, а нужно чтобы вся строка вставилась, а если нет хоть одного совпадения то выводится надпись 0 (нет решения)

Код
=ЕСЛИ(ЕНД(СУММ(ПОИСКПОЗ({1:2:3:4:5};НАЙТИ(ПСТР(D15&", ";СТРОКА($A$1:$A$100);3);E15&", ");)));;E15)
я не понял, какая первая ячейка и какая вторая
Благодарю вас всех, что написали мне.
hands

Автор - sarxip
Дата добавления - 05.12.2017 в 22:53
_Boroda_ Дата: Вторник, 05.12.2017, 23:06 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
sarxip, Давайте уточним - Уая буква? Вас там всегда буква "В" или может быть любая буква?
Всегда ли вообще там буква?
Сколько может быть цифр после буквы?
Какие вообще возможны варианты написания?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеsarxip, Давайте уточним - Уая буква? Вас там всегда буква "В" или может быть любая буква?
Всегда ли вообще там буква?
Сколько может быть цифр после буквы?
Какие вообще возможны варианты написания?

Автор - _Boroda_
Дата добавления - 05.12.2017 в 23:06
sarxip Дата: Вторник, 05.12.2017, 23:46 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Да Буквы всегда, это номера контролера например №17 это W-8741-G и я в своей контрольной пишу В17 не знаю почему В но это так надо писать в контрольной,
они группируются по тех. характеристикам, и нам надо собрать похожим по тех. характеристикам, их может быть 1, или 2……до 10шт, и получается что в одной ячейке будет В11, В13, В23, и так далее.
цифр только после буквы 1 или 2 например В7, В45
Варианты только в примере (ответ) столбике G

я ставил формулу
Код
=ЕСЛИ
но она не работает,
хотя после вашего вопроса какие варианты написания,
я завтра попробую написать , сгенерировать цифровой код например
В1, В12, В34 можно написать так 11234 и тогда возможно формула
Код
=ЕСЛИ
сработает
Вы дали ИДЕЮ СПАСИБО hands
К сообщению приложен файл: 4358703.xlsx(9Kb)


иии

Сообщение отредактировал sarxip - Среда, 06.12.2017, 00:00
 
Ответить
СообщениеДа Буквы всегда, это номера контролера например №17 это W-8741-G и я в своей контрольной пишу В17 не знаю почему В но это так надо писать в контрольной,
они группируются по тех. характеристикам, и нам надо собрать похожим по тех. характеристикам, их может быть 1, или 2……до 10шт, и получается что в одной ячейке будет В11, В13, В23, и так далее.
цифр только после буквы 1 или 2 например В7, В45
Варианты только в примере (ответ) столбике G

я ставил формулу
Код
=ЕСЛИ
но она не работает,
хотя после вашего вопроса какие варианты написания,
я завтра попробую написать , сгенерировать цифровой код например
В1, В12, В34 можно написать так 11234 и тогда возможно формула
Код
=ЕСЛИ
сработает
Вы дали ИДЕЮ СПАСИБО hands

Автор - sarxip
Дата добавления - 05.12.2017 в 23:46
sarxip Дата: Среда, 06.12.2017, 07:49 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
не получилось сгенерировать цифровой код например
В1, В12, В34 можно написать так 11234
Код
=если
не поймет, она же берет всю суму а не разбивает ее на составляющие.

в идеале вот что должно быть, в приложенном файле для 30 варианта например закрашено зеленым цветом
я файл урезал а то он здесь не проходит
К сообщению приложен файл: 1957411.xlsx(85Kb)


иии

Сообщение отредактировал sarxip - Среда, 06.12.2017, 07:50
 
Ответить
Сообщениене получилось сгенерировать цифровой код например
В1, В12, В34 можно написать так 11234
Код
=если
не поймет, она же берет всю суму а не разбивает ее на составляющие.

в идеале вот что должно быть, в приложенном файле для 30 варианта например закрашено зеленым цветом
я файл урезал а то он здесь не проходит

Автор - sarxip
Дата добавления - 06.12.2017 в 07:49
_Boroda_ Дата: Среда, 06.12.2017, 09:05 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ой! Не, два раза ой!
Что это? Куда откуда что почему нужно?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОй! Не, два раза ой!
Что это? Куда откуда что почему нужно?

Автор - _Boroda_
Дата добавления - 06.12.2017 в 09:05
sarxip Дата: Среда, 06.12.2017, 09:54 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
вариант
если сходиться хоть один вариант
Код
=$AT$146&" "&$AS$152&" "&AT156&" = "&AX156


не сходится не один вариант
Код
=$AT$147&" "&$AS$152&" "&AT156&" = "&AS151

это сравнение из двух матриц
в Вузе профессор сказал что, эту работу можно сделать только Mathcad, потому-что в нем есть логический блок, он не понимает как эксель умножает в матрице,
я ему говорю что мне не нужно перемножать, потому что у нас есть 0 не принимаем 1 принимаем профессор не верит своим глазам
нужен последний штрих, плиззз hands
помогите кто знает как сделать


иии

Сообщение отредактировал sarxip - Среда, 06.12.2017, 10:28
 
Ответить
Сообщениевариант
если сходиться хоть один вариант
Код
=$AT$146&" "&$AS$152&" "&AT156&" = "&AX156


не сходится не один вариант
Код
=$AT$147&" "&$AS$152&" "&AT156&" = "&AS151

это сравнение из двух матриц
в Вузе профессор сказал что, эту работу можно сделать только Mathcad, потому-что в нем есть логический блок, он не понимает как эксель умножает в матрице,
я ему говорю что мне не нужно перемножать, потому что у нас есть 0 не принимаем 1 принимаем профессор не верит своим глазам
нужен последний штрих, плиззз hands
помогите кто знает как сделать

Автор - sarxip
Дата добавления - 06.12.2017 в 09:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить две ячейки, и найти 1,2, или 3 совпадение (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!