Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/необычная сортировка текста и чисел в одном столбце формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » необычная сортировка текста и чисел в одном столбце формулой (Формулы/Formulas)
необычная сортировка текста и чисел в одном столбце формулой
Рид Дата: Понедельник, 01.01.2018, 23:29 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день , всех с новым годом))
имееться таблица с именами и цифрами,
как формулой рассортировать в одном столбце данные так ,что бы сначала шли фамилии по алфавиту с а до я, а затем цифры по возрастанию ?
К сообщению приложен файл: 5555.xlsx(9.2 Kb)


ridik

Сообщение отредактировал Рид - Понедельник, 01.01.2018, 23:30
 
Ответить
СообщениеДобрый день , всех с новым годом))
имееться таблица с именами и цифрами,
как формулой рассортировать в одном столбце данные так ,что бы сначала шли фамилии по алфавиту с а до я, а затем цифры по возрастанию ?

Автор - Рид
Дата добавления - 01.01.2018 в 23:29
vikttur Дата: Вторник, 02.01.2018, 02:50 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2687
Репутация: 477 ±
Замечаний: 0% ±

С доп. столбцом:
Код
=ЕСЛИ(ЕОШ(--C3);СЧЁТЕСЛИ($C$3:$C$34;"<"&C3);РАНГ(C3;$C$3:$C$34;1)*1000)

Код
=ИНДЕКС($C$3:$C$34;ПОИСКПОЗ(НАИМЕНЬШИЙ($E$3:$E$34;СТРОКА(A1));$E$3:$E$34;))


Одной формулой массива:
Код
=ИНДЕКС($C$3:$C$34;--ПРАВБ(ТЕКСТ(НАИМЕНЬШИЙ(СТРОКА($C$3:$C$34)/1000+ЕСЛИ(ЕОШ(--$C$3:$C$34);СЧЁТЕСЛИ($C$3:$C$34;"<"&$C$3:$C$34);РАНГ($C$3:$C$34;$C$3:$C$34;1)*100);СТРОКА(A1));"0,000");2)-2)
К сообщению приложен файл: 6264597.xlsx(11.7 Kb)
 
Ответить
СообщениеС доп. столбцом:
Код
=ЕСЛИ(ЕОШ(--C3);СЧЁТЕСЛИ($C$3:$C$34;"<"&C3);РАНГ(C3;$C$3:$C$34;1)*1000)

Код
=ИНДЕКС($C$3:$C$34;ПОИСКПОЗ(НАИМЕНЬШИЙ($E$3:$E$34;СТРОКА(A1));$E$3:$E$34;))


Одной формулой массива:
Код
=ИНДЕКС($C$3:$C$34;--ПРАВБ(ТЕКСТ(НАИМЕНЬШИЙ(СТРОКА($C$3:$C$34)/1000+ЕСЛИ(ЕОШ(--$C$3:$C$34);СЧЁТЕСЛИ($C$3:$C$34;"<"&$C$3:$C$34);РАНГ($C$3:$C$34;$C$3:$C$34;1)*100);СТРОКА(A1));"0,000");2)-2)

Автор - vikttur
Дата добавления - 02.01.2018 в 02:50
Nic70y Дата: Вторник, 02.01.2018, 12:16 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4560
Репутация: 985 ±
Замечаний: 0% ±

Excel 2013
еще вариант
Код
=ИНДЕКС(C$1:C$34;ОСТАТ(НАИМЕНЬШИЙ(СЧЁТЕСЛИ(C$3:C$34;"<"&C$3:C$34)+ЕСЛИ(ЕЧИСЛО(C$3:C$34);C$3:C$34+1000000)+СТРОКА(C$3:C$34)/1000;СТРОКА(H1));1)*1000)
К сообщению приложен файл: 5980616.xlsx(10.5 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениееще вариант
Код
=ИНДЕКС(C$1:C$34;ОСТАТ(НАИМЕНЬШИЙ(СЧЁТЕСЛИ(C$3:C$34;"<"&C$3:C$34)+ЕСЛИ(ЕЧИСЛО(C$3:C$34);C$3:C$34+1000000)+СТРОКА(C$3:C$34)/1000;СТРОКА(H1));1)*1000)

Автор - Nic70y
Дата добавления - 02.01.2018 в 12:16
Рид Дата: Четверг, 04.01.2018, 15:54 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
спасибо большое Nic70y и vikttur Вы очень помогли))


ridik
 
Ответить
Сообщениеспасибо большое Nic70y и vikttur Вы очень помогли))

Автор - Рид
Дата добавления - 04.01.2018 в 15:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » необычная сортировка текста и чисел в одном столбце формулой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!