Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/количество дней для расчёта отпускных - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » количество дней для расчёта отпускных (Формулы/Formulas)
количество дней для расчёта отпускных
gling Дата: Четверг, 11.01.2018, 20:02 | Сообщение № 21
Группа: Друзья
Ранг: Старожил
Сообщений: 1816
Репутация: 440 ±
Замечаний: 0% ±

2010
Цитата Никанор, 11.01.2018 в 13:57, в сообщении № 20 ()
можно ли выполнить
Вар.3
К сообщению приложен файл: 1562844.xlsx(46.7 Kb)


ЯД-41001506838083
 
Ответить
Сообщение
Цитата Никанор, 11.01.2018 в 13:57, в сообщении № 20 ()
можно ли выполнить
Вар.3

Автор - gling
Дата добавления - 11.01.2018 в 20:02
Никанор Дата: Пятница, 12.01.2018, 17:49 | Сообщение № 22
Группа: Проверенные
Ранг: Обитатель
Сообщений: 342
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
gling, Здравствуйте!
Большое спасибо что добавили в столбец С в диапазон ячеек C20:C31 название «Для наглядности» период, с которого начинается расчёт дней отпускных.
Это полностью выполняет моё условие: начинать расчёт дней, с которого устроился сотрудник: Календарные с начала устройства сотрудника (ячейка D9) дни минус праздничные дни Таблицы в диапазоне ячеек I20:O31;R20:X31;Z20:AF31.
Я проверил несколько вариантов – формула в диапазоне ячеек C20:C31 «работает» так как я и просил.
Я в свой рабочий вариант добавлю Ваш столбец «Для наглядности». Допишу в него: «Дата, с которого начинается расчёт отпускных».
Вы даже усовершенствовали таблицу. Я очень доволен – Вы полностью выполнили условия, которые я просил, этим облегчили мне работу.
Всё чудесно – большое Вам спасибо за формулы и уделённое моему вопросу время!


Сообщение отредактировал Никанор - Пятница, 12.01.2018, 17:50
 
Ответить
Сообщениеgling, Здравствуйте!
Большое спасибо что добавили в столбец С в диапазон ячеек C20:C31 название «Для наглядности» период, с которого начинается расчёт дней отпускных.
Это полностью выполняет моё условие: начинать расчёт дней, с которого устроился сотрудник: Календарные с начала устройства сотрудника (ячейка D9) дни минус праздничные дни Таблицы в диапазоне ячеек I20:O31;R20:X31;Z20:AF31.
Я проверил несколько вариантов – формула в диапазоне ячеек C20:C31 «работает» так как я и просил.
Я в свой рабочий вариант добавлю Ваш столбец «Для наглядности». Допишу в него: «Дата, с которого начинается расчёт отпускных».
Вы даже усовершенствовали таблицу. Я очень доволен – Вы полностью выполнили условия, которые я просил, этим облегчили мне работу.
Всё чудесно – большое Вам спасибо за формулы и уделённое моему вопросу время!

Автор - Никанор
Дата добавления - 12.01.2018 в 17:49
Никанор Дата: Среда, 17.01.2018, 12:58 | Сообщение № 23
Группа: Проверенные
Ранг: Обитатель
Сообщений: 342
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Работая в рабочем файле, я заметил, что формулы в диапазоне ячеек B20:В31 не всегда считают правильно.
Помогите, пожалуйста, изменить формулу в ячейке В31 в приложенном файле.
В этом примере в ячейке Е15 месяц Декабрь. Значит, в ячейке В31 должен бать месяц Ноябрь, а не Декабрь.
К сообщению приложен файл: _____.xlsx(25.9 Kb)
 
Ответить
СообщениеЗдравствуйте!
Работая в рабочем файле, я заметил, что формулы в диапазоне ячеек B20:В31 не всегда считают правильно.
Помогите, пожалуйста, изменить формулу в ячейке В31 в приложенном файле.
В этом примере в ячейке Е15 месяц Декабрь. Значит, в ячейке В31 должен бать месяц Ноябрь, а не Декабрь.

Автор - Никанор
Дата добавления - 17.01.2018 в 12:58
Никанор Дата: Среда, 17.01.2018, 15:17 | Сообщение № 24
Группа: Проверенные
Ранг: Обитатель
Сообщений: 342
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
Вот формулу, которую надо поменять в диапазоне ячеек B20: B31
Код
=ЕСЛИ(И(СТРОКА(A12)>11-$B$10;B$10<12);ЕСЛИ(B30="";$D$9;КОНМЕСЯЦА(B30;0)+1);ЕСЛИ(ДАТАМЕС($D$9;12)>$E$15;"";КОНМЕСЯЦА($E$15;СТРОКА(A12)-14)+1))


Я обратил внимание на следующую закономерность:
1. Если в ячейке D9 (D9 – это Устроен с:) написать например от 1 по 15 июля включительно, а в ячейке E15 (E15 – это срок отпуска включительно) в это время написать от 1 до 15 декабря включительно – то считает неправильно, последний месяц в ячейке В31 Декабрь (должен быть Ноябрь).

2. Если в ячейке D9 (D9 – это Устроен с:) написать например от 16 по 31 июля включительно, а в ячейке E15 (E15 – это срок отпуска включительно) в это время написать от 1 до 15 декабря включительно – то считает правильно, последний месяц в ячейке В31 Ноябрь.

3. 2. Если в ячейке D9 (D9 – это Устроен с:) написать например от 16 по 31 июля включительно, а в ячейке E15 (E15 – это срок отпуска включительно) в это время написать от 16 до 31 декабря включительно – то считает неправильно, последний месяц в ячейке В31 Декабрь (должен быть Ноябрь).

4. Если в ячейке D9 – 25 июля, а в ячейке E15 от 1 до 24 декабря – то считает правильно, последний месяц в ячейке В31 Ноябрь.

5. Если в ячейке D9 – 25 июля, а в ячейке E15 от 25 до 31 декабря – то считает неправильно, последний месяц в ячейке В31 Декабрь (должен быть Ноябрь).


Сообщение отредактировал Pelena - Вторник, 23.01.2018, 10:30
 
Ответить
СообщениеВот формулу, которую надо поменять в диапазоне ячеек B20: B31
Код
=ЕСЛИ(И(СТРОКА(A12)>11-$B$10;B$10<12);ЕСЛИ(B30="";$D$9;КОНМЕСЯЦА(B30;0)+1);ЕСЛИ(ДАТАМЕС($D$9;12)>$E$15;"";КОНМЕСЯЦА($E$15;СТРОКА(A12)-14)+1))


Я обратил внимание на следующую закономерность:
1. Если в ячейке D9 (D9 – это Устроен с:) написать например от 1 по 15 июля включительно, а в ячейке E15 (E15 – это срок отпуска включительно) в это время написать от 1 до 15 декабря включительно – то считает неправильно, последний месяц в ячейке В31 Декабрь (должен быть Ноябрь).

2. Если в ячейке D9 (D9 – это Устроен с:) написать например от 16 по 31 июля включительно, а в ячейке E15 (E15 – это срок отпуска включительно) в это время написать от 1 до 15 декабря включительно – то считает правильно, последний месяц в ячейке В31 Ноябрь.

3. 2. Если в ячейке D9 (D9 – это Устроен с:) написать например от 16 по 31 июля включительно, а в ячейке E15 (E15 – это срок отпуска включительно) в это время написать от 16 до 31 декабря включительно – то считает неправильно, последний месяц в ячейке В31 Декабрь (должен быть Ноябрь).

4. Если в ячейке D9 – 25 июля, а в ячейке E15 от 1 до 24 декабря – то считает правильно, последний месяц в ячейке В31 Ноябрь.

5. Если в ячейке D9 – 25 июля, а в ячейке E15 от 25 до 31 декабря – то считает неправильно, последний месяц в ячейке В31 Декабрь (должен быть Ноябрь).

Автор - Никанор
Дата добавления - 17.01.2018 в 15:17
gling Дата: Пятница, 19.01.2018, 23:32 | Сообщение № 25
Группа: Друзья
Ранг: Старожил
Сообщений: 1816
Репутация: 440 ±
Замечаний: 0% ±

2010
Попробуйте для ячейки В20
Код
=ЕСЛИ(И(СТРОКА(A1)>11+(ДЕНЬ($D$9)<ДЕНЬ($E$15))-$B$10;B$10<12);ЕСЛИ(B19="";$D$9;КОНМЕСЯЦА(B19;0)+1);ЕСЛИ(ДАТАМЕС($D$9;12)>$E$15;"";КОНМЕСЯЦА($E$15;СТРОКА(A1)-14)+1))
Погоняйте по разным данным.
К сообщению приложен файл: 5713600.xlsx(46.7 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Пятница, 19.01.2018, 23:32
 
Ответить
СообщениеПопробуйте для ячейки В20
Код
=ЕСЛИ(И(СТРОКА(A1)>11+(ДЕНЬ($D$9)<ДЕНЬ($E$15))-$B$10;B$10<12);ЕСЛИ(B19="";$D$9;КОНМЕСЯЦА(B19;0)+1);ЕСЛИ(ДАТАМЕС($D$9;12)>$E$15;"";КОНМЕСЯЦА($E$15;СТРОКА(A1)-14)+1))
Погоняйте по разным данным.

Автор - gling
Дата добавления - 19.01.2018 в 23:32
Никанор Дата: Понедельник, 22.01.2018, 12:37 | Сообщение № 26
Группа: Проверенные
Ранг: Обитатель
Сообщений: 342
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
gling, Здравствуйте!
Спасибо за ответ. Погонял по разным датам – прошлые ошибки исправились и результат правильный.

Сейчас заметил одну ошибку:
Если в ячейке D9 и в ячейке и в ячейке Е15 стоят одинаковые числа месяца. Например: в ячейке D9 15 июля а в ячейке Е15 15 декабря.
Или в D9 6 июля, а в Е15 6 ноября, и так далее.
Вывод: сейчас я заметил если в ячейке D9 и в ячейке Е15 стоят одинаковые числа разных месяцев, то результат неправильный – последний месяц в ячейке В31 равняется месяцу в ячейке Е15. А должен быть на один месяц меньше.

Ячейка D9 – дата трудоустройства;
Ячейка Е15 – Срок отпуска включительно с какого числа


Сообщение отредактировал Никанор - Вторник, 23.01.2018, 10:42
 
Ответить
Сообщениеgling, Здравствуйте!
Спасибо за ответ. Погонял по разным датам – прошлые ошибки исправились и результат правильный.

Сейчас заметил одну ошибку:
Если в ячейке D9 и в ячейке и в ячейке Е15 стоят одинаковые числа месяца. Например: в ячейке D9 15 июля а в ячейке Е15 15 декабря.
Или в D9 6 июля, а в Е15 6 ноября, и так далее.
Вывод: сейчас я заметил если в ячейке D9 и в ячейке Е15 стоят одинаковые числа разных месяцев, то результат неправильный – последний месяц в ячейке В31 равняется месяцу в ячейке Е15. А должен быть на один месяц меньше.

Ячейка D9 – дата трудоустройства;
Ячейка Е15 – Срок отпуска включительно с какого числа

Автор - Никанор
Дата добавления - 22.01.2018 в 12:37
gling Дата: Понедельник, 22.01.2018, 22:47 | Сообщение № 27
Группа: Друзья
Ранг: Старожил
Сообщений: 1816
Репутация: 440 ±
Замечаний: 0% ±

2010
Цитата Никанор, 22.01.2018 в 12:37, в сообщении № 26 ()
А должен быть на один месяц меньше.

Тогда может так?
Код
=ЕСЛИ(И(СТРОКА(A1)>11+(ДЕНЬ($D$9)<=ДЕНЬ($E$15))-$B$10;B$10<12);ЕСЛИ(C19="";$D$9;КОНМЕСЯЦА(C19;0)+1);ЕСЛИ(ДАТАМЕС($D$9;12)>$E$15;"";КОНМЕСЯЦА($E$15;СТРОКА(A1)-14)+1))
ДЕНЬ($D$9)<=ДЕНЬ($E$15)


ЯД-41001506838083

Сообщение отредактировал gling - Понедельник, 22.01.2018, 22:48
 
Ответить
Сообщение
Цитата Никанор, 22.01.2018 в 12:37, в сообщении № 26 ()
А должен быть на один месяц меньше.

Тогда может так?
Код
=ЕСЛИ(И(СТРОКА(A1)>11+(ДЕНЬ($D$9)<=ДЕНЬ($E$15))-$B$10;B$10<12);ЕСЛИ(C19="";$D$9;КОНМЕСЯЦА(C19;0)+1);ЕСЛИ(ДАТАМЕС($D$9;12)>$E$15;"";КОНМЕСЯЦА($E$15;СТРОКА(A1)-14)+1))
ДЕНЬ($D$9)<=ДЕНЬ($E$15)

Автор - gling
Дата добавления - 22.01.2018 в 22:47
Никанор Дата: Вторник, 23.01.2018, 10:04 | Сообщение № 28
Группа: Проверенные
Ранг: Обитатель
Сообщений: 342
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
gling, Здравствуйте!
Поставил в ячейку В20 эту формулу ↑ и "протянул" ниже до ячейки В31 – результат тот же: ошибок, которые были в файле 1562844.xlsx(47Kb) про которые я написал в моём сообщении Дата: Среда, 17.01.2018, 15:17 | Сообщение № 24 нет.
А ошибки, которые были в файле 5713600.xlsx(47Kb) тоже остались: если в ячейке D9 и в ячейке Е15 стоят одинаковые числа разных месяцев, то результат неправильный – последний месяц в ячейке В31 равняется месяцу в ячейке Е15. А должен быть на один месяц меньше.
Формулу надо как-то изменить.


Сообщение отредактировал Никанор - Вторник, 23.01.2018, 10:05
 
Ответить
Сообщениеgling, Здравствуйте!
Поставил в ячейку В20 эту формулу ↑ и "протянул" ниже до ячейки В31 – результат тот же: ошибок, которые были в файле 1562844.xlsx(47Kb) про которые я написал в моём сообщении Дата: Среда, 17.01.2018, 15:17 | Сообщение № 24 нет.
А ошибки, которые были в файле 5713600.xlsx(47Kb) тоже остались: если в ячейке D9 и в ячейке Е15 стоят одинаковые числа разных месяцев, то результат неправильный – последний месяц в ячейке В31 равняется месяцу в ячейке Е15. А должен быть на один месяц меньше.
Формулу надо как-то изменить.

Автор - Никанор
Дата добавления - 23.01.2018 в 10:04
gling Дата: Вторник, 23.01.2018, 12:38 | Сообщение № 29
Группа: Друзья
Ранг: Старожил
Сообщений: 1816
Репутация: 440 ±
Замечаний: 0% ±

2010
Цитата Никанор, 23.01.2018 в 10:04, в сообщении № 28 ()
если в ячейке D9 и в ячейке Е15 стоят одинаковые числа разных месяцев, то результат неправильный – последний месяц в ячейке В31 равняется месяцу в ячейке Е15. А должен быть на один месяц меньше.

Вообще то формул была написана для столбца С, и вставлять её нужно было в столбец С. При вставке в столбец В, формула не будет считать правильно, так как ссылается на данные соседнего столбца "КОНМЕСЯЦА(C19".
Но можно было в любом столбце добавить знак равенства =, выделенный красным в сообщении. В файле то что у меня получилось, поясните в файле, если что не правильно.
К сообщению приложен файл: 0811022.xlsx(46.6 Kb)


ЯД-41001506838083
 
Ответить
Сообщение
Цитата Никанор, 23.01.2018 в 10:04, в сообщении № 28 ()
если в ячейке D9 и в ячейке Е15 стоят одинаковые числа разных месяцев, то результат неправильный – последний месяц в ячейке В31 равняется месяцу в ячейке Е15. А должен быть на один месяц меньше.

Вообще то формул была написана для столбца С, и вставлять её нужно было в столбец С. При вставке в столбец В, формула не будет считать правильно, так как ссылается на данные соседнего столбца "КОНМЕСЯЦА(C19".
Но можно было в любом столбце добавить знак равенства =, выделенный красным в сообщении. В файле то что у меня получилось, поясните в файле, если что не правильно.

Автор - gling
Дата добавления - 23.01.2018 в 12:38
Никанор Дата: Вторник, 23.01.2018, 16:28 | Сообщение № 30
Группа: Проверенные
Ранг: Обитатель
Сообщений: 342
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
gling!
Спасибо большое. Задача решена!
Я проверил разные варианты в Вашем файле 0811022.xlsx(47Kb). Результат то, что надо.
Если в ячейках D9 и Е15 одно число разных месяцев считает правильно. В ячейке В31 всегда месяц, который предшествует месяцу, указанному в ячейке Е15.
Я понял, формулу из Вашего сообщения № 27 надо было вставлять в столбец С.
А в столбце В в формуле надо было поставить знак = выделенный красным в Вашем сообщении № 26. Правильно?

Если можно у меня к Вам уже небольшая просьба.
У меня в моём рабочем файле ячейки столбцов В и С объединены, так как бывает длинное название месяца и оно не помещается в одну ячейку. И у меня в рабочем файле эти формулы, находятся в столбце D (этот столбец называется «Дата начала расчёта в месяце»), а в Вашем файле 0811022.xlsx(47Kb) формулы «Для наглядности» находятся в столбце С.
Я прикрепил файл.
1-ый вопрос: правильно ли я перенёс эти формулы в своё рабочий файл?
Правильные ли формулы в столбце В? И правильные ли формулы в столбце D?
Сейчас в ячейке D20 формула:
Код
=ЕСЛИ(И(СТРОКА(A1)>11+(ДЕНЬ($D$9)<=ДЕНЬ($E$15))-$B$10;B$10<12);ЕСЛИ(C19="";$D$9;КОНМЕСЯЦА(C19;0)+1);ЕСЛИ(ДАТАМЕС($D$9;12)>$E$15;"";КОНМЕСЯЦА($E$15;СТРОКА(A1)-14)+1))

Может её надо сменить на
Код
=ЕСЛИ(И(СТРОКА(A1)>11+(ДЕНЬ($D$9)<=ДЕНЬ($E$15))-$B$10;B$10<12);ЕСЛИ(D19="";$D$9;КОНМЕСЯЦА(D19;0)+1);ЕСЛИ(ДАТАМЕС($D$9;12)>$E$15;"";КОНМЕСЯЦА($E$15;СТРОКА(A1)-14)+1))

ЕСЛИ(C19=""; изменить на ЕСЛИ(D19="";
и КОНМЕСЯЦА(C19;0) изменить на КОНМЕСЯЦА(D19;0)
Или не надо?

2-ой вопрос: можно ли изменить формулу в столбце В что бы месяц писался прописью ТЕКСТом?
Это для того, что бы не объединять ячейки и не раздвигать столбец.
Вот ниже даю примеры формул, когда месяц пишется ТЕКСТом и не надо раздвигать столбец или объединять ячейки. Где в ячейке D9 – название месяца.
Код
=ТЕКСТ(ДАТАМЕС(D9;0);"[$-419]ММММ ГГГГ")
в этом случае название месяца с большой буквы.
Код
=ТЕКСТ(ДАТАМЕС(D9;0);"[$-F419]ММММ ГГГГ")
в этом случае название месяца с маленькой буквы.

Может и в формулу в столбец В как то дописать ТЕКСТ.
К сообщению приложен файл: 2438810.xlsx(27.7 Kb)


Сообщение отредактировал Никанор - Вторник, 23.01.2018, 16:30
 
Ответить
Сообщениеgling!
Спасибо большое. Задача решена!
Я проверил разные варианты в Вашем файле 0811022.xlsx(47Kb). Результат то, что надо.
Если в ячейках D9 и Е15 одно число разных месяцев считает правильно. В ячейке В31 всегда месяц, который предшествует месяцу, указанному в ячейке Е15.
Я понял, формулу из Вашего сообщения № 27 надо было вставлять в столбец С.
А в столбце В в формуле надо было поставить знак = выделенный красным в Вашем сообщении № 26. Правильно?

Если можно у меня к Вам уже небольшая просьба.
У меня в моём рабочем файле ячейки столбцов В и С объединены, так как бывает длинное название месяца и оно не помещается в одну ячейку. И у меня в рабочем файле эти формулы, находятся в столбце D (этот столбец называется «Дата начала расчёта в месяце»), а в Вашем файле 0811022.xlsx(47Kb) формулы «Для наглядности» находятся в столбце С.
Я прикрепил файл.
1-ый вопрос: правильно ли я перенёс эти формулы в своё рабочий файл?
Правильные ли формулы в столбце В? И правильные ли формулы в столбце D?
Сейчас в ячейке D20 формула:
Код
=ЕСЛИ(И(СТРОКА(A1)>11+(ДЕНЬ($D$9)<=ДЕНЬ($E$15))-$B$10;B$10<12);ЕСЛИ(C19="";$D$9;КОНМЕСЯЦА(C19;0)+1);ЕСЛИ(ДАТАМЕС($D$9;12)>$E$15;"";КОНМЕСЯЦА($E$15;СТРОКА(A1)-14)+1))

Может её надо сменить на
Код
=ЕСЛИ(И(СТРОКА(A1)>11+(ДЕНЬ($D$9)<=ДЕНЬ($E$15))-$B$10;B$10<12);ЕСЛИ(D19="";$D$9;КОНМЕСЯЦА(D19;0)+1);ЕСЛИ(ДАТАМЕС($D$9;12)>$E$15;"";КОНМЕСЯЦА($E$15;СТРОКА(A1)-14)+1))

ЕСЛИ(C19=""; изменить на ЕСЛИ(D19="";
и КОНМЕСЯЦА(C19;0) изменить на КОНМЕСЯЦА(D19;0)
Или не надо?

2-ой вопрос: можно ли изменить формулу в столбце В что бы месяц писался прописью ТЕКСТом?
Это для того, что бы не объединять ячейки и не раздвигать столбец.
Вот ниже даю примеры формул, когда месяц пишется ТЕКСТом и не надо раздвигать столбец или объединять ячейки. Где в ячейке D9 – название месяца.
Код
=ТЕКСТ(ДАТАМЕС(D9;0);"[$-419]ММММ ГГГГ")
в этом случае название месяца с большой буквы.
Код
=ТЕКСТ(ДАТАМЕС(D9;0);"[$-F419]ММММ ГГГГ")
в этом случае название месяца с маленькой буквы.

Может и в формулу в столбец В как то дописать ТЕКСТ.

Автор - Никанор
Дата добавления - 23.01.2018 в 16:28
gling Дата: Вторник, 23.01.2018, 22:18 | Сообщение № 31
Группа: Друзья
Ранг: Старожил
Сообщений: 1816
Репутация: 440 ±
Замечаний: 0% ±

2010
Цитата Никанор, 23.01.2018 в 16:28, в сообщении № 30 ()
что бы месяц писался прописью ТЕКСТом
Это не вяжется с названием темы. Если еще возникнут вопросы не связанные с названием этой темы, то создавайте новую в соответствии с правилами форума. В завершение этой темы, отвечаю на последние 2 вопроса. Изменил формулы в столбце В и в столбце Е.
Для удобства анализа формул: Если активировать ячейку с формулой и установить курсор в строку формул, то ячейки участвующие в расчетах будут окантованы разноцветными прямоугольниками. Эти прямоугольники можно перемещать, в результате чего формула будет изменяться, так что не обязательно прописывать ячейки с которых брать данные, достаточно на нужную ячейку переместить этот цветной прямоугольник. Ячейки и имена ячеек в формуле окрашены одинаковым цветом, удобно для визуального анализа что и от куда берется.
К сообщению приложен файл: 9427132.xlsx(28.6 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Вторник, 23.01.2018, 22:25
 
Ответить
Сообщение
Цитата Никанор, 23.01.2018 в 16:28, в сообщении № 30 ()
что бы месяц писался прописью ТЕКСТом
Это не вяжется с названием темы. Если еще возникнут вопросы не связанные с названием этой темы, то создавайте новую в соответствии с правилами форума. В завершение этой темы, отвечаю на последние 2 вопроса. Изменил формулы в столбце В и в столбце Е.
Для удобства анализа формул: Если активировать ячейку с формулой и установить курсор в строку формул, то ячейки участвующие в расчетах будут окантованы разноцветными прямоугольниками. Эти прямоугольники можно перемещать, в результате чего формула будет изменяться, так что не обязательно прописывать ячейки с которых брать данные, достаточно на нужную ячейку переместить этот цветной прямоугольник. Ячейки и имена ячеек в формуле окрашены одинаковым цветом, удобно для визуального анализа что и от куда берется.

Автор - gling
Дата добавления - 23.01.2018 в 22:18
Никанор Дата: Среда, 24.01.2018, 15:07 | Сообщение № 32
Группа: Проверенные
Ранг: Обитатель
Сообщений: 342
Репутация: 2 ±
Замечаний: 0% ±

Excel 2007
gling, Здравствуйте!
Вопрос полностью решён при – разных вариантах все формулы считают правильно.
Больше спасибо за полное решение всех моих вопросов, написании и усовершенствовании формул и углублённое, понятное объяснение.

P. S. Вы пишите:
Если активировать ячейку с формулой и установить курсор в строку формул...

Я ещё посмотрел в Интернете и узнал что активировать ячейку можно так: Выделить нужную ячейку и нажать клавишу F2 и появится формула не в строке формул, а в ячейке. Раньше я этого не знал.
 
Ответить
Сообщениеgling, Здравствуйте!
Вопрос полностью решён при – разных вариантах все формулы считают правильно.
Больше спасибо за полное решение всех моих вопросов, написании и усовершенствовании формул и углублённое, понятное объяснение.

P. S. Вы пишите:
Если активировать ячейку с формулой и установить курсор в строку формул...

Я ещё посмотрел в Интернете и узнал что активировать ячейку можно так: Выделить нужную ячейку и нажать клавишу F2 и появится формула не в строке формул, а в ячейке. Раньше я этого не знал.

Автор - Никанор
Дата добавления - 24.01.2018 в 15:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » количество дней для расчёта отпускных (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!