Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сумма значений до и после слэш - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 2
  • 1
  • 2
  • »
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сумма значений до и после слэш (Формулы/Formulas)
сумма значений до и после слэш
@Анастасия@ Дата: Пятница, 12.01.2018, 19:52 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!Пожалуйста помогите!!!Очень нужно сложить два значения через слэш. Нашла несколько вариантов с помощью формул массива, но никак не могу с ними разобраться(((Файл прикладываю.Если можно объясните, пожалуйста, что означают составляющие этих формул!!!Спасибо!
 
Ответить
СообщениеЗдравствуйте!Пожалуйста помогите!!!Очень нужно сложить два значения через слэш. Нашла несколько вариантов с помощью формул массива, но никак не могу с ними разобраться(((Файл прикладываю.Если можно объясните, пожалуйста, что означают составляющие этих формул!!!Спасибо!

Автор - @Анастасия@
Дата добавления - 12.01.2018 в 19:52
Pelena Дата: Пятница, 12.01.2018, 19:57 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13312
Репутация: 2932 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Файл не приложился


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл не приложился

Автор - Pelena
Дата добавления - 12.01.2018 в 19:57
Nic70y Дата: Пятница, 12.01.2018, 19:57 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4949
Репутация: 1070 ±
Замечаний: 0% ±

Excel 2013
Цитата @Анастасия@, 12.01.2018 в 19:52, в сообщении № 1 ()
Файл прикладываю
где?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Цитата @Анастасия@, 12.01.2018 в 19:52, в сообщении № 1 ()
Файл прикладываю
где?

Автор - Nic70y
Дата добавления - 12.01.2018 в 19:57
bmv98rus Дата: Пятница, 12.01.2018, 20:10 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1417
Репутация: 238 ±
Замечаний: 0% ±

Excel 2013/2016
Цитата @Анастасия@, 12.01.2018 в 19:52, в сообщении № 1 ( писал(а)):
Файл прикладываю
где?
Цитата @Анастасия@, 12.01.2018 в 19:52, в сообщении № 1 ( писал(а)): Файл прикладываюгде?Nic70y

это present continuous, то есть в процессе.
 
Ответить
Сообщение
Цитата @Анастасия@, 12.01.2018 в 19:52, в сообщении № 1 ( писал(а)):
Файл прикладываю
где?
Цитата @Анастасия@, 12.01.2018 в 19:52, в сообщении № 1 ( писал(а)): Файл прикладываюгде?Nic70y

это present continuous, то есть в процессе.

Автор - bmv98rus
Дата добавления - 12.01.2018 в 20:10
@Анастасия@ Дата: Суббота, 13.01.2018, 17:51 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Не могу отправит файл!Выкидывает со страницы(((
 
Ответить
СообщениеНе могу отправит файл!Выкидывает со страницы(((

Автор - @Анастасия@
Дата добавления - 13.01.2018 в 17:51
Che79 Дата: Суббота, 13.01.2018, 17:54 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
@Анастасия@, проверьте по весу - должен быть не более 100 кб. (можно xls(x,m,b) или их в архивах)


Делай нормально и будет нормально!
 
Ответить
Сообщение@Анастасия@, проверьте по весу - должен быть не более 100 кб. (можно xls(x,m,b) или их в архивах)

Автор - Che79
Дата добавления - 13.01.2018 в 17:54
@Анастасия@ Дата: Суббота, 13.01.2018, 18:05 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
по весу 8,61 всего(((
 
Ответить
Сообщениепо весу 8,61 всего(((

Автор - @Анастасия@
Дата добавления - 13.01.2018 в 18:05
@Анастасия@ Дата: Суббота, 13.01.2018, 18:13 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
файл
К сообщению приложен файл: 7399277.xlsx(8.6 Kb)
 
Ответить
Сообщениефайл

Автор - @Анастасия@
Дата добавления - 13.01.2018 в 18:13
@Анастасия@ Дата: Суббота, 13.01.2018, 18:13 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Получилось!!!Помогите, пожалуйста!!!
 
Ответить
СообщениеПолучилось!!!Помогите, пожалуйста!!!

Автор - @Анастасия@
Дата добавления - 13.01.2018 в 18:13
Che79 Дата: Суббота, 13.01.2018, 18:22 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Результаты в зеленых ячейках
Код
=ЕСЛИОШИБКА(--ПСТР(B2;1;ПОИСК("/";B2)-1)+(--ПСТР(B2;ПОИСК("/";B2)+1;99));"")


С правками от Виктора (vikttur) формула чуть короче и, безусловно, корректней
Код
=ЕСЛИОШИБКА(ПСТР(B2;1;ПОИСК("/";B2)-1)+ПСТР(B2;ПОИСК("/";B2)+1;99);"")
К сообщению приложен файл: 7399277_1.xlsx(10.2 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Воскресенье, 14.01.2018, 00:26
 
Ответить
СообщениеРезультаты в зеленых ячейках
Код
=ЕСЛИОШИБКА(--ПСТР(B2;1;ПОИСК("/";B2)-1)+(--ПСТР(B2;ПОИСК("/";B2)+1;99));"")


С правками от Виктора (vikttur) формула чуть короче и, безусловно, корректней
Код
=ЕСЛИОШИБКА(ПСТР(B2;1;ПОИСК("/";B2)-1)+ПСТР(B2;ПОИСК("/";B2)+1;99);"")

Автор - Che79
Дата добавления - 13.01.2018 в 18:22
vikttur Дата: Суббота, 13.01.2018, 18:46 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 2716
Репутация: 477 ±
Замечаний: 0% ±

Che79, скобки и двойные отрицания лишние.

Код
=СУММ(ЕСЛИОШИБКА(ЛЕВБ(ПОДСТАВИТЬ(B2:B6;"/";"     ");5)+ПРАВБ(ПОДСТАВИТЬ(B2:B6;"/";"     ");5);))

Формула массива, вводится нажатием трех клавиш.
К сообщению приложен файл: 1238.xlsx(10.8 Kb)


Сообщение отредактировал vikttur - Суббота, 13.01.2018, 18:52
 
Ответить
СообщениеChe79, скобки и двойные отрицания лишние.

Код
=СУММ(ЕСЛИОШИБКА(ЛЕВБ(ПОДСТАВИТЬ(B2:B6;"/";"     ");5)+ПРАВБ(ПОДСТАВИТЬ(B2:B6;"/";"     ");5);))

Формула массива, вводится нажатием трех клавиш.

Автор - vikttur
Дата добавления - 13.01.2018 в 18:46
Che79 Дата: Суббота, 13.01.2018, 18:50 | Сообщение № 12
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
[offtop]
скобки и двойные отрицаия лишни.
тороплюсь, на носу Старый Новый год :D


Делай нормально и будет нормально!
 
Ответить
Сообщение[offtop]
скобки и двойные отрицаия лишни.
тороплюсь, на носу Старый Новый год :D

Автор - Che79
Дата добавления - 13.01.2018 в 18:50
@Анастасия@ Дата: Суббота, 13.01.2018, 18:53 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо!Но мне нужно,чтобы в желтых ячейках подсчитывался итог)Файл прикладываю.
К сообщению приложен файл: _2.xlsx(8.6 Kb)
 
Ответить
СообщениеСпасибо!Но мне нужно,чтобы в желтых ячейках подсчитывался итог)Файл прикладываю.

Автор - @Анастасия@
Дата добавления - 13.01.2018 в 18:53
Che79 Дата: Суббота, 13.01.2018, 19:12 | Сообщение № 14
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Код
=СУММ(--ПСТР(B2:B6;1;ПОИСК("/";B2:B6)-1))&"/"&СУММ(--ПСТР(B2:B6;ПОИСК("/";B2:B6)+1;99))
- формула массива, НО при условии, что вместо пустых ячеек, будет, например, 0/0
К сообщению приложен файл: _2-1.xlsx(10.0 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
Код
=СУММ(--ПСТР(B2:B6;1;ПОИСК("/";B2:B6)-1))&"/"&СУММ(--ПСТР(B2:B6;ПОИСК("/";B2:B6)+1;99))
- формула массива, НО при условии, что вместо пустых ячеек, будет, например, 0/0

Автор - Che79
Дата добавления - 13.01.2018 в 19:12
@Анастасия@ Дата: Суббота, 13.01.2018, 20:11 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
ОГРОМНОЕ СПАСИБО!!!Вы меня спасли!!! hands
 
Ответить
СообщениеОГРОМНОЕ СПАСИБО!!!Вы меня спасли!!! hands

Автор - @Анастасия@
Дата добавления - 13.01.2018 в 20:11
Кайли Дата: Суббота, 13.01.2018, 20:28 | Сообщение № 16
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Che79, Круто hands


Привет Мир!
 
Ответить
СообщениеChe79, Круто hands

Автор - Кайли
Дата добавления - 13.01.2018 в 20:28
vikttur Дата: Суббота, 13.01.2018, 20:53 | Сообщение № 17
Группа: Друзья
Ранг: Старожил
Сообщений: 2716
Репутация: 477 ±
Замечаний: 0% ±

А сообщение №11?
 
Ответить
СообщениеА сообщение №11?

Автор - vikttur
Дата добавления - 13.01.2018 в 20:53
@Анастасия@ Дата: Суббота, 13.01.2018, 21:01 | Сообщение № 18
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
В сообщении №11 общая сумма(((А мне нужно две разные суммы через "/".Пыталась подкорректировать формулу, но у меня ничего не получилось(((
 
Ответить
СообщениеВ сообщении №11 общая сумма(((А мне нужно две разные суммы через "/".Пыталась подкорректировать формулу, но у меня ничего не получилось(((

Автор - @Анастасия@
Дата добавления - 13.01.2018 в 21:01
@Анастасия@ Дата: Суббота, 13.01.2018, 21:03 | Сообщение № 19
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Если есть еще варианты, будет интересно попробовать их!Может быть можно как-нибудь обходить пустые ячейки?!
 
Ответить
СообщениеЕсли есть еще варианты, будет интересно попробовать их!Может быть можно как-нибудь обходить пустые ячейки?!

Автор - @Анастасия@
Дата добавления - 13.01.2018 в 21:03
vikttur Дата: Суббота, 13.01.2018, 21:14 | Сообщение № 20
Группа: Друзья
Ранг: Старожил
Сообщений: 2716
Репутация: 477 ±
Замечаний: 0% ±

Из сообщения №11, подкорректирована для "через /":
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВБ(ПОДСТАВИТЬ(B2:B6;"/";"     ");5);))&"/"&СУММ(--ПРАВБ(ПОДСТАВИТЬ("/"&B2:B6;"/";"0    ");5))

Формла массива, не забывайте. Пустые ячейки допускаются.


Сообщение отредактировал vikttur - Суббота, 13.01.2018, 21:20
 
Ответить
СообщениеИз сообщения №11, подкорректирована для "через /":
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВБ(ПОДСТАВИТЬ(B2:B6;"/";"     ");5);))&"/"&СУММ(--ПРАВБ(ПОДСТАВИТЬ("/"&B2:B6;"/";"0    ");5))

Формла массива, не забывайте. Пустые ячейки допускаются.

Автор - vikttur
Дата добавления - 13.01.2018 в 21:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сумма значений до и после слэш (Формулы/Formulas)
  • Страница 1 из 2
  • 1
  • 2
  • »
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!