Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Копирование ячеек при заполнении другой ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование ячеек при заполнении другой ячейки (Формулы/Formulas)
Копирование ячеек при заполнении другой ячейки
Dmitry1992_92 Дата: Вторник, 06.02.2018, 14:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуете! Имеются две таблицы, они находятся на разных страницах (лист 1 и лист 2). Хотелось бы сделать так: допустим, в таблице на листе 1, я напишу в столбце "кол-во" в ячейке B2 цифру 1 и тогда скопируются ячейки А2 B2 и C2 и вставятся в таблицу, которая находится на второй странице. Т.е. хочется сделать копирование определённых ячеек только тогда, когда что-нибудь напишут в столбце "кол-во".
К сообщению приложен файл: 1361828.xlsx(8.9 Kb)
 
Ответить
СообщениеЗдравствуете! Имеются две таблицы, они находятся на разных страницах (лист 1 и лист 2). Хотелось бы сделать так: допустим, в таблице на листе 1, я напишу в столбце "кол-во" в ячейке B2 цифру 1 и тогда скопируются ячейки А2 B2 и C2 и вставятся в таблицу, которая находится на второй странице. Т.е. хочется сделать копирование определённых ячеек только тогда, когда что-нибудь напишут в столбце "кол-во".

Автор - Dmitry1992_92
Дата добавления - 06.02.2018 в 14:30
китин Дата: Вторник, 06.02.2018, 14:44 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4818
Репутация: 771 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Здравствуйте!!! формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$2:A$52;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$C$2:$C$52=1;СТРОКА(Лист1!$C$2:$C$52)-1);СТРОКА(A1)));"")
К сообщению приложен файл: _1361828.xlsx(12.2 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеЗдравствуйте!!! формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$2:A$52;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$C$2:$C$52=1;СТРОКА(Лист1!$C$2:$C$52)-1);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 06.02.2018 в 14:44
Manyasha Дата: Вторник, 06.02.2018, 14:44 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 2138
Репутация: 869 ±
Замечаний: 0% ±

Excel 2010, 2016
Dmitry1992_92, здравствуйте, так подойдет?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$2:A$10;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$B$2:$B$10>0;СТРОКА($B$2:$B$10)-1;"");СТРОКА(A1)));"")

Формула массива (вводится сочетанием клавиш ctrl+shift+enter)

[offtop] Игорь, beer [/offtop]
К сообщению приложен файл: 1361828-1.xlsx(10.1 Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804


Сообщение отредактировал Manyasha - Вторник, 06.02.2018, 14:46
 
Ответить
СообщениеDmitry1992_92, здравствуйте, так подойдет?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$2:A$10;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$B$2:$B$10>0;СТРОКА($B$2:$B$10)-1;"");СТРОКА(A1)));"")

Формула массива (вводится сочетанием клавиш ctrl+shift+enter)

[offtop] Игорь, beer [/offtop]

Автор - Manyasha
Дата добавления - 06.02.2018 в 14:44
китин Дата: Вторник, 06.02.2018, 14:50 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4818
Репутация: 771 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]
Марина у кого говорят мысли сходятся? :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]
Марина у кого говорят мысли сходятся? :D

Автор - китин
Дата добавления - 06.02.2018 в 14:50
Dmitry1992_92 Дата: Вторник, 06.02.2018, 14:52 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо всем!
 
Ответить
СообщениеСпасибо всем!

Автор - Dmitry1992_92
Дата добавления - 06.02.2018 в 14:52
sboy Дата: Вторник, 06.02.2018, 14:59 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1748
Репутация: 497 ±
Замечаний: 0% ±

Excel 2010
[offtop]Когда Вы уже закончите их клонопировать )
К сообщению приложен файл: 1343480.jpg(62.0 Kb)
 
Ответить
Сообщение[offtop]Когда Вы уже закончите их клонопировать )

Автор - sboy
Дата добавления - 06.02.2018 в 14:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование ячеек при заполнении другой ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!