Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для подсчета данных по 3 колонкам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для подсчета данных по 3 колонкам (Формулы/Formulas)
Формула для подсчета данных по 3 колонкам
Skittish Дата: Вторник, 13.02.2018, 12:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день. Раньше сталкивалась с подобной проблемой нужно было в зависимости от того что в ячейке есть (1/9 1/20 1/24), сделать действие деление и разнести по 3 колонкам.
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(ЛЕВБ(D$1;ПОИСК("/";D$1)+2));$B3));$C3/--ПСТР(D$1&" ";ПОИСК("/";D$1&" ")+1;2);"")

Такая формула для 1го условия
Только не вижу где там условие с 1/9 чтоб можно было что поменять(
И можно ли в первую колонку добавить условие 1/2 и 1/12, чтоб тоже соответственно делилось на 2 или 12 и итог вносился в туже колонку что и 1/9
К сообщению приложен файл: 12.xlsx(9Kb)


Сообщение отредактировал Skittish - Вторник, 13.02.2018, 12:18
 
Ответить
СообщениеДобрый день. Раньше сталкивалась с подобной проблемой нужно было в зависимости от того что в ячейке есть (1/9 1/20 1/24), сделать действие деление и разнести по 3 колонкам.
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(ЛЕВБ(D$1;ПОИСК("/";D$1)+2));$B3));$C3/--ПСТР(D$1&" ";ПОИСК("/";D$1&" ")+1;2);"")

Такая формула для 1го условия
Только не вижу где там условие с 1/9 чтоб можно было что поменять(
И можно ли в первую колонку добавить условие 1/2 и 1/12, чтоб тоже соответственно делилось на 2 или 12 и итог вносился в туже колонку что и 1/9

Автор - Skittish
Дата добавления - 13.02.2018 в 12:18
bmv98rus Дата: Вторник, 13.02.2018, 13:46 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1131
Репутация: 188 ±
Замечаний: 0% ±

Excel 2013/2016
для D5
Код
=IF(ISNUMBER(SEARCH(D$1;$B5));$C5/MID(D$1;FIND("/";D$1)+1;20);"")

это
Код
=MID(D$1;FIND("/";D$1)+1;20)
находит заветный знаменатель в D1
Если вам надо числитель выбрать другим, отличным от 9,20,24 проще его вынести в отдельную строку или лепить конструкцию для соответствия
Код
=IFERROR((SEARCH(D$1;$B5)>0)*$C5/LOOKUP(D$1;D1:F1;{2;3;4});"")


Сообщение отредактировал bmv98rus - Вторник, 13.02.2018, 13:55
 
Ответить
Сообщениедля D5
Код
=IF(ISNUMBER(SEARCH(D$1;$B5));$C5/MID(D$1;FIND("/";D$1)+1;20);"")

это
Код
=MID(D$1;FIND("/";D$1)+1;20)
находит заветный знаменатель в D1
Если вам надо числитель выбрать другим, отличным от 9,20,24 проще его вынести в отдельную строку или лепить конструкцию для соответствия
Код
=IFERROR((SEARCH(D$1;$B5)>0)*$C5/LOOKUP(D$1;D1:F1;{2;3;4});"")

Автор - bmv98rus
Дата добавления - 13.02.2018 в 13:46
Skittish Дата: Вторник, 13.02.2018, 16:28 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
а если в другую колонку как сделать формулу для 1/2, а то он у меня чет и 1/20 и 1/24 считает(
 
Ответить
Сообщениеа если в другую колонку как сделать формулу для 1/2, а то он у меня чет и 1/20 и 1/24 считает(

Автор - Skittish
Дата добавления - 13.02.2018 в 16:28
bmv98rus Дата: Вторник, 13.02.2018, 17:42 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1131
Репутация: 188 ±
Замечаний: 0% ±

Excel 2013/2016
и 1/20 и 1/24 считает(

Покажите что есть и что нужно в файле.
 
Ответить
Сообщение
и 1/20 и 1/24 считает(

Покажите что есть и что нужно в файле.

Автор - bmv98rus
Дата добавления - 13.02.2018 в 17:42
Skittish Дата: Вторник, 13.02.2018, 17:50 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
вот в колонке красной дожно делить на 2 только ту строчку где 1/2, а оно считает и где 1/20 и 1/24
К сообщению приложен файл: _223.xls(27Kb)
 
Ответить
Сообщениевот в колонке красной дожно делить на 2 только ту строчку где 1/2, а оно считает и где 1/20 и 1/24

Автор - Skittish
Дата добавления - 13.02.2018 в 17:50
bmv98rus Дата: Вторник, 13.02.2018, 18:04 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1131
Репутация: 188 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=IF(ISNUMBER(SEARCH(TRIM(LEFTB(H$1;SEARCH("/";H$1)+2))&" ";$B9&" "));$C9/--MID(H$1&" ";SEARCH("/";H$1&" ")+1;2);"")
 
Ответить
Сообщение
Код
=IF(ISNUMBER(SEARCH(TRIM(LEFTB(H$1;SEARCH("/";H$1)+2))&" ";$B9&" "));$C9/--MID(H$1&" ";SEARCH("/";H$1&" ")+1;2);"")

Автор - bmv98rus
Дата добавления - 13.02.2018 в 18:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для подсчета данных по 3 колонкам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!