Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автодобавление данных при изменение названия месяца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автодобавление данных при изменение названия месяца (Формулы/Formulas)
Автодобавление данных при изменение названия месяца
Marinus1986 Дата: Вторник, 27.02.2018, 17:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток!
Есть два листа. На первом по месяцам и отделам расписаны транспортные компании. На второй лист нужно собрать инфу за тот или иной месяц (ежемесячный отчет ТК по отделам).
Например изменяя ячейку А1 на листе1(месяц), чтобы вставлялись данные по отделам (ОРО, ОТТ, ОДС, ОИО) и по ТК за указанный месяц в ячейке А1.
Надеюсь понятно изъяснилась.
Благодарю за помощь!
К сообщению приложен файл: 9338240.xlsx(19.8 Kb)
 
Ответить
СообщениеДоброго времени суток!
Есть два листа. На первом по месяцам и отделам расписаны транспортные компании. На второй лист нужно собрать инфу за тот или иной месяц (ежемесячный отчет ТК по отделам).
Например изменяя ячейку А1 на листе1(месяц), чтобы вставлялись данные по отделам (ОРО, ОТТ, ОДС, ОИО) и по ТК за указанный месяц в ячейке А1.
Надеюсь понятно изъяснилась.
Благодарю за помощь!

Автор - Marinus1986
Дата добавления - 27.02.2018 в 17:33
sboy Дата: Вторник, 27.02.2018, 17:47 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2063
Репутация: 593 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
можно прописать через именованные диапазоны сразу в формулах
Код
=ИНДЕКС(ОТТ;ПОИСКПОЗ($A2;ИНДЕКС(ОТТ;;1););ПОИСКПОЗ($A$1;ИНДЕКС(ОТТ;1;);))

или, чтобы "протягивалась" использовать волатильную ДВССЫЛ()
Код
=ИНДЕКС(ДВССЫЛ(C$1&"");ПОИСКПОЗ($A2;ИНДЕКС(ДВССЫЛ(C$1&"");;1););ПОИСКПОЗ($A$1;ИНДЕКС(ДВССЫЛ(C$1&"");1;);))
К сообщению приложен файл: 9177936.xlsx(21.2 Kb)
 
Ответить
СообщениеДобрый день.
можно прописать через именованные диапазоны сразу в формулах
Код
=ИНДЕКС(ОТТ;ПОИСКПОЗ($A2;ИНДЕКС(ОТТ;;1););ПОИСКПОЗ($A$1;ИНДЕКС(ОТТ;1;);))

или, чтобы "протягивалась" использовать волатильную ДВССЫЛ()
Код
=ИНДЕКС(ДВССЫЛ(C$1&"");ПОИСКПОЗ($A2;ИНДЕКС(ДВССЫЛ(C$1&"");;1););ПОИСКПОЗ($A$1;ИНДЕКС(ДВССЫЛ(C$1&"");1;);))

Автор - sboy
Дата добавления - 27.02.2018 в 17:47
Che79 Дата: Вторник, 27.02.2018, 18:11 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
[offtop] Эх, была бы у Вас другая организация исходных данных, можно было бы сводную + срезы (в Excel 2010 они есть). Не по примеру, просто, как вариант реализации (см. файл)
К сообщению приложен файл: 9338240_1.xlsx(25.6 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение[offtop] Эх, была бы у Вас другая организация исходных данных, можно было бы сводную + срезы (в Excel 2010 они есть). Не по примеру, просто, как вариант реализации (см. файл)

Автор - Che79
Дата добавления - 27.02.2018 в 18:11
Marinus1986 Дата: Среда, 28.02.2018, 08:57 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, при изменении названия месяца формулы перестают работать((((
там можно и на 12 месяцев через связь сделать 12 табличек. Но цель сделать одну табличку с возможностью отображения в ней любого месяца.
(простите если не правильно объясняюсь)
 
Ответить
Сообщениеsboy, при изменении названия месяца формулы перестают работать((((
там можно и на 12 месяцев через связь сделать 12 табличек. Но цель сделать одну табличку с возможностью отображения в ней любого месяца.
(простите если не правильно объясняюсь)

Автор - Marinus1986
Дата добавления - 28.02.2018 в 08:57
Marinus1986 Дата: Среда, 28.02.2018, 08:58 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Che79, идея не плохая, но мне не удобна для отчета, спасибо))
 
Ответить
СообщениеChe79, идея не плохая, но мне не удобна для отчета, спасибо))

Автор - Marinus1986
Дата добавления - 28.02.2018 в 08:58
sboy Дата: Среда, 28.02.2018, 09:56 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2063
Репутация: 593 ±
Замечаний: 0% ±

Excel 2010
при изменении названия месяца формулы перестают работать((((

не верю(с)
в файле из моего сообщения все работает (просто там в табличках данных только на январь-февраль, остальное нули)
покажите в файле, где не работает
 
Ответить
Сообщение
при изменении названия месяца формулы перестают работать((((

не верю(с)
в файле из моего сообщения все работает (просто там в табличках данных только на январь-февраль, остальное нули)
покажите в файле, где не работает

Автор - sboy
Дата добавления - 28.02.2018 в 09:56
Marinus1986 Дата: Среда, 28.02.2018, 09:56 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Вот что помогло, использовала формулы чуть по другому.

Код
=ИНДЕКС(Лист2!$B$2:$M$36;ПОИСКПОЗ(Лист1!A2;Лист2!$A$2:$A$36;0);ПОИСКПОЗ(Лист1!$A$1;Лист2!$B$1:$M$1;0))
К сообщению приложен файл: 8870536.xlsx(20.9 Kb)
 
Ответить
СообщениеВот что помогло, использовала формулы чуть по другому.

Код
=ИНДЕКС(Лист2!$B$2:$M$36;ПОИСКПОЗ(Лист1!A2;Лист2!$A$2:$A$36;0);ПОИСКПОЗ(Лист1!$A$1;Лист2!$B$1:$M$1;0))

Автор - Marinus1986
Дата добавления - 28.02.2018 в 09:56
sboy Дата: Среда, 28.02.2018, 10:18 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2063
Репутация: 593 ±
Замечаний: 0% ±

Excel 2010
ну дык я же писал Вам
через именованные диапазоны

а в Вашем файле они исчезли) (посмотреть можно вкладка Формулы - Диспетчер имен) поэтому и не работали
 
Ответить
Сообщениену дык я же писал Вам
через именованные диапазоны

а в Вашем файле они исчезли) (посмотреть можно вкладка Формулы - Диспетчер имен) поэтому и не работали

Автор - sboy
Дата добавления - 28.02.2018 в 10:18
Marinus1986 Дата: Среда, 28.02.2018, 12:17 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, ааа, спасибо!!!!!!! очень помогли!!! hands hands hands


Сообщение отредактировал Marinus1986 - Среда, 28.02.2018, 12:18
 
Ответить
Сообщениеsboy, ааа, спасибо!!!!!!! очень помогли!!! hands hands hands

Автор - Marinus1986
Дата добавления - 28.02.2018 в 12:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автодобавление данных при изменение названия месяца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!