Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сделать массив чисел из диапазонов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сделать массив чисел из диапазонов (Формулы/Formulas)
Сделать массив чисел из диапазонов
JohnyCoaly Дата: Среда, 28.02.2018, 08:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Уважаемые форумчане, доброго дня.
Подскажите, пожалуйста, как можно сделать массив чисел из диапазона?
Есть диапазон чисел в двух столбцах. В первом столбце начальный номер, во втором - конечный.
Задача: рядом с ними сделать общий массив, в котором будет все числа заданного диапазона.

Пример во вложении.
Заранее спасибо за помощь.
К сообщению приложен файл: 1242949.xlsx(8.3 Kb)
 
Ответить
СообщениеУважаемые форумчане, доброго дня.
Подскажите, пожалуйста, как можно сделать массив чисел из диапазона?
Есть диапазон чисел в двух столбцах. В первом столбце начальный номер, во втором - конечный.
Задача: рядом с ними сделать общий массив, в котором будет все числа заданного диапазона.

Пример во вложении.
Заранее спасибо за помощь.

Автор - JohnyCoaly
Дата добавления - 28.02.2018 в 08:39
Karataev Дата: Среда, 28.02.2018, 09:05 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1249
Репутация: 481 ±
Замечаний: 0% ±

Excel


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288


Сообщение отредактировал Karataev - Среда, 28.02.2018, 09:13
 
Ответить
Сообщение

Автор - Karataev
Дата добавления - 28.02.2018 в 09:05
JohnyCoaly Дата: Среда, 28.02.2018, 11:14 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо. Работает.
 
Ответить
СообщениеСпасибо. Работает.

Автор - JohnyCoaly
Дата добавления - 28.02.2018 в 11:14
Светлый Дата: Среда, 28.02.2018, 13:30 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 612
Репутация: 165 ±
Замечаний: 0% ±

Excel 2010
Можно массивной формулой, начиная со второго значения:
Код
=МИН(ЕСЛИ((B$2:B$9<=G2+СТОЛБЕЦ(A:ZZ))*(C$2:C$9>=G2+СТОЛБЕЦ(A:ZZ));G2+СТОЛБЕЦ(A:ZZ)))
К сообщению приложен файл: 1242949_1.xlsx(9.5 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМожно массивной формулой, начиная со второго значения:
Код
=МИН(ЕСЛИ((B$2:B$9<=G2+СТОЛБЕЦ(A:ZZ))*(C$2:C$9>=G2+СТОЛБЕЦ(A:ZZ));G2+СТОЛБЕЦ(A:ZZ)))

Автор - Светлый
Дата добавления - 28.02.2018 в 13:30
krosav4ig Дата: Среда, 28.02.2018, 16:20 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1647
Репутация: 687 ±
Замечаний: 0% ±

Excel 2007,2010,2013
До кучи, массивная монстроформула
Код
=ЕСЛИ(СЧЁТЕСЛИ(F1:F$1;МАКС(C:C));"";МАКС(Ч(F1)+1;ПРОСМОТР(СТРОКА(F1)-1;МУМНОЖ((СТРОКА(B$1:B$5)>=ТРАНСП(СТРОКА(B$1:B$5)))*ТРАНСП(ЕСЛИОШИБКА(C$1:C$5-B$1:B$5+1;));СТРОКА(B$1:B$5)^0);$B$2:$B$3)))
К сообщению приложен файл: 9492359.xlsx(9.2 Kb)


(_)Õvõ(_)
 
Ответить
СообщениеДо кучи, массивная монстроформула
Код
=ЕСЛИ(СЧЁТЕСЛИ(F1:F$1;МАКС(C:C));"";МАКС(Ч(F1)+1;ПРОСМОТР(СТРОКА(F1)-1;МУМНОЖ((СТРОКА(B$1:B$5)>=ТРАНСП(СТРОКА(B$1:B$5)))*ТРАНСП(ЕСЛИОШИБКА(C$1:C$5-B$1:B$5+1;));СТРОКА(B$1:B$5)^0);$B$2:$B$3)))

Автор - krosav4ig
Дата добавления - 28.02.2018 в 16:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сделать массив чисел из диапазонов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!