Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск совпадений с определением значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск совпадений с определением значения (Формулы/Formulas)
Поиск совпадений с определением значения
Silence Дата: Среда, 28.02.2018, 17:49 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
Добрый вечер, прошу помочь в написании формулы! В файле нужно провести поиск соответствия значений по столбцам "КОД" на листе 1 с листом 2. В случае соответствия в лист 1 столбец "ЦЕНА" проставить значение цены из листа 2.
К сообщению приложен файл: 6828582.xlsx(14.1 Kb)
 
Ответить
СообщениеДобрый вечер, прошу помочь в написании формулы! В файле нужно провести поиск соответствия значений по столбцам "КОД" на листе 1 с листом 2. В случае соответствия в лист 1 столбец "ЦЕНА" проставить значение цены из листа 2.

Автор - Silence
Дата добавления - 28.02.2018 в 17:49
Che79 Дата: Среда, 28.02.2018, 18:28 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте.
Не уверен, что правильно понял.
Может, так? желтые ячейки
Код
=ЕСЛИОШИБКА(ВПР(B2;'2 лист'!B:C;2;);)
Или так? оранжевые ячейки
Код
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК(ПСТР($A2;3;99);'2 лист'!$A$2:$A$65)));ВПР(ПСТР($A2;3;99);'2 лист'!$A$2:$C$64;3;);"")
. Вторая формула массивная, ввод Ctrl+Shift+Enter
К сообщению приложен файл: 6828582_1.xlsx(14.7 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте.
Не уверен, что правильно понял.
Может, так? желтые ячейки
Код
=ЕСЛИОШИБКА(ВПР(B2;'2 лист'!B:C;2;);)
Или так? оранжевые ячейки
Код
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК(ПСТР($A2;3;99);'2 лист'!$A$2:$A$65)));ВПР(ПСТР($A2;3;99);'2 лист'!$A$2:$C$64;3;);"")
. Вторая формула массивная, ввод Ctrl+Shift+Enter

Автор - Che79
Дата добавления - 28.02.2018 в 18:28
Karataev Дата: Среда, 28.02.2018, 20:03 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1268
Репутация: 489 ±
Замечаний: 0% ±

Excel
Формула для "C2", точное совпадение:
Код
=ВПР(B2;'2 лист'!B:C;2;0)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288


Сообщение отредактировал Karataev - Среда, 28.02.2018, 20:03
 
Ответить
СообщениеФормула для "C2", точное совпадение:
Код
=ВПР(B2;'2 лист'!B:C;2;0)

Автор - Karataev
Дата добавления - 28.02.2018 в 20:03
Silence Дата: Четверг, 01.03.2018, 10:21 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
Излишнее цитирование удалено
Спасибо!
На первый взгляд работают 2 варианта. Добавлю данные и буду проверять.


Сообщение отредактировал Pelena - Четверг, 01.03.2018, 14:16
 
Ответить
СообщениеИзлишнее цитирование удалено
Спасибо!
На первый взгляд работают 2 варианта. Добавлю данные и буду проверять.

Автор - Silence
Дата добавления - 01.03.2018 в 10:21
Silence Дата: Четверг, 01.03.2018, 11:36 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
Излишнее цитирование удалено
Karataev,

Работает, спасибо!


Сообщение отредактировал Pelena - Четверг, 01.03.2018, 14:17
 
Ответить
СообщениеИзлишнее цитирование удалено
Karataev,

Работает, спасибо!

Автор - Silence
Дата добавления - 01.03.2018 в 11:36
Silence Дата: Понедельник, 05.03.2018, 17:01 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
В продолжении темы, прошу помочь с формулой. Необходимо найти наименьшее значение в столбцах "Оператор 1,2,3" и указать в столбце "Выбор Оператора" наименование Оператора.
К сообщению приложен файл: 7172773.xlsx(9.7 Kb)


Сообщение отредактировал Silence - Понедельник, 05.03.2018, 17:03
 
Ответить
СообщениеВ продолжении темы, прошу помочь с формулой. Необходимо найти наименьшее значение в столбцах "Оператор 1,2,3" и указать в столбце "Выбор Оператора" наименование Оператора.

Автор - Silence
Дата добавления - 05.03.2018 в 17:01
Che79 Дата: Понедельник, 05.03.2018, 17:06 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
В продолжении темы
это не продолжении темы, это абсолютно другой вопрос. Создайте новую тему согласно Правилам форума. А ответ на вопрос давно готов.


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 05.03.2018, 17:09
 
Ответить
Сообщение
В продолжении темы
это не продолжении темы, это абсолютно другой вопрос. Создайте новую тему согласно Правилам форума. А ответ на вопрос давно готов.

Автор - Che79
Дата добавления - 05.03.2018 в 17:06
Silence Дата: Понедельник, 05.03.2018, 17:16 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
это не продолжении темы, это абсолютно другой вопрос. Создайте новую тему согласно Правилам форума. А ответ на вопрос давно готов.

Создал http://www.excelworld.ru/forum/2-37566-1
 
Ответить
Сообщение
это не продолжении темы, это абсолютно другой вопрос. Создайте новую тему согласно Правилам форума. А ответ на вопрос давно готов.

Создал http://www.excelworld.ru/forum/2-37566-1

Автор - Silence
Дата добавления - 05.03.2018 в 17:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск совпадений с определением значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!