Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск наименьшего значения с указанием наименования столбца. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наименьшего значения с указанием наименования столбца. (Формулы/Formulas)
Поиск наименьшего значения с указанием наименования столбца.
Silence Дата: Понедельник, 05.03.2018, 17:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
Прошу помочь с формулой. Необходимо найти наименьшее значение в столбцах "Оператор 1,2,3" и указать в столбце "Выбор Оператора" наименование Оператора.
К сообщению приложен файл: 4499589.xlsx(9.7 Kb)
 
Ответить
СообщениеПрошу помочь с формулой. Необходимо найти наименьшее значение в столбцах "Оператор 1,2,3" и указать в столбце "Выбор Оператора" наименование Оператора.

Автор - Silence
Дата добавления - 05.03.2018 в 17:15
Che79 Дата: Понедельник, 05.03.2018, 17:17 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1277
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте.
Три формулы на выбор во вложении
ИНДЕКС+ПОИСКПОЗ, ГПР, ПРОСМОТР...
К сообщению приложен файл: 7172773_1.xlsx(10.3 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте.
Три формулы на выбор во вложении
ИНДЕКС+ПОИСКПОЗ, ГПР, ПРОСМОТР...

Автор - Che79
Дата добавления - 05.03.2018 в 17:17
Silence Дата: Понедельник, 05.03.2018, 17:22 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
ИНДЕКС+ПОИСКПОЗ, ГПР, ПРОСМОТР..

Фантастика, спасибо!
 
Ответить
Сообщение
ИНДЕКС+ПОИСКПОЗ, ГПР, ПРОСМОТР..

Фантастика, спасибо!

Автор - Silence
Дата добавления - 05.03.2018 в 17:22
Silence Дата: Понедельник, 05.03.2018, 17:38 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
Che79!
Подскажите, а если в одном их трёх столбцов значение #Н/Д из перекрёстной формулы, как прописать формулу, чтобы данные учитывались из других столбцов.
 
Ответить
СообщениеChe79!
Подскажите, а если в одном их трёх столбцов значение #Н/Д из перекрёстной формулы, как прописать формулу, чтобы данные учитывались из других столбцов.

Автор - Silence
Дата добавления - 05.03.2018 в 17:38
Che79 Дата: Понедельник, 05.03.2018, 17:42 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1277
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Silence, покажите файл, желательно, максимально приближенный к реальному.


Делай нормально и будет нормально!
 
Ответить
СообщениеSilence, покажите файл, желательно, максимально приближенный к реальному.

Автор - Che79
Дата добавления - 05.03.2018 в 17:42
Silence Дата: Понедельник, 05.03.2018, 17:51 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
0,99 #Н/Д 1,43 вот выбор формулы #Н/Д, формула должна выбрать из 0,99 и 1,43. Н/Д убрать из таблицы нельзя. Извините файл большой, вложить не получается.
 
Ответить
Сообщение0,99 #Н/Д 1,43 вот выбор формулы #Н/Д, формула должна выбрать из 0,99 и 1,43. Н/Д убрать из таблицы нельзя. Извините файл большой, вложить не получается.

Автор - Silence
Дата добавления - 05.03.2018 в 17:51
Che79 Дата: Понедельник, 05.03.2018, 17:55 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1277
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Как вариант, в перекрестной, как Вы говорите, формуле избавьтесь от ошибки с помощью ЕСЛИОШИБКА(). Аргументом "значение_если_ошибка" попробуйте подставить любой текст.
См. файл.
К сообщению приложен файл: 0328810.xlsx(10.4 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 05.03.2018, 17:57
 
Ответить
СообщениеКак вариант, в перекрестной, как Вы говорите, формуле избавьтесь от ошибки с помощью ЕСЛИОШИБКА(). Аргументом "значение_если_ошибка" попробуйте подставить любой текст.
См. файл.

Автор - Che79
Дата добавления - 05.03.2018 в 17:55
Che79 Дата: Понедельник, 05.03.2018, 18:09 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1277
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Или просто встройте проверку на наличие ошибки прямо в формулу. Например, так
Код
=ИНДЕКС(C1:E1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(C2:E2;9^9));C2:E2;))
формула массива (ввод Ctrl+Shift+Enter)


Делай нормально и будет нормально!
 
Ответить
СообщениеИли просто встройте проверку на наличие ошибки прямо в формулу. Например, так
Код
=ИНДЕКС(C1:E1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(C2:E2;9^9));C2:E2;))
формула массива (ввод Ctrl+Shift+Enter)

Автор - Che79
Дата добавления - 05.03.2018 в 18:09
Silence Дата: Вторник, 06.03.2018, 11:38 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
=ИНДЕКС(C1:E1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(C2:E2;9^9));C2:E2;))

Спасибо, работает)
 
Ответить
Сообщение
=ИНДЕКС(C1:E1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(C2:E2;9^9));C2:E2;))

Спасибо, работает)

Автор - Silence
Дата добавления - 06.03.2018 в 11:38
Silence Дата: Вторник, 06.03.2018, 11:59 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
Che79, подскажите, есть ошибка, формула
Код
=ИНДЕКС(C1:E1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(C2:E2;9^9));C2:E2;))
не учитывает значение столбца D, берёт наименьшее из столбцов С и Е.
Вот оригинал
Код
=ИНДЕКС($D$1:$F$1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(D11904:F11904;9^9));D11904:F11904;))


Сообщение отредактировал Silence - Вторник, 06.03.2018, 12:02
 
Ответить
СообщениеChe79, подскажите, есть ошибка, формула
Код
=ИНДЕКС(C1:E1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(C2:E2;9^9));C2:E2;))
не учитывает значение столбца D, берёт наименьшее из столбцов С и Е.
Вот оригинал
Код
=ИНДЕКС($D$1:$F$1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(D11904:F11904;9^9));D11904:F11904;))

Автор - Silence
Дата добавления - 06.03.2018 в 11:59
Silence Дата: Вторник, 06.03.2018, 12:06 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
9^9 возможно здесь нужно указать весь диапазон всех строк?))
 
Ответить
Сообщение9^9 возможно здесь нужно указать весь диапазон всех строк?))

Автор - Silence
Дата добавления - 06.03.2018 в 12:06
китин Дата: Вторник, 06.03.2018, 12:18 | Сообщение № 12
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5142
Репутация: 815 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Silence, оформите формулы тэгами. посмотрите как у Che79, красиво все смотрится, и перевести можно формулу
Как оформлять сообщения?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 06.03.2018, 12:20
 
Ответить
СообщениеSilence, оформите формулы тэгами. посмотрите как у Che79, красиво все смотрится, и перевести можно формулу
Как оформлять сообщения?

Автор - китин
Дата добавления - 06.03.2018 в 12:18
Che79 Дата: Вторник, 06.03.2018, 12:21 | Сообщение № 13
Группа: Проверенные
Ранг: Старожил
Сообщений: 1277
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Silence, оформите формулы в своем сообщении #11 cпомощью тэгов (кнопка fx в режиме правки поста). Без файла-примера что-то конкретное не берусь сказать, учитывая, что сначала вы пишите про формулу
Спасибо, работает
, а потом практически сразу
есть ошибка
. Проверьте диапазоны, массивный ввод (Ctrl+Shift+Enter)
В моем примере все работает корректно
К сообщению приложен файл: 7172773_2.xlsx(10.3 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеSilence, оформите формулы в своем сообщении #11 cпомощью тэгов (кнопка fx в режиме правки поста). Без файла-примера что-то конкретное не берусь сказать, учитывая, что сначала вы пишите про формулу
Спасибо, работает
, а потом практически сразу
есть ошибка
. Проверьте диапазоны, массивный ввод (Ctrl+Shift+Enter)
В моем примере все работает корректно

Автор - Che79
Дата добавления - 06.03.2018 в 12:21
Silence Дата: Вторник, 06.03.2018, 12:45 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
Извините, ошибку нашёл.
 
Ответить
СообщениеИзвините, ошибку нашёл.

Автор - Silence
Дата добавления - 06.03.2018 в 12:45
Silence Дата: Вторник, 06.03.2018, 15:29 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007 RUS
Che79, меня терзают размышления, а зачем в формуле
Код
=ИНДЕКС(C1:E1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(C2:E2;9^9));C2:E2;))
используется 9 в 9 степени?
 
Ответить
СообщениеChe79, меня терзают размышления, а зачем в формуле
Код
=ИНДЕКС(C1:E1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(C2:E2;9^9));C2:E2;))
используется 9 в 9 степени?

Автор - Silence
Дата добавления - 06.03.2018 в 15:29
Che79 Дата: Вторник, 06.03.2018, 15:36 | Сообщение № 16
Группа: Проверенные
Ранг: Старожил
Сообщений: 1277
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Зачем так терзаться :) 9^9 -это самая краткая форма записи заведомо большого числа в Excel. Здесь используется только для того, чтобы все большие числа, которые могут быть использованы в диапазоне, были изначально меньше и уже из них выбирать минимальное.
Что называется, почувствуйте разницу. Если в обработчик ошибки поставить 0 (ноль)
Код
=ИНДЕКС(C1:E1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(C2:E2;));C2:E2;))
то во всех случаях 0 и будет минимальным значением в диапазоне среди неотрицательных чисел.


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Вторник, 06.03.2018, 16:16
 
Ответить
СообщениеЗачем так терзаться :) 9^9 -это самая краткая форма записи заведомо большого числа в Excel. Здесь используется только для того, чтобы все большие числа, которые могут быть использованы в диапазоне, были изначально меньше и уже из них выбирать минимальное.
Что называется, почувствуйте разницу. Если в обработчик ошибки поставить 0 (ноль)
Код
=ИНДЕКС(C1:E1;ПОИСКПОЗ(МИН(ЕСЛИОШИБКА(C2:E2;));C2:E2;))
то во всех случаях 0 и будет минимальным значением в диапазоне среди неотрицательных чисел.

Автор - Che79
Дата добавления - 06.03.2018 в 15:36
sboy Дата: Вторник, 06.03.2018, 15:47 | Сообщение № 17
Группа: Друзья
Ранг: Старожил
Сообщений: 2224
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
почти такой же вариант (обычная)
Код
=ИНДЕКС($C$1:$E$1;ПОИСКПОЗ(АГРЕГАТ(5;6;C2:E2);C2:E2;))
К сообщению приложен файл: 6583128.xlsx(10.3 Kb)
 
Ответить
Сообщениепочти такой же вариант (обычная)
Код
=ИНДЕКС($C$1:$E$1;ПОИСКПОЗ(АГРЕГАТ(5;6;C2:E2);C2:E2;))

Автор - sboy
Дата добавления - 06.03.2018 в 15:47
Che79 Дата: Вторник, 06.03.2018, 15:51 | Сообщение № 18
Группа: Проверенные
Ранг: Старожил
Сообщений: 1277
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
sboy, у ТС'а, похоже, Excel 2007, там АГРЕГАТ() еще не живёт.


Делай нормально и будет нормально!
 
Ответить
Сообщениеsboy, у ТС'а, похоже, Excel 2007, там АГРЕГАТ() еще не живёт.

Автор - Che79
Дата добавления - 06.03.2018 в 15:51
sboy Дата: Вторник, 06.03.2018, 16:13 | Сообщение № 19
Группа: Друзья
Ранг: Старожил
Сообщений: 2224
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
Che79, точно, не посмотрел версию.
 
Ответить
СообщениеChe79, точно, не посмотрел версию.

Автор - sboy
Дата добавления - 06.03.2018 в 16:13
Che79 Дата: Вторник, 06.03.2018, 16:45 | Сообщение № 20
Группа: Проверенные
Ранг: Старожил
Сообщений: 1277
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Silence, вот ещё для коллекции. Массивная
Код
=ВПР(МИН(ЕСЛИОШИБКА(C2:E2;"ьыъ"));ТРАНСП(ЕСЛИ({1:0};C2:E2;$C$1:$E$1));2;)
К сообщению приложен файл: 6872940.xlsx(10.7 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеSilence, вот ещё для коллекции. Массивная
Код
=ВПР(МИН(ЕСЛИОШИБКА(C2:E2;"ьыъ"));ТРАНСП(ЕСЛИ({1:0};C2:E2;$C$1:$E$1));2;)

Автор - Che79
Дата добавления - 06.03.2018 в 16:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наименьшего значения с указанием наименования столбца. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!