Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверка по послед дате, и копировать цену - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка по послед дате, и копировать цену (Формулы/Formulas)
Проверка по послед дате, и копировать цену
Middy Дата: Среда, 28.02.2018, 17:55 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем доброго времени суток!

Подскажите, пож-та, нужно придумать формулу(или может быть макрос написать), чтобы сначала проверяла последнюю дату по строке 2, после того как последняя дата известна(например 28.02.2018) нужно по столбцу (где эта дата стоит) и строке(к которой относится этот артикул) проверить есть ли значение, если значения нету, то следующую дату более раннюю из строки 2, если значение присутствует в столбце где последняя дата то копировать ее в ячейку B3, B4 и т.д в зависимости от того какой артикул проверяем(в какой строке формула эта будет).

Проще говоря, нужно копировать последнюю(по дате) цену.

Во вложении сама табличка.
К сообщению приложен файл: 1207985.xls(100.0 Kb)


Сообщение отредактировал Middy - Среда, 28.02.2018, 17:55
 
Ответить
СообщениеВсем доброго времени суток!

Подскажите, пож-та, нужно придумать формулу(или может быть макрос написать), чтобы сначала проверяла последнюю дату по строке 2, после того как последняя дата известна(например 28.02.2018) нужно по столбцу (где эта дата стоит) и строке(к которой относится этот артикул) проверить есть ли значение, если значения нету, то следующую дату более раннюю из строки 2, если значение присутствует в столбце где последняя дата то копировать ее в ячейку B3, B4 и т.д в зависимости от того какой артикул проверяем(в какой строке формула эта будет).

Проще говоря, нужно копировать последнюю(по дате) цену.

Во вложении сама табличка.

Автор - Middy
Дата добавления - 28.02.2018 в 17:55
Pelena Дата: Среда, 28.02.2018, 18:09 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13033
Репутация: 2877 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Так подойдёт?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9^9;C3:BV3);"")
К сообщению приложен файл: 1207985.xlsx(62.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Так подойдёт?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9^9;C3:BV3);"")

Автор - Pelena
Дата добавления - 28.02.2018 в 18:09
Karataev Дата: Среда, 28.02.2018, 20:18 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1250
Репутация: 481 ±
Замечаний: 0% ±

Excel
Предполагается, что в столбцах с "C" по последний находятся числа, а не текст. Для "B3":
Код
=ИНДЕКС(C3:IV3;1;ПОИСКПОЗ(1E+306;C3:IV3;1))


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеПредполагается, что в столбцах с "C" по последний находятся числа, а не текст. Для "B3":
Код
=ИНДЕКС(C3:IV3;1;ПОИСКПОЗ(1E+306;C3:IV3;1))

Автор - Karataev
Дата добавления - 28.02.2018 в 20:18
gling Дата: Среда, 28.02.2018, 22:21 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1814
Репутация: 439 ±
Замечаний: 0% ±

2010
Здравствуйте. Так как даты не сортированы, пошел другим путем. Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(C3:BV3;ПОИСКПОЗ(1;($C$2:$BV$2=МАКС((C3:BV3>0)*($C$2:$BV$2)))*(C3:BV3>0);));"")
Получился немного другой результат. Сравнение в файле. Который из них правильный не знаю.
К сообщению приложен файл: 7858937.xlsx(70.7 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. Так как даты не сортированы, пошел другим путем. Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(C3:BV3;ПОИСКПОЗ(1;($C$2:$BV$2=МАКС((C3:BV3>0)*($C$2:$BV$2)))*(C3:BV3>0);));"")
Получился немного другой результат. Сравнение в файле. Который из них правильный не знаю.

Автор - gling
Дата добавления - 28.02.2018 в 22:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка по послед дате, и копировать цену (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!