Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для выявления разницы данных в таблице - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для выявления разницы данных в таблице (Формулы/Formulas)
Формула для выявления разницы данных в таблице
220Volt Дата: Воскресенье, 04.03.2018, 11:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет. Суть вопроса в том, что есть огромная таблица с огромным количеством данных (скрин прилагаю).
Нужно сделать так, что бы формула выдала позиции которых больше на n количество в одном месте, чем в другом.
Например показало так, что на Склад Карпинского меньше чем на Склад второго магазина (Уинская)
 
Ответить
СообщениеВсем привет. Суть вопроса в том, что есть огромная таблица с огромным количеством данных (скрин прилагаю).
Нужно сделать так, что бы формула выдала позиции которых больше на n количество в одном месте, чем в другом.
Например показало так, что на Склад Карпинского меньше чем на Склад второго магазина (Уинская)

Автор - 220Volt
Дата добавления - 04.03.2018 в 11:27
Nic70y Дата: Воскресенье, 04.03.2018, 11:34 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4679
Репутация: 1008 ±
Замечаний: 0% ±

Excel 2013
скрин прилагаю
а вот это совсем ни к чему,
этож форум по эксель.
Файл давайте.
(желательно с результатом вручную написанным)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
скрин прилагаю
а вот это совсем ни к чему,
этож форум по эксель.
Файл давайте.
(желательно с результатом вручную написанным)

Автор - Nic70y
Дата добавления - 04.03.2018 в 11:34
220Volt Дата: Воскресенье, 04.03.2018, 13:29 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вот файл
К сообщению приложен файл: 5239707.xlsx(10.3 Kb)


Сообщение отредактировал 220Volt - Воскресенье, 04.03.2018, 13:41
 
Ответить
СообщениеВот файл

Автор - 220Volt
Дата добавления - 04.03.2018 в 13:29
Nic70y Дата: Воскресенье, 04.03.2018, 14:36 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4679
Репутация: 1008 ±
Замечаний: 0% ±

Excel 2013
в файле 2 варианта (2 листа)
/куча ненужных формул; один столбец формул + фильтр/
вдруг правильно
К сообщению приложен файл: 8002602.xlsx(16.6 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениев файле 2 варианта (2 листа)
/куча ненужных формул; один столбец формул + фильтр/
вдруг правильно

Автор - Nic70y
Дата добавления - 04.03.2018 в 14:36
220Volt Дата: Воскресенье, 04.03.2018, 14:54 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
вдруг правильно

я не совсем то имел в виду. нужно что бы в итоге выводилась точно такая же таблица, но выводились только те позиции, которые удовлетворяют a > (на 2 либо более) b
 
Ответить
Сообщение
вдруг правильно

я не совсем то имел в виду. нужно что бы в итоге выводилась точно такая же таблица, но выводились только те позиции, которые удовлетворяют a > (на 2 либо более) b

Автор - 220Volt
Дата добавления - 04.03.2018 в 14:54
Nic70y Дата: Воскресенье, 04.03.2018, 15:07 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4679
Репутация: 1008 ±
Замечаний: 0% ±

Excel 2013
случайно фильтром 0 выбрал вместо 1
моглиб и догадаться.
К сообщению приложен файл: 8917795.xlsx(16.6 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеслучайно фильтром 0 выбрал вместо 1
моглиб и догадаться.

Автор - Nic70y
Дата добавления - 04.03.2018 в 15:07
220Volt Дата: Воскресенье, 04.03.2018, 15:25 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
случайно фильтром 0 выбрал вместо 1
моглиб и догадаться.

В оригинальном файле формула к сожалению не сработала(


Сообщение отредактировал 220Volt - Воскресенье, 04.03.2018, 15:38
 
Ответить
Сообщение
случайно фильтром 0 выбрал вместо 1
моглиб и догадаться.

В оригинальном файле формула к сожалению не сработала(

Автор - 220Volt
Дата добавления - 04.03.2018 в 15:25
220Volt Дата: Воскресенье, 04.03.2018, 15:40 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вот ссылка на оригинал. Может быть у вас получится что то придумать?
https://yadi.sk/i/9nYgVstI3SzKab
 
Ответить
СообщениеВот ссылка на оригинал. Может быть у вас получится что то придумать?
https://yadi.sk/i/9nYgVstI3SzKab

Автор - 220Volt
Дата добавления - 04.03.2018 в 15:40
Светлый Дата: Понедельник, 05.03.2018, 09:19 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 480
Репутация: 113 ±
Замечаний: 0% ±

Excel 2007
С дополнительным столбцом с формулой массива:
Код
=ЕСЛИ(ЕОШ(-A2);R1;МАКС(СМЕЩ(Q3;;;МИН(ЕСЛИ(1-ЕОШ(-A3:A10);СТРОКА(A3:A10)-СТРОКА(A3))))-ТРАНСП(СМЕЩ(Q3;;;МИН(ЕСЛИ(1-ЕОШ(-A3:A10);СТРОКА(A3:A10)-СТРОКА(A3)))))))

Из фильтра исключить 1, тогда получится требуемый результат.
К сообщению приложен файл: 5239707_1.xlsx(11.2 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеС дополнительным столбцом с формулой массива:
Код
=ЕСЛИ(ЕОШ(-A2);R1;МАКС(СМЕЩ(Q3;;;МИН(ЕСЛИ(1-ЕОШ(-A3:A10);СТРОКА(A3:A10)-СТРОКА(A3))))-ТРАНСП(СМЕЩ(Q3;;;МИН(ЕСЛИ(1-ЕОШ(-A3:A10);СТРОКА(A3:A10)-СТРОКА(A3)))))))

Из фильтра исключить 1, тогда получится требуемый результат.

Автор - Светлый
Дата добавления - 05.03.2018 в 09:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для выявления разницы данных в таблице (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!