Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка значений из базы по значению в ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений из базы по значению в ячейке (Формулы/Formulas)
Подстановка значений из базы по значению в ячейке
qbinez Дата: Понедельник, 05.03.2018, 22:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!

Подскажите, пожалуйста, решение: есть форма (столбцы К-Р).

В неё нужно вставить из базы (столбцы A-F) по значению в ячейке К2.
К сообщению приложен файл: 1260578.xlsx(14.8 Kb)
 
Ответить
СообщениеДобрый день!

Подскажите, пожалуйста, решение: есть форма (столбцы К-Р).

В неё нужно вставить из базы (столбцы A-F) по значению в ячейке К2.

Автор - qbinez
Дата добавления - 05.03.2018 в 22:38
Che79 Дата: Понедельник, 05.03.2018, 22:49 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
qbinez, здравствуйте. Уточните, нужно заполнить только столбец P (в примере правый желтый) при изменении K2 или всю форму K:P? У вас в L:N там ссылки на ячейки - это Вы как пример нужно результата сделали?


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 05.03.2018, 22:50
 
Ответить
Сообщениеqbinez, здравствуйте. Уточните, нужно заполнить только столбец P (в примере правый желтый) при изменении K2 или всю форму K:P? У вас в L:N там ссылки на ячейки - это Вы как пример нужно результата сделали?

Автор - Che79
Дата добавления - 05.03.2018 в 22:49
Che79 Дата: Понедельник, 05.03.2018, 22:59 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Как понял задачу. В K2 выпадающий список по диапазону D1:F1. В P3 формула
Код
=ЕСЛИОШИБКА(ГПР($K$2;$A$1:$F$48;ПОИСКПОЗ($M3;$B$1:$B$48;););)
и далее протянуть вниз
К сообщению приложен файл: _1260578-.xlsx(15.0 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 05.03.2018, 22:59
 
Ответить
СообщениеКак понял задачу. В K2 выпадающий список по диапазону D1:F1. В P3 формула
Код
=ЕСЛИОШИБКА(ГПР($K$2;$A$1:$F$48;ПОИСКПОЗ($M3;$B$1:$B$48;););)
и далее протянуть вниз

Автор - Che79
Дата добавления - 05.03.2018 в 22:59
qbinez Дата: Понедельник, 05.03.2018, 23:04 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Уточните, нужно заполнить только столбец P (в примере правый желтый) при изменении K2 или всю форму K:P?


Всю форму К-Р т.к. в различных расценках разные материалы и механизмы.
 
Ответить
Сообщение
Уточните, нужно заполнить только столбец P (в примере правый желтый) при изменении K2 или всю форму K:P?


Всю форму К-Р т.к. в различных расценках разные материалы и механизмы.

Автор - qbinez
Дата добавления - 05.03.2018 в 23:04
Che79 Дата: Вторник, 06.03.2018, 00:54 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
qbinez, проверяйте.
Формулы (неоптимизированные) в серых ячейках. Написал первое, что прилетело в голову. Основная в столбце P. Формула массива (ввод Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$5:F$48;НАИМЕНЬШИЙ(ЕСЛИ((ДВССЫЛ("$"&ГПР($K$2;ЕСЛИ({1:0};$D$1:$F$1;$G$1:$I$1);2;)&"$5"):ДВССЫЛ("$"&ГПР($K$2;ЕСЛИ({1:0};$D$1:$F$1;$G$1:$I$1);2;)&"$48")<>0);СТРОКА($A$5:$A$48)-4);СТРОКА(E1));ПОИСКПОЗ($K$2;$D$1:$F$1;));"")

Наверняка, еще предложат варианты короче и изящнее.

Добавлено
Довложил файл -2, в нём уже более-менее по-человечески :D (только коды ресурсов подтягиваются массивным ИНДЕКС()-ом, остальные параметры через ВПР() и обычный ИНДЕКС().
К сообщению приложен файл: _1260578-2.xlsx(18.0 Kb) · 1260578-2.xlsx(17.6 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Вторник, 06.03.2018, 11:32
 
Ответить
Сообщениеqbinez, проверяйте.
Формулы (неоптимизированные) в серых ячейках. Написал первое, что прилетело в голову. Основная в столбце P. Формула массива (ввод Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$5:F$48;НАИМЕНЬШИЙ(ЕСЛИ((ДВССЫЛ("$"&ГПР($K$2;ЕСЛИ({1:0};$D$1:$F$1;$G$1:$I$1);2;)&"$5"):ДВССЫЛ("$"&ГПР($K$2;ЕСЛИ({1:0};$D$1:$F$1;$G$1:$I$1);2;)&"$48")<>0);СТРОКА($A$5:$A$48)-4);СТРОКА(E1));ПОИСКПОЗ($K$2;$D$1:$F$1;));"")

Наверняка, еще предложат варианты короче и изящнее.

Добавлено
Довложил файл -2, в нём уже более-менее по-человечески :D (только коды ресурсов подтягиваются массивным ИНДЕКС()-ом, остальные параметры через ВПР() и обычный ИНДЕКС().

Автор - Che79
Дата добавления - 06.03.2018 в 00:54
sboy Дата: Вторник, 06.03.2018, 11:25 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2063
Репутация: 593 ±
Замечаний: 0% ±

Excel 2010
варианты короче

для строк
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$5:A$48;АГРЕГАТ(15;6;(СТРОКА(A$5:A$48)-4)/ЕЧИСЛО(ИНДЕКС($D$5:$F$48;;ПОИСКПОЗ($K$2;$D$1:$F$1;)));СТРОКА(A1)));"")

для значений чуть другая
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$5:F$48;АГРЕГАТ(15;6;(СТРОКА(E$5:E$48)-4)/ЕЧИСЛО(ИНДЕКС($D$5:$F$48;;ПОИСКПОЗ($K$2;$D$1:$F$1;)));СТРОКА(E1));ПОИСКПОЗ($K$2;$D$1:$F$1;));"")
К сообщению приложен файл: 1479284.xlsx(17.6 Kb)
 
Ответить
Сообщение
варианты короче

для строк
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$5:A$48;АГРЕГАТ(15;6;(СТРОКА(A$5:A$48)-4)/ЕЧИСЛО(ИНДЕКС($D$5:$F$48;;ПОИСКПОЗ($K$2;$D$1:$F$1;)));СТРОКА(A1)));"")

для значений чуть другая
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$5:F$48;АГРЕГАТ(15;6;(СТРОКА(E$5:E$48)-4)/ЕЧИСЛО(ИНДЕКС($D$5:$F$48;;ПОИСКПОЗ($K$2;$D$1:$F$1;)));СТРОКА(E1));ПОИСКПОЗ($K$2;$D$1:$F$1;));"")

Автор - sboy
Дата добавления - 06.03.2018 в 11:25
qbinez Дата: Вторник, 06.03.2018, 15:50 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо всем! Всё работает!
 
Ответить
СообщениеСпасибо всем! Всё работает!

Автор - qbinez
Дата добавления - 06.03.2018 в 15:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений из базы по значению в ячейке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!