Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Принадлежность даты к периоду дат. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Принадлежность даты к периоду дат. (Формулы/Formulas)
Принадлежность даты к периоду дат.
Mark1976 Дата: Пятница, 09.03.2018, 23:13 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 518
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Есть таблица с датами. Необходимо проверить принадлежность даты в колонке С, к периоду дат в колонках А и B. Если принадлежит, то в D ставим да, если не принадлежит, то ставим нет. Заранее спасибо.
К сообщению приложен файл: Date.xlsx(10.7 Kb)


Сообщение отредактировал Mark1976 - Пятница, 09.03.2018, 23:15
 
Ответить
СообщениеЗдравствуйте. Есть таблица с датами. Необходимо проверить принадлежность даты в колонке С, к периоду дат в колонках А и B. Если принадлежит, то в D ставим да, если не принадлежит, то ставим нет. Заранее спасибо.

Автор - Mark1976
Дата добавления - 09.03.2018 в 23:13
Светлый Дата: Суббота, 10.03.2018, 00:20 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 747
Репутация: 198 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте.
Код
=ЕСЛИ(ИЛИ(И(--ЛЕВБ(C2;10)>=A2;--ЛЕВБ(C2;10)<=B2);И(--ПРАВБ(C2;10)>=A2;--ПРАВБ(C2;10)<=B2));"да";"нет")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИ(ИЛИ(И(--ЛЕВБ(C2;10)>=A2;--ЛЕВБ(C2;10)<=B2);И(--ПРАВБ(C2;10)>=A2;--ПРАВБ(C2;10)<=B2));"да";"нет")

Автор - Светлый
Дата добавления - 10.03.2018 в 00:20
Mark1976 Дата: Суббота, 10.03.2018, 08:15 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 518
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Светлый, спасибо за формулу, в примере все отлично. Скопировал в свой файл, а там не работает. В чем может быть причина ошибки? Свои даты скопировал в пример.
К сообщению приложен файл: 6104461.xlsx(11.9 Kb)


Сообщение отредактировал Mark1976 - Суббота, 10.03.2018, 08:18
 
Ответить
СообщениеСветлый, спасибо за формулу, в примере все отлично. Скопировал в свой файл, а там не работает. В чем может быть причина ошибки? Свои даты скопировал в пример.

Автор - Mark1976
Дата добавления - 10.03.2018 в 08:15
Pelena Дата: Суббота, 10.03.2018, 08:47 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13298
Репутация: 2927 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Mark1976, у Вас в F7 дата записана текстом. В формуле перед F7 поставьте два минуса --F7, да и перед G7 тоже можно на всякий случай


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеMark1976, у Вас в F7 дата записана текстом. В формуле перед F7 поставьте два минуса --F7, да и перед G7 тоже можно на всякий случай

Автор - Pelena
Дата добавления - 10.03.2018 в 08:47
AlexM Дата: Суббота, 10.03.2018, 10:40 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3780
Репутация: 952 ±
Замечаний: 0% ±

Excel 2003
У меня результат отличается
Код
=ЕСЛИ(ЕОШ(ИНДЕКС(A:A;МИН(F7:G7)):ИНДЕКС(A:A;МАКС(F7:G7)) ИНДЕКС(A:A;M7));"нет";"да")
К сообщению приложен файл: 6104461_01.xlsx(11.2 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеУ меня результат отличается
Код
=ЕСЛИ(ЕОШ(ИНДЕКС(A:A;МИН(F7:G7)):ИНДЕКС(A:A;МАКС(F7:G7)) ИНДЕКС(A:A;M7));"нет";"да")

Автор - AlexM
Дата добавления - 10.03.2018 в 10:40
Mark1976 Дата: Среда, 14.03.2018, 01:16 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 518
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, Вам спасибо за подсказку, а также всем остальным за формулу.
 
Ответить
СообщениеPelena, Вам спасибо за подсказку, а также всем остальным за формулу.

Автор - Mark1976
Дата добавления - 14.03.2018 в 01:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Принадлежность даты к периоду дат. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!