Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Запрос на выборку данных в MS EXCEL - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Запрос на выборку данных в MS EXCEL (Формулы/Formulas)
Запрос на выборку данных в MS EXCEL
attake Дата: Среда, 04.04.2018, 12:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго времени суток!

Ребят помогите пожалуйста с решением задачки.
Есть таблица с поставками и там куча столбцов:
1. Вид товара
2.Наименование товара
3.Номер документа
4.Форма документа
5.Дата
6.Ед.изм
7.Количество
8.Цена
9.Цена за ед. товара
10.поставщик
11. Примечание.
(Пример таблицы прикрепил. Табл 1. )
Хочу сделать выборку при помощи функции ИНДЕКС по 3м критериям
первые два критерия: Диапазон дат (от , до), третий критерий - вид товара.

Также прикрепил файл в котором находится примерный вид. И наглядный пример того, что именно хочу реализовать.

Если есть какие-то мысли, подскажите пожалуйста, как это сделать.
К сообщению приложен файл: _1..xlsx(16.2 Kb)
 
Ответить
СообщениеДоброго времени суток!

Ребят помогите пожалуйста с решением задачки.
Есть таблица с поставками и там куча столбцов:
1. Вид товара
2.Наименование товара
3.Номер документа
4.Форма документа
5.Дата
6.Ед.изм
7.Количество
8.Цена
9.Цена за ед. товара
10.поставщик
11. Примечание.
(Пример таблицы прикрепил. Табл 1. )
Хочу сделать выборку при помощи функции ИНДЕКС по 3м критериям
первые два критерия: Диапазон дат (от , до), третий критерий - вид товара.

Также прикрепил файл в котором находится примерный вид. И наглядный пример того, что именно хочу реализовать.

Если есть какие-то мысли, подскажите пожалуйста, как это сделать.

Автор - attake
Дата добавления - 04.04.2018 в 12:35
китин Дата: Среда, 04.04.2018, 12:47 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5143
Репутация: 815 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так?
Код
=ЕСЛИОШИБКА(ИНДЕКС(L$9:L$20;НАИМЕНЬШИЙ(ЕСЛИ(($O$9:$O$20>=$R$3)*($O$9:$O$20<=$R$4)*($L$9:$L$20=$R$5);СТРОКА($L$9:$L$20)-8);СТРОКА(A1)));"")

формула массива
К сообщению приложен файл: attake.xlsx(18.8 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак?
Код
=ЕСЛИОШИБКА(ИНДЕКС(L$9:L$20;НАИМЕНЬШИЙ(ЕСЛИ(($O$9:$O$20>=$R$3)*($O$9:$O$20<=$R$4)*($L$9:$L$20=$R$5);СТРОКА($L$9:$L$20)-8);СТРОКА(A1)));"")

формула массива

Автор - китин
Дата добавления - 04.04.2018 в 12:47
sboy Дата: Среда, 04.04.2018, 12:48 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2230
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если есть какие-то мысли, подскажите пожалуйста

Мысль такая: а почему не пользоваться встроенным фильтром?
 
Ответить
СообщениеДобрый день.
Если есть какие-то мысли, подскажите пожалуйста

Мысль такая: а почему не пользоваться встроенным фильтром?

Автор - sboy
Дата добавления - 04.04.2018 в 12:48
attake Дата: Четверг, 05.04.2018, 11:12 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин, спасибо большое - ты гений!
 
Ответить
Сообщениекитин, спасибо большое - ты гений!

Автор - attake
Дата добавления - 05.04.2018 в 11:12
attake Дата: Четверг, 05.04.2018, 11:43 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин,

А что значит - 8 в формуле?


Сообщение отредактировал attake - Четверг, 05.04.2018, 11:58
 
Ответить
Сообщениекитин,

А что значит - 8 в формуле?

Автор - attake
Дата добавления - 05.04.2018 в 11:43
китин Дата: Четверг, 05.04.2018, 11:50 | Сообщение № 6
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5143
Репутация: 815 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
А что значит - 8 в формуле?


а вы выделите в строке формул СТРОКА($L$9:$L$20)-8) и нажмите F9.увидите, что вам покажет массив от 1 до 12
[p.s.]формулу в тэги заключите, а то придут наши добрейшей души модераторы и будут ругаццо


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 05.04.2018, 11:51
 
Ответить
Сообщение
А что значит - 8 в формуле?


а вы выделите в строке формул СТРОКА($L$9:$L$20)-8) и нажмите F9.увидите, что вам покажет массив от 1 до 12
[p.s.]формулу в тэги заключите, а то придут наши добрейшей души модераторы и будут ругаццо

Автор - китин
Дата добавления - 05.04.2018 в 11:50
attake Дата: Четверг, 05.04.2018, 12:21 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин, Спасибо!
 
Ответить
Сообщениекитин, Спасибо!

Автор - attake
Дата добавления - 05.04.2018 в 12:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Запрос на выборку данных в MS EXCEL (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!