Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Добавить в формулу новый параметр - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавить в формулу новый параметр (Формулы/Formulas)
Добавить в формулу новый параметр
buh Дата: Четверг, 05.04.2018, 20:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток всем. Есть формула, но в неё надо добавить новый параметр. Более подробно о проблеме говорится в приложенном файле. Спасибо.
К сообщению приложен файл: 7305971.xls(61.0 Kb)


Сообщение отредактировал buh - Четверг, 05.04.2018, 20:37
 
Ответить
СообщениеДоброго времени суток всем. Есть формула, но в неё надо добавить новый параметр. Более подробно о проблеме говорится в приложенном файле. Спасибо.

Автор - buh
Дата добавления - 05.04.2018 в 20:31
Nic70y Дата: Четверг, 05.04.2018, 20:45 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4695
Репутация: 1011 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(ИЛИ($E1="Б";$E1="Т");C1;ЕСЛИ(ИЛИ($E1="К";$E1="Н";$E1="Ч");D1;""))
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(E1;"БТ"));C1;ЕСЛИ(ЕЧИСЛО(ПОИСК(E1;"КНЧ"));D1;""))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(ИЛИ($E1="Б";$E1="Т");C1;ЕСЛИ(ИЛИ($E1="К";$E1="Н";$E1="Ч");D1;""))
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(E1;"БТ"));C1;ЕСЛИ(ЕЧИСЛО(ПОИСК(E1;"КНЧ"));D1;""))

Автор - Nic70y
Дата добавления - 05.04.2018 в 20:45
vikttur Дата: Пятница, 06.04.2018, 01:06 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2706
Репутация: 477 ±
Замечаний: 0% ±

Код
=ИНДЕКС(C1:D1;1+(ПОИСК(E1;"БТКНЧ")>2))
 
Ответить
Сообщение
Код
=ИНДЕКС(C1:D1;1+(ПОИСК(E1;"БТКНЧ")>2))

Автор - vikttur
Дата добавления - 06.04.2018 в 01:06
Светлый Дата: Пятница, 06.04.2018, 07:22 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 523
Репутация: 125 ±
Замечаний: 0% ±

Excel 2007
Вставлю свои пять копеек:
Код
=СМЕЩ(C1;;ПОИСК(E1;"БТКНЧ")>2)

Для данного конкретного файла неплохо работает вот такая формула:
Код
=C1&D1


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 06.04.2018, 07:27
 
Ответить
СообщениеВставлю свои пять копеек:
Код
=СМЕЩ(C1;;ПОИСК(E1;"БТКНЧ")>2)

Для данного конкретного файла неплохо работает вот такая формула:
Код
=C1&D1

Автор - Светлый
Дата добавления - 06.04.2018 в 07:22
buh Дата: Пятница, 06.04.2018, 10:14 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день всем. Спасибо, что ответили. Прошу прощения, но ни одна из формул не работает или я, что-то не так вставляю. Не могли бы так же, как и я вписать новую формулу в тот же файл, который был прикреплен в вопросе, чтобы я могла его скачать и воочию, так сказать, убедиться, что она работает. Я не совсем понятно объяснила и еще ошиблась в файле, поэтому уточняю цель новой формулы: если в колонке "Е" стоит: "Б", или "Т", или "Ч", то номера вручную я всегда записываю в колонку "С". Если в колонке "Е" стоит: "Н" или "К", то номера вручную я всегда записываю в колонку "D", но при этом они все должны автоматически попадать в общую колонку "В", т .е. главное сделать автоматическое попадание номера в общую колонку, а сейчас при "Ч" в ней проставляется "0". Всем спасибо за помощь.
К сообщению приложен файл: 1065253.xls(63.0 Kb)


Сообщение отредактировал buh - Пятница, 06.04.2018, 10:58
 
Ответить
СообщениеДобрый день всем. Спасибо, что ответили. Прошу прощения, но ни одна из формул не работает или я, что-то не так вставляю. Не могли бы так же, как и я вписать новую формулу в тот же файл, который был прикреплен в вопросе, чтобы я могла его скачать и воочию, так сказать, убедиться, что она работает. Я не совсем понятно объяснила и еще ошиблась в файле, поэтому уточняю цель новой формулы: если в колонке "Е" стоит: "Б", или "Т", или "Ч", то номера вручную я всегда записываю в колонку "С". Если в колонке "Е" стоит: "Н" или "К", то номера вручную я всегда записываю в колонку "D", но при этом они все должны автоматически попадать в общую колонку "В", т .е. главное сделать автоматическое попадание номера в общую колонку, а сейчас при "Ч" в ней проставляется "0". Всем спасибо за помощь.

Автор - buh
Дата добавления - 06.04.2018 в 10:14
Светлый Дата: Пятница, 06.04.2018, 10:30 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 523
Репутация: 125 ±
Замечаний: 0% ±

Excel 2007
Скопировать любую из вышеприведённых формул в ячейку B1 и протянуть на все ячейки. И будет Вам счастье.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеСкопировать любую из вышеприведённых формул в ячейку B1 и протянуть на все ячейки. И будет Вам счастье.

Автор - Светлый
Дата добавления - 06.04.2018 в 10:30
buh Дата: Пятница, 06.04.2018, 21:58 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Цитата Светлый, 06.04.2018 в 10:30, в сообщении № 6 ()
Скопировать любую из вышеприведённых формул в ячейку B1 и протянуть на все ячейки. И будет Вам счастье.

Я пробовала, не получается. Я не сильна в этом деле. Вставьте её в эксельный файл и прикрепите, пжл, к своему ответу. Спасибо.
 
Ответить
Сообщение
Цитата Светлый, 06.04.2018 в 10:30, в сообщении № 6 ()
Скопировать любую из вышеприведённых формул в ячейку B1 и протянуть на все ячейки. И будет Вам счастье.

Я пробовала, не получается. Я не сильна в этом деле. Вставьте её в эксельный файл и прикрепите, пжл, к своему ответу. Спасибо.

Автор - buh
Дата добавления - 06.04.2018 в 21:58
buh Дата: Пятница, 06.04.2018, 22:01 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Светлый, вот, что получилось
К сообщению приложен файл: 2011688.xls(63.5 Kb)
 
Ответить
СообщениеСветлый, вот, что получилось

Автор - buh
Дата добавления - 06.04.2018 в 22:01
Светлый Дата: Пятница, 06.04.2018, 22:32 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 523
Репутация: 125 ±
Замечаний: 0% ±

Excel 2007
А почему в последнем файле данные расположены не так, как в задании? Естественно, получится 0.
Прикрепляю исходный файл со всеми предложенными формулами. В изменённом файле будет работать только формула:
Код
=C1&D1
К сообщению приложен файл: 7305971_1.xls(55.5 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеА почему в последнем файле данные расположены не так, как в задании? Естественно, получится 0.
Прикрепляю исходный файл со всеми предложенными формулами. В изменённом файле будет работать только формула:
Код
=C1&D1

Автор - Светлый
Дата добавления - 06.04.2018 в 22:32
buh Дата: Суббота, 07.04.2018, 10:21 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Светлый, я писала, что ошиблась при составлении задания
 
Ответить
СообщениеСветлый, я писала, что ошиблась при составлении задания

Автор - buh
Дата добавления - 07.04.2018 в 10:21
Светлый Дата: Суббота, 07.04.2018, 11:08 | Сообщение № 11
Группа: Проверенные
Ранг: Ветеран
Сообщений: 523
Репутация: 125 ±
Замечаний: 0% ±

Excel 2007
Прошу прощения, был невнимателен.
Код
=СМЕЩ(C1;;ПОИСК(E1;"БТЧКН")>3)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеПрошу прощения, был невнимателен.
Код
=СМЕЩ(C1;;ПОИСК(E1;"БТЧКН")>3)

Автор - Светлый
Дата добавления - 07.04.2018 в 11:08
buh Дата: Воскресенье, 08.04.2018, 23:09 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Светлый, спасибо, все работает))
 
Ответить
СообщениеСветлый, спасибо, все работает))

Автор - buh
Дата добавления - 08.04.2018 в 23:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавить в формулу новый параметр (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!