Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое заполнение при определенных условиях - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение при определенных условиях (Формулы/Formulas)
Автоматическое заполнение при определенных условиях
andreyss Дата: Среда, 11.04.2018, 11:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет. Очень тяжело объяснить, что именно мне нужно, но попробую.
Итак, есть файл excel с определенными данными, 116 строк в одном столбике с одной цифрой (например 1), есть второй столбик с другими значениями, они уже разные, но некоторые повторяются, например 3 строчки со значениям 56, следующие с другим значениям 57 и т.д., и есть 3 столбик, там все значения не повторяются (они буквенные, в виде ссылки с путем к изображению).
Далее, есть второй файл, который выгружается с сайта, с первым значением, то есть 1 и т.д. до 536 (например). Мне нужно размножить значения 1, 2 и т.п. до 536 по 116 строчки и добавить к каждой значения из 2 и 3 столбца.
 
Ответить
СообщениеВсем привет. Очень тяжело объяснить, что именно мне нужно, но попробую.
Итак, есть файл excel с определенными данными, 116 строк в одном столбике с одной цифрой (например 1), есть второй столбик с другими значениями, они уже разные, но некоторые повторяются, например 3 строчки со значениям 56, следующие с другим значениям 57 и т.д., и есть 3 столбик, там все значения не повторяются (они буквенные, в виде ссылки с путем к изображению).
Далее, есть второй файл, который выгружается с сайта, с первым значением, то есть 1 и т.д. до 536 (например). Мне нужно размножить значения 1, 2 и т.п. до 536 по 116 строчки и добавить к каждой значения из 2 и 3 столбца.

Автор - andreyss
Дата добавления - 11.04.2018 в 11:13
sboy Дата: Среда, 11.04.2018, 11:17 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1944
Репутация: 564 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Очень тяжело объяснить, что именно мне нужно

Вы в файле нарисуйте что есть, Лист1 - это первый файл, Лист2 - второй и Лист3 - результат, который бы хотелось
строк 10-20 будет вполне достаточно
 
Ответить
СообщениеДобрый день.
Очень тяжело объяснить, что именно мне нужно

Вы в файле нарисуйте что есть, Лист1 - это первый файл, Лист2 - второй и Лист3 - результат, который бы хотелось
строк 10-20 будет вполне достаточно

Автор - sboy
Дата добавления - 11.04.2018 в 11:17
andreyss Дата: Среда, 11.04.2018, 11:27 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Прикрепил
Вы в файле нарисуйте что есть, Лист1 - это первый файл, Лист2 - второй и Лист3 - результат, который бы хотелось
строк 10-20 будет вполне достаточно
К сообщению приложен файл: 5794712.xlsx(10.0 Kb)
 
Ответить
СообщениеПрикрепил
Вы в файле нарисуйте что есть, Лист1 - это первый файл, Лист2 - второй и Лист3 - результат, который бы хотелось
строк 10-20 будет вполне достаточно

Автор - andreyss
Дата добавления - 11.04.2018 в 11:27
sboy Дата: Среда, 11.04.2018, 12:34 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1944
Репутация: 564 ±
Замечаний: 0% ±

Excel 2010
Вот такой вариант, если все правильно уловил
для 1 столбца
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$1:$A$999;АГРЕГАТ(15;6;СТРОКА(Лист2!$A$1:$A$999)/(НЕ(ЕПУСТО(Лист2!$A$1:$A$999)));ОКРУГЛВВЕРХ(СТРОКА(A1)/СЧЁТЗ(Лист1!$A$1:$A$999);)));"")

для остальных
Код
=ЕСЛИ(A1<>"";ИНДЕКС(Лист1!B$1:B$999;ЕСЛИ(ОСТАТ(СТРОКА(A1);СЧЁТЗ(Лист1!$A$1:$A$999));ОСТАТ(СТРОКА(A1);СЧЁТЗ(Лист1!$A$1:$A$999));СЧЁТЗ(Лист1!$A$1:$A$999)));"")
К сообщению приложен файл: 0346743.xlsx(11.3 Kb)
 
Ответить
СообщениеВот такой вариант, если все правильно уловил
для 1 столбца
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$1:$A$999;АГРЕГАТ(15;6;СТРОКА(Лист2!$A$1:$A$999)/(НЕ(ЕПУСТО(Лист2!$A$1:$A$999)));ОКРУГЛВВЕРХ(СТРОКА(A1)/СЧЁТЗ(Лист1!$A$1:$A$999);)));"")

для остальных
Код
=ЕСЛИ(A1<>"";ИНДЕКС(Лист1!B$1:B$999;ЕСЛИ(ОСТАТ(СТРОКА(A1);СЧЁТЗ(Лист1!$A$1:$A$999));ОСТАТ(СТРОКА(A1);СЧЁТЗ(Лист1!$A$1:$A$999));СЧЁТЗ(Лист1!$A$1:$A$999)));"")

Автор - sboy
Дата добавления - 11.04.2018 в 12:34
pabchek Дата: Среда, 11.04.2018, 12:39 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 878
Репутация: 211 ±
Замечаний: 0% ±

Excel 2007
Да, понять непросто... И у меня разные формулы для колонок
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$13:$A$15;ОКРВВЕРХ(СТРОКА()/СЧЁТЗ(Лист1!A:A);1));"")

Код
=ЕСЛИ(K1="";"";Лист1!$B$1)

Код
=ЕСЛИ(K1="";"";ИНДЕКС(Лист1!C:C;ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ(Лист1!A:A))+1))


Ошибся. Перезалил.
К сообщению приложен файл: 6047676.xlsx(10.9 Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Среда, 11.04.2018, 12:48
 
Ответить
СообщениеДа, понять непросто... И у меня разные формулы для колонок
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$13:$A$15;ОКРВВЕРХ(СТРОКА()/СЧЁТЗ(Лист1!A:A);1));"")

Код
=ЕСЛИ(K1="";"";Лист1!$B$1)

Код
=ЕСЛИ(K1="";"";ИНДЕКС(Лист1!C:C;ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ(Лист1!A:A))+1))


Ошибся. Перезалил.

Автор - pabchek
Дата добавления - 11.04.2018 в 12:39
sboy Дата: Среда, 11.04.2018, 12:52 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1944
Репутация: 564 ±
Замечаний: 0% ±

Excel 2010
pabchek, Виктор у Вас 2 и 3 столбец не совпадает с данными ТС
 
Ответить
Сообщениеpabchek, Виктор у Вас 2 и 3 столбец не совпадает с данными ТС

Автор - sboy
Дата добавления - 11.04.2018 в 12:52
pabchek Дата: Среда, 11.04.2018, 12:55 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 878
Репутация: 211 ±
Замечаний: 0% ±

Excel 2007
не совпадает с данными ТС

да, я видел, и подумал, что, судя по представленному образцу, условий там больше, и формулу в любом случае нужно будет корректировать ))))))))))))))))))
А 3-й столбец я уже сам исправил и перезалил


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Среда, 11.04.2018, 12:57
 
Ответить
Сообщение
не совпадает с данными ТС

да, я видел, и подумал, что, судя по представленному образцу, условий там больше, и формулу в любом случае нужно будет корректировать ))))))))))))))))))
А 3-й столбец я уже сам исправил и перезалил

Автор - pabchek
Дата добавления - 11.04.2018 в 12:55
andreyss Дата: Среда, 11.04.2018, 13:15 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вот такой вариант, если все правильно уловил
для 1 столбца

=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$1:$A$999;АГРЕГАТ(15;6;СТРОКА(Лист2!$A$1:$A$999)/(НЕ(ЕПУСТО(Лист2!$A$1:$A$999)));ОКРУГЛВВЕРХ(СТРОКА(A1)/СЧЁТЗ(Лист1!$A$1:$A$999);)));"")

для остальных

=ЕСЛИ(A1<>"";ИНДЕКС(Лист1!B$1:B$999;ЕСЛИ(ОСТАТ(СТРОКА(A1);СЧЁТЗ(Лист1!$A$1:$A$999));ОСТАТ(СТРОКА(A1);СЧЁТЗ(Лист1!$A$1:$A$999));СЧЁТЗ(Лист1!$A$1:$A$999)));"")
К сообщению приложен файл: 0346743.xlsx(11.3 Kb)


Это то, что нужно!
Спасибо огромное, я думал такое не возможно.
 
Ответить
Сообщение
Вот такой вариант, если все правильно уловил
для 1 столбца

=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$1:$A$999;АГРЕГАТ(15;6;СТРОКА(Лист2!$A$1:$A$999)/(НЕ(ЕПУСТО(Лист2!$A$1:$A$999)));ОКРУГЛВВЕРХ(СТРОКА(A1)/СЧЁТЗ(Лист1!$A$1:$A$999);)));"")

для остальных

=ЕСЛИ(A1<>"";ИНДЕКС(Лист1!B$1:B$999;ЕСЛИ(ОСТАТ(СТРОКА(A1);СЧЁТЗ(Лист1!$A$1:$A$999));ОСТАТ(СТРОКА(A1);СЧЁТЗ(Лист1!$A$1:$A$999));СЧЁТЗ(Лист1!$A$1:$A$999)));"")
К сообщению приложен файл: 0346743.xlsx(11.3 Kb)


Это то, что нужно!
Спасибо огромное, я думал такое не возможно.

Автор - andreyss
Дата добавления - 11.04.2018 в 13:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение при определенных условиях (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!