Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как вывести данные из нескольких листов в зависимости от дат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как вывести данные из нескольких листов в зависимости от дат (Формулы/Formulas)
как вывести данные из нескольких листов в зависимости от дат
Juli_95 Дата: Воскресенье, 15.04.2018, 23:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго времени суток)) Прошу помочь в работе с таблицами. Имеются таблицы, в которых планируются работы на месяц по участкам. В каждой таблице я пишу оборудование, вид ТО, время ТО и отмечаю запланированные работы по дням и сменам. Если работа запланирована я ставлю 1 в нужный день и нужную смену. Нужно сделать таблицу, в которой бы выводился список запланированных работ на день, в таком виде, как на листе "сводная таблица" в закрепленном файле. Как должна работать таблица: в ячейке под "дата" (отмечено желтым цветом) я пишу день, например 16, и таблица должна заполниться данными запланированных работ на 16 число месяца со всех листов. Буду очень благодарна за помощь)
 
Ответить
СообщениеДоброго времени суток)) Прошу помочь в работе с таблицами. Имеются таблицы, в которых планируются работы на месяц по участкам. В каждой таблице я пишу оборудование, вид ТО, время ТО и отмечаю запланированные работы по дням и сменам. Если работа запланирована я ставлю 1 в нужный день и нужную смену. Нужно сделать таблицу, в которой бы выводился список запланированных работ на день, в таком виде, как на листе "сводная таблица" в закрепленном файле. Как должна работать таблица: в ячейке под "дата" (отмечено желтым цветом) я пишу день, например 16, и таблица должна заполниться данными запланированных работ на 16 число месяца со всех листов. Буду очень благодарна за помощь)

Автор - Juli_95
Дата добавления - 15.04.2018 в 23:02
китин Дата: Понедельник, 16.04.2018, 07:21 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5142
Репутация: 815 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Имеются таблицы,

стесняюсь спросить: где?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Имеются таблицы,

стесняюсь спросить: где?

Автор - китин
Дата добавления - 16.04.2018 в 07:21
sboy Дата: Понедельник, 16.04.2018, 09:49 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2224
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
[offtop]
стесняюсь спросить

не надо стесняться (с) :)
 
Ответить
Сообщение[offtop]
стесняюсь спросить

не надо стесняться (с) :)

Автор - sboy
Дата добавления - 16.04.2018 в 09:49
Juli_95 Дата: Вторник, 17.04.2018, 20:52 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин, простите, почему то не прикрепился файл
К сообщению приложен файл: 7421824.xlsx(27.3 Kb)
 
Ответить
Сообщениекитин, простите, почему то не прикрепился файл

Автор - Juli_95
Дата добавления - 17.04.2018 в 20:52
sboy Дата: Среда, 18.04.2018, 09:51 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2224
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Исходный таблицы не самые удобные для сведения данных)
вариант с промежуточными таблицами для каждого участка и каждой смены
для примера формула 1 участок 1 смена
Код
=ЕСЛИОШИБКА(ИНДЕКС('1участок'!B$17:B$33;АГРЕГАТ(15;6;(СТРОКА($B$17:$B$33)-16)/ИНДЕКС('1участок'!$E$17:$BN$33;;Сводная!$G$2*2-1);СТРОКА(A1)));"")

собираем все с помощью Power Query
при смене даты надо нажать "Обновить все" на вкладке "Данные"
[p.s.]Не посмотрел версию Excel у ТС( в 2007 не будет работать
К сообщению приложен файл: 8183116.xlsx(52.0 Kb)


Сообщение отредактировал sboy - Среда, 18.04.2018, 09:52
 
Ответить
СообщениеДобрый день.
Исходный таблицы не самые удобные для сведения данных)
вариант с промежуточными таблицами для каждого участка и каждой смены
для примера формула 1 участок 1 смена
Код
=ЕСЛИОШИБКА(ИНДЕКС('1участок'!B$17:B$33;АГРЕГАТ(15;6;(СТРОКА($B$17:$B$33)-16)/ИНДЕКС('1участок'!$E$17:$BN$33;;Сводная!$G$2*2-1);СТРОКА(A1)));"")

собираем все с помощью Power Query
при смене даты надо нажать "Обновить все" на вкладке "Данные"
[p.s.]Не посмотрел версию Excel у ТС( в 2007 не будет работать

Автор - sboy
Дата добавления - 18.04.2018 в 09:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как вывести данные из нескольких листов в зависимости от дат (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!