Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск ряда слов в определенном промежутке текста - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ряда слов в определенном промежутке текста (Формулы/Formulas)
Поиск ряда слов в определенном промежутке текста
АлексейАльтман Дата: Пятница, 27.04.2018, 16:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте люди. Подскажите с решением проблемы.

Имеется формула для простановки единиц - при найденном слове
Код
=ЕСЛИ(ЕОШИБКА(ПОИСК("тема5";I8))=ИСТИНА;0;1)

Эта формула ищет только одно слово в строке - слово "тема5"... и выводит только два результата - либо 1 либо 0.
Сейчас эта формула действует в ячейке G10

Но вот вопрос - как заставить искать это значение не во всем слове, а в промежутке между "ОТМЕТКА-" и "," ?
И искать не одно слово, а любое из нескольких ?

То есть - нужно формулой в промежутке между "ОТМЕТКА-" и "," - найти хотя бы одно слово из списка "тема5, вопрос,... и т.д." - и вывести первое попавшееся слово (соответствующее списку) в ячейке G8.
К сообщению приложен файл: 7860667.xls(30.0 Kb)


Сообщение отредактировал АлексейАльтман - Пятница, 27.04.2018, 17:19
 
Ответить
СообщениеЗдравствуйте люди. Подскажите с решением проблемы.

Имеется формула для простановки единиц - при найденном слове
Код
=ЕСЛИ(ЕОШИБКА(ПОИСК("тема5";I8))=ИСТИНА;0;1)

Эта формула ищет только одно слово в строке - слово "тема5"... и выводит только два результата - либо 1 либо 0.
Сейчас эта формула действует в ячейке G10

Но вот вопрос - как заставить искать это значение не во всем слове, а в промежутке между "ОТМЕТКА-" и "," ?
И искать не одно слово, а любое из нескольких ?

То есть - нужно формулой в промежутке между "ОТМЕТКА-" и "," - найти хотя бы одно слово из списка "тема5, вопрос,... и т.д." - и вывести первое попавшееся слово (соответствующее списку) в ячейке G8.

Автор - АлексейАльтман
Дата добавления - 27.04.2018 в 16:51
Nic70y Дата: Пятница, 27.04.2018, 17:10 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4618
Репутация: 996 ±
Замечаний: 0% ±

Excel 2013
{формула массива вводится одновременным нажатием Ctrl Shift Enter}
1)2003 не хавает
2)список из одной ячейки разнесен по разным в примере F1:F2
3)Вашу формулу засуньте пжл. в тег
4) в Вашей =ИСТИНА лишнее
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$1:$F$2;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК($F$1:$F$2;ЛЕВБ(ПОДСТАВИТЬ(ПСТР($I8;ПОИСК("ОТМЕТКА-";$I8)+8;897);",";ПОВТОР(" ";3427));897)));СТРОКА($F$1:$F$2));СТОЛБЕЦ(A1)));"")
К сообщению приложен файл: 18.xlsx(12.5 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение{формула массива вводится одновременным нажатием Ctrl Shift Enter}
1)2003 не хавает
2)список из одной ячейки разнесен по разным в примере F1:F2
3)Вашу формулу засуньте пжл. в тег
4) в Вашей =ИСТИНА лишнее
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$1:$F$2;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК($F$1:$F$2;ЛЕВБ(ПОДСТАВИТЬ(ПСТР($I8;ПОИСК("ОТМЕТКА-";$I8)+8;897);",";ПОВТОР(" ";3427));897)));СТРОКА($F$1:$F$2));СТОЛБЕЦ(A1)));"")

Автор - Nic70y
Дата добавления - 27.04.2018 в 17:10
АлексейАльтман Дата: Пятница, 27.04.2018, 19:52 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Nic70y, да вроде нормально.

Спасибо за совет.
 
Ответить
СообщениеNic70y, да вроде нормально.

Спасибо за совет.

Автор - АлексейАльтман
Дата добавления - 27.04.2018 в 19:52
AlexM Дата: Пятница, 27.04.2018, 19:54 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3735
Репутация: 944 ±
Замечаний: 0% ±

Excel 2003
Формула массива
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/(МИН(ПОИСК(F1:F2;ПСТР(I8;ПОИСК("отметка-";I8);999)))=ПОИСК(F1:F2;ПСТР(I8;ПОИСК("отметка-";I8);999)));F1:F2);"")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормула массива
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/(МИН(ПОИСК(F1:F2;ПСТР(I8;ПОИСК("отметка-";I8);999)))=ПОИСК(F1:F2;ПСТР(I8;ПОИСК("отметка-";I8);999)));F1:F2);"")

Автор - AlexM
Дата добавления - 27.04.2018 в 19:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ряда слов в определенном промежутке текста (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!