Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение типовой таблицы данными из другой таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение типовой таблицы данными из другой таблицы (Формулы/Formulas)
Заполнение типовой таблицы данными из другой таблицы
aTBepTKa Дата: Пятница, 27.04.2018, 18:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Существует таблица с данными сотрудников следующего формата:
1.__|__Петров И. И.__|__1990_|__4р
2.__|__Иванов П. П. _|__1980__|_5р
3. _|_Сидоров А. А.___|_1970 _|__6р

Необходимо данные приведенные выше подставить в типовую табличную форму и поочередно вывести на печать. Например:
1. Сотрудник Петров И. И. 1990 года рождения: слесарь 4р.
2. Сотрудник Иванов П. П. 1980 года рождения: слесарь 5р.
3. Сотрудник Сидоров А. А. 1970 года рождения: слесарь 6р.

То есть на печать необходимо вывести три листа с данными по каждому сотруднику отдельно. Подскажите как реализовать данное решение?
 
Ответить
СообщениеСуществует таблица с данными сотрудников следующего формата:
1.__|__Петров И. И.__|__1990_|__4р
2.__|__Иванов П. П. _|__1980__|_5р
3. _|_Сидоров А. А.___|_1970 _|__6р

Необходимо данные приведенные выше подставить в типовую табличную форму и поочередно вывести на печать. Например:
1. Сотрудник Петров И. И. 1990 года рождения: слесарь 4р.
2. Сотрудник Иванов П. П. 1980 года рождения: слесарь 5р.
3. Сотрудник Сидоров А. А. 1970 года рождения: слесарь 6р.

То есть на печать необходимо вывести три листа с данными по каждому сотруднику отдельно. Подскажите как реализовать данное решение?

Автор - aTBepTKa
Дата добавления - 27.04.2018 в 18:10
Nic70y Дата: Пятница, 27.04.2018, 18:16 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4850
Репутация: 1050 ±
Замечаний: 0% ±

Excel 2013
для начала посмотреть бы Ваш файл...


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениедля начала посмотреть бы Ваш файл...

Автор - Nic70y
Дата добавления - 27.04.2018 в 18:16
aTBepTKa Дата: Суббота, 28.04.2018, 09:22 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Прикрепляю файл. В течении месяца заполняются данные на листе "Данные". В конце месяца необходимо вывести отчеты за каждые день из листа "Форма".

На данный момент задача реализована через рассылки Word: в документ с формой подгружаются данные из таблицы и выводится на печать вся пачка. Но такое решение крайне не удобно, хотелось бы работать в одном файле excel.
К сообщению приложен файл: 1427717.xlsx(13.2 Kb)
 
Ответить
СообщениеПрикрепляю файл. В течении месяца заполняются данные на листе "Данные". В конце месяца необходимо вывести отчеты за каждые день из листа "Форма".

На данный момент задача реализована через рассылки Word: в документ с формой подгружаются данные из таблицы и выводится на печать вся пачка. Но такое решение крайне не удобно, хотелось бы работать в одном файле excel.

Автор - aTBepTKa
Дата добавления - 28.04.2018 в 09:22
Nic70y Дата: Суббота, 28.04.2018, 10:23 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4850
Репутация: 1050 ±
Замечаний: 0% ±

Excel 2013
наскоряк нарекордил
[vba]
Код
Sub U__897()
    u_14 = Application.Max(Sheets("Данные").Range("b3:b33"))
    u_27 = Application.Match(u_14, Sheets("Данные").Range("b3:b33"), 0)
    u = 0
    For u_1 = 1 To u_27
        u = u + 1
        [b1] = u
        ActiveWindow.SelectedSheets.PrintOut Copies:=1
    Next
End Sub
[/vba]и изменил формулу
Код
=ИНДЕКС(Данные!$C3:$ZZ33;$B1;СТОЛБЕЦ(A1))
К сообщению приложен файл: 1427717.xlsm(20.6 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениенаскоряк нарекордил
[vba]
Код
Sub U__897()
    u_14 = Application.Max(Sheets("Данные").Range("b3:b33"))
    u_27 = Application.Match(u_14, Sheets("Данные").Range("b3:b33"), 0)
    u = 0
    For u_1 = 1 To u_27
        u = u + 1
        [b1] = u
        ActiveWindow.SelectedSheets.PrintOut Copies:=1
    Next
End Sub
[/vba]и изменил формулу
Код
=ИНДЕКС(Данные!$C3:$ZZ33;$B1;СТОЛБЕЦ(A1))

Автор - Nic70y
Дата добавления - 28.04.2018 в 10:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение типовой таблицы данными из другой таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!