Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для excel 2007 подсчет кал. дней без праздников - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для excel 2007 подсчет кал. дней без праздников (Формулы/Formulas)
Формула для excel 2007 подсчет кал. дней без праздников
ASWP Дата: Среда, 09.05.2018, 12:07 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
Добрый день. В excel 2010 можно использовать функцию ЧИСТРАБДНИ.МЕЖД, но ее нет в excel 2007.
Код
=ЧИСТРАБДНИ.МЕЖД(A1;B1;"0000011";праздники)

Какой формулой это можно реализовать в excel 2007?


я знаю что ничего не знаю, но другие не знают и этого
 
Ответить
СообщениеДобрый день. В excel 2010 можно использовать функцию ЧИСТРАБДНИ.МЕЖД, но ее нет в excel 2007.
Код
=ЧИСТРАБДНИ.МЕЖД(A1;B1;"0000011";праздники)

Какой формулой это можно реализовать в excel 2007?

Автор - ASWP
Дата добавления - 09.05.2018 в 12:07
abtextime Дата: Среда, 09.05.2018, 12:42 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 829
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Может я чего-то не понимаю, но

Код
=ЧИСТРАБДНИ(A1;B1;праздники)


эквивалентна Вашей формуле, и эта функция есть в Excel 2007
К сообщению приложен файл: 4722544.xlsx(9.7 Kb)
 
Ответить
СообщениеМожет я чего-то не понимаю, но

Код
=ЧИСТРАБДНИ(A1;B1;праздники)


эквивалентна Вашей формуле, и эта функция есть в Excel 2007

Автор - abtextime
Дата добавления - 09.05.2018 в 12:42
ASWP Дата: Среда, 09.05.2018, 13:39 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
=ЧИСТРАБДНИ.МЕЖД(A1;B1;"0000011";праздники)

Не много ошибся с формулой
Код
=ЧИСТРАБДНИ.МЕЖД(A1;B1;"0000000";праздники)

Я хочу чтобы считались все дни и выходные тоже , но без праздников.


я знаю что ничего не знаю, но другие не знают и этого

Сообщение отредактировал ASWP - Среда, 09.05.2018, 15:21
 
Ответить
Сообщение
=ЧИСТРАБДНИ.МЕЖД(A1;B1;"0000011";праздники)

Не много ошибся с формулой
Код
=ЧИСТРАБДНИ.МЕЖД(A1;B1;"0000000";праздники)

Я хочу чтобы считались все дни и выходные тоже , но без праздников.

Автор - ASWP
Дата добавления - 09.05.2018 в 13:39
abtextime Дата: Среда, 09.05.2018, 13:49 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 829
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Ну тогда правильным вариантом использования ЧИСТРАБДНИ.МЕЖД в Вашем случае было бы

Код
=ЧИСТРАБДНИ.МЕЖД(A1;B1;"0000000";праздники)


а не "0000011"
 
Ответить
СообщениеНу тогда правильным вариантом использования ЧИСТРАБДНИ.МЕЖД в Вашем случае было бы

Код
=ЧИСТРАБДНИ.МЕЖД(A1;B1;"0000000";праздники)


а не "0000011"

Автор - abtextime
Дата добавления - 09.05.2018 в 13:49
abtextime Дата: Среда, 09.05.2018, 13:51 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 829
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Напишите содержательно, что Вы хотите считать. Разумеется, можно написать UDF - аналог ЧИСТРАБДНИ.МЕЖД
 
Ответить
СообщениеНапишите содержательно, что Вы хотите считать. Разумеется, можно написать UDF - аналог ЧИСТРАБДНИ.МЕЖД

Автор - abtextime
Дата добавления - 09.05.2018 в 13:51
ASWP Дата: Среда, 09.05.2018, 14:06 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
Вот что я хочу получить в excel 2007, на примере 2010.
К сообщению приложен файл: tabledata2007.xlsx(5.8 Kb)


я знаю что ничего не знаю, но другие не знают и этого

Сообщение отредактировал ASWP - Среда, 09.05.2018, 14:07
 
Ответить
СообщениеВот что я хочу получить в excel 2007, на примере 2010.

Автор - ASWP
Дата добавления - 09.05.2018 в 14:06
abtextime Дата: Среда, 09.05.2018, 14:21 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 829
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Пожалуйста

[vba]
Код
Public Function БезПраздников(D1, D2 As Date, Celebrations As Range)

   БезПраздников = D2 - D1 + 1
    
    For Each R In Celebrations
    
        If R.Value >= D1 And R.Value <= D2 Then БезПраздников = БезПраздников - 1
    
    Next R

End Function
[/vba]
К сообщению приложен файл: tabledata2007.xlsm(15.2 Kb)
 
Ответить
СообщениеПожалуйста

[vba]
Код
Public Function БезПраздников(D1, D2 As Date, Celebrations As Range)

   БезПраздников = D2 - D1 + 1
    
    For Each R In Celebrations
    
        If R.Value >= D1 And R.Value <= D2 Then БезПраздников = БезПраздников - 1
    
    Next R

End Function
[/vba]

Автор - abtextime
Дата добавления - 09.05.2018 в 14:21
ASWP Дата: Среда, 09.05.2018, 15:22 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
Пожалуйста

Спасибо, а просто формулами это можно реализовать?


я знаю что ничего не знаю, но другие не знают и этого
 
Ответить
Сообщение
Пожалуйста

Спасибо, а просто формулами это можно реализовать?

Автор - ASWP
Дата добавления - 09.05.2018 в 15:22
abtextime Дата: Среда, 09.05.2018, 15:37 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 829
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
а просто формулами

Лично для меня это сложнее. А в чем проблема UDF использовать?
 
Ответить
Сообщение
а просто формулами

Лично для меня это сложнее. А в чем проблема UDF использовать?

Автор - abtextime
Дата добавления - 09.05.2018 в 15:37
Pelena Дата: Среда, 09.05.2018, 15:45 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12909
Репутация: 2844 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Варианты
[vba]
Код
=ЕСЛИ(A1*B1;B1-A1+1-СУММПРОИЗВ((A1<=праздники!holidays_dates)*(B1>=праздники!holidays_dates));"")
[/vba]
[vba]
Код
=ЕСЛИ(A1*B1;B1-A1+1-СЧЁТЕСЛИМН(праздники!holidays_dates;">="&A1;праздники!holidays_dates;"<="&B1);"")
[/vba]
К сообщению приложен файл: 7242525.xlsx(10.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВарианты
[vba]
Код
=ЕСЛИ(A1*B1;B1-A1+1-СУММПРОИЗВ((A1<=праздники!holidays_dates)*(B1>=праздники!holidays_dates));"")
[/vba]
[vba]
Код
=ЕСЛИ(A1*B1;B1-A1+1-СЧЁТЕСЛИМН(праздники!holidays_dates;">="&A1;праздники!holidays_dates;"<="&B1);"")
[/vba]

Автор - Pelena
Дата добавления - 09.05.2018 в 15:45
abtextime Дата: Среда, 09.05.2018, 15:56 | Сообщение № 11
Группа: Проверенные
Ранг: Ветеран
Сообщений: 829
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
У меня такая формула нарисовалась, на данном примере всё ОК, но головой бы не стал за ее правильность ручаться :)

[vba]
Код
=B2-A2+1-ПОИСКПОЗ(ВПР(B2;праздники!holidays_dates;1;1);праздники!holidays_dates;0)+ПОИСКПОЗ(ВПР(A2;праздники!holidays_dates;1;1);праздники!holidays_dates;0)-ЕСЛИ(A2=ВПР(A2;праздники!holidays_dates;1;1);1;0)
[/vba]

Вариант уважаемой Pelena намного изящней и наверняка правильный. используйте его. Не формулист я ...
К сообщению приложен файл: tabledata2007-1.xlsm(16.4 Kb)


Сообщение отредактировал abtextime - Среда, 09.05.2018, 15:59
 
Ответить
СообщениеУ меня такая формула нарисовалась, на данном примере всё ОК, но головой бы не стал за ее правильность ручаться :)

[vba]
Код
=B2-A2+1-ПОИСКПОЗ(ВПР(B2;праздники!holidays_dates;1;1);праздники!holidays_dates;0)+ПОИСКПОЗ(ВПР(A2;праздники!holidays_dates;1;1);праздники!holidays_dates;0)-ЕСЛИ(A2=ВПР(A2;праздники!holidays_dates;1;1);1;0)
[/vba]

Вариант уважаемой Pelena намного изящней и наверняка правильный. используйте его. Не формулист я ...

Автор - abtextime
Дата добавления - 09.05.2018 в 15:56
ASWP Дата: Среда, 09.05.2018, 17:28 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
Спасибо всем, все работает specool


я знаю что ничего не знаю, но другие не знают и этого

Сообщение отредактировал ASWP - Среда, 09.05.2018, 17:28
 
Ответить
СообщениеСпасибо всем, все работает specool

Автор - ASWP
Дата добавления - 09.05.2018 в 17:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для excel 2007 подсчет кал. дней без праздников (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!