Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Удаление пустых строк из таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление пустых строк из таблицы (Формулы/Formulas)
Удаление пустых строк из таблицы
lfuthobr Дата: Четверг, 10.05.2018, 18:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день имеется таблица из 2х столбцов
А - название
В - наличие
В столбце "В" напротив позиции отмечается ее наличие, значком "+".
Необходимо сформировать новую таблицу в которой будет выводится только те наименования (строки) столбца "А", напротив которых стоит "+". Необходимо решить эту задачу без использования макросов, сортировки фильтров и формул массива.
Файл примера, прилагается
решал задачу таким путем:
Код
=ЕСЛИОШИБКА(ДВССЫЛ("A"&НАИМЕНЬШИЙ(ЕСЛИ(ЕПУСТО($A$2:$A$200);"";СТРОКА($A$2:$A$200));СТРОКА(B1)));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$1:A$99;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!A$1:A$99<>"";СТРОКА(Лист1!A$1:A$99));СТРОКА(D1)));"")

но это массив......
К сообщению приложен файл: _Microsoft_Exce.xlsx(9.1 Kb)


Сообщение отредактировал lfuthobr - Четверг, 10.05.2018, 21:32
 
Ответить
СообщениеДобрый день имеется таблица из 2х столбцов
А - название
В - наличие
В столбце "В" напротив позиции отмечается ее наличие, значком "+".
Необходимо сформировать новую таблицу в которой будет выводится только те наименования (строки) столбца "А", напротив которых стоит "+". Необходимо решить эту задачу без использования макросов, сортировки фильтров и формул массива.
Файл примера, прилагается
решал задачу таким путем:
Код
=ЕСЛИОШИБКА(ДВССЫЛ("A"&НАИМЕНЬШИЙ(ЕСЛИ(ЕПУСТО($A$2:$A$200);"";СТРОКА($A$2:$A$200));СТРОКА(B1)));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$1:A$99;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!A$1:A$99<>"";СТРОКА(Лист1!A$1:A$99));СТРОКА(D1)));"")

но это массив......

Автор - lfuthobr
Дата добавления - 10.05.2018 в 18:15
abtextime Дата: Четверг, 10.05.2018, 18:17 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 828
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Мышку хоть можно использовать? Или только клавиатуру? :)

Файла нет. Название не отражает суть задачи, т.к. удаляются не пустые строки, а строки, не отмеченнные плюсом в столбце B


Сообщение отредактировал abtextime - Четверг, 10.05.2018, 18:18
 
Ответить
СообщениеМышку хоть можно использовать? Или только клавиатуру? :)

Файла нет. Название не отражает суть задачи, т.к. удаляются не пустые строки, а строки, не отмеченнные плюсом в столбце B

Автор - abtextime
Дата добавления - 10.05.2018 в 18:17
lfuthobr Дата: Четверг, 10.05.2018, 18:20 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
abtextime, файл приложен. задача неоднозначна как и ее название на мой взгляд. так как формируется новая таблица а не меняется старая.
 
Ответить
Сообщениеabtextime, файл приложен. задача неоднозначна как и ее название на мой взгляд. так как формируется новая таблица а не меняется старая.

Автор - lfuthobr
Дата добавления - 10.05.2018 в 18:20
Pelena Дата: Четверг, 10.05.2018, 18:33 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13143
Репутация: 2895 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
lfuthobr, оформите формулы тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеlfuthobr, оформите формулы тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 10.05.2018 в 18:33
lfuthobr Дата: Четверг, 10.05.2018, 20:45 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, прошу прощения кнопка "fx"???
 
Ответить
СообщениеPelena, прошу прощения кнопка "fx"???

Автор - lfuthobr
Дата добавления - 10.05.2018 в 20:45
Pelena Дата: Четверг, 10.05.2018, 21:44 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13143
Репутация: 2895 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
без использования макросов, сортировки фильтров и формул массива
С доп. столбцом
К сообщению приложен файл: 1363387.xlsx(9.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
без использования макросов, сортировки фильтров и формул массива
С доп. столбцом

Автор - Pelena
Дата добавления - 10.05.2018 в 21:44
lfuthobr Дата: Четверг, 10.05.2018, 22:21 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, если я правильно понял, от доп столбца ни куда не уйти?А если наименование не уникальный показатель ? Поиск позиции не решит задачу?


Сообщение отредактировал lfuthobr - Четверг, 10.05.2018, 22:34
 
Ответить
СообщениеPelena, если я правильно понял, от доп столбца ни куда не уйти?А если наименование не уникальный показатель ? Поиск позиции не решит задачу?

Автор - lfuthobr
Дата добавления - 10.05.2018 в 22:21
Pelena Дата: Четверг, 10.05.2018, 22:42 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 13143
Репутация: 2895 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
от доп столбца ни куда не уйти?
Вы слишком много ограничений поставили :)

если наименование не уникальный показатель
в доп. столбце будет другая формула
К сообщению приложен файл: 3517007.xlsx(9.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
от доп столбца ни куда не уйти?
Вы слишком много ограничений поставили :)

если наименование не уникальный показатель
в доп. столбце будет другая формула

Автор - Pelena
Дата добавления - 10.05.2018 в 22:42
_Boroda_ Дата: Четверг, 10.05.2018, 23:38 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13251
Репутация: 5457 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
от доп столбца ни куда не уйти?

Да не, почему?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;ИНДЕКС(-1/(СТРОКА(A$2:A$99)=НАИМЕНЬШИЙ((B$2:B$99="+")*СТРОКА(A$2:A$99);СТРОКА(G1)+98-СЧЁТЕСЛИ(B$2:B$99;"+"))););A$2:A$99);"")

Не зависит от повторов в названии

Добавлено
Не знаю, зачем я туда ИНДЕКС всунул. Вот так прекрасно работает
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(СТРОКА(A$2:A$99)=НАИМЕНЬШИЙ((B$2:B$99="+")*СТРОКА(A$2:A$99);СТРОКА(G1)+98-СЧЁТЕСЛИ(B$2:B$99;"+")));A$2:A$99);"")
К сообщению приложен файл: 6419151_2.xlsx(9.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Пятница, 11.05.2018, 09:03
 
Ответить
Сообщение
от доп столбца ни куда не уйти?

Да не, почему?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;ИНДЕКС(-1/(СТРОКА(A$2:A$99)=НАИМЕНЬШИЙ((B$2:B$99="+")*СТРОКА(A$2:A$99);СТРОКА(G1)+98-СЧЁТЕСЛИ(B$2:B$99;"+"))););A$2:A$99);"")

Не зависит от повторов в названии

Добавлено
Не знаю, зачем я туда ИНДЕКС всунул. Вот так прекрасно работает
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(СТРОКА(A$2:A$99)=НАИМЕНЬШИЙ((B$2:B$99="+")*СТРОКА(A$2:A$99);СТРОКА(G1)+98-СЧЁТЕСЛИ(B$2:B$99;"+")));A$2:A$99);"")

Автор - _Boroda_
Дата добавления - 10.05.2018 в 23:38
Nic70y Дата: Пятница, 11.05.2018, 06:44 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4850
Репутация: 1050 ±
Замечаний: 0% ±

Excel 2013
ну и мое любимое - ИНДЕКС на ИНДЕКСе сидит, ИНДЕКСом погоняет
Код
=ИНДЕКС(A:A;ПОИСКПОЗ("+";ИНДЕКС(B$1:B$185491;ПОИСКПОЗ(E2;A:A;)+1):B$185491;)+ПОИСКПОЗ(E2;A:A;))
условие названия не должны повторяться
К сообщению приложен файл: 4443277.xlsx(9.2 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениену и мое любимое - ИНДЕКС на ИНДЕКСе сидит, ИНДЕКСом погоняет
Код
=ИНДЕКС(A:A;ПОИСКПОЗ("+";ИНДЕКС(B$1:B$185491;ПОИСКПОЗ(E2;A:A;)+1):B$185491;)+ПОИСКПОЗ(E2;A:A;))
условие названия не должны повторяться

Автор - Nic70y
Дата добавления - 11.05.2018 в 06:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление пустых строк из таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!