Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить следующею числовую комбинацию от заданной - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить следующею числовую комбинацию от заданной (Формулы/Formulas)
Определить следующею числовую комбинацию от заданной
Chelovekov Дата: Понедельник, 04.06.2018, 10:05 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте Гуры Экселя, прошу Вас решить следующею задачку, есть некая таблица состоящее из двух столбцов. Цифровая комбинация, это цифра с первого столбца и цифра рядом со второго столбца, нужно узнать какая цифровая комбинация стоит выше заданной, цифровой комбинации. В другую таблицу занести данные, какие были цифровые комбинации и сколько раз, если можно результат разместить в порядке убывания.
Пример прилагаю
К сообщению приложен файл: 6598449.xlsx(9.2 Kb)


Сообщение отредактировал Chelovekov - Понедельник, 04.06.2018, 10:06
 
Ответить
СообщениеЗдравствуйте Гуры Экселя, прошу Вас решить следующею задачку, есть некая таблица состоящее из двух столбцов. Цифровая комбинация, это цифра с первого столбца и цифра рядом со второго столбца, нужно узнать какая цифровая комбинация стоит выше заданной, цифровой комбинации. В другую таблицу занести данные, какие были цифровые комбинации и сколько раз, если можно результат разместить в порядке убывания.
Пример прилагаю

Автор - Chelovekov
Дата добавления - 04.06.2018 в 10:05
_Boroda_ Дата: Понедельник, 04.06.2018, 10:23 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13187
Репутация: 5422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Первые два столбца
Код
=ЕСЛИОШИБКА(ПСТР(ТЕКСТ(НАИМЕНЬШИЙ(ЕСЛИ($A$4:$A$99&$B$4:$B$99=$F$2&$G$2;--($A$3:$A$98&$B$3:$B$98));1+СУММ($H$2:$H2));"00");СТОЛБЕЦ(A3);1);"")

Количество
Код
=ЕСЛИ(F3="";"";СУММ(--(ЕСЛИ($A$4:$A$99&$B$4:$B$99=$F$2&$G$2;$A$3:$A$98&$B$3:$B$98)=F3&G3)))

Все формулы - формулы массива. Вводятся одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 6598449_1.xlsx(10.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Первые два столбца
Код
=ЕСЛИОШИБКА(ПСТР(ТЕКСТ(НАИМЕНЬШИЙ(ЕСЛИ($A$4:$A$99&$B$4:$B$99=$F$2&$G$2;--($A$3:$A$98&$B$3:$B$98));1+СУММ($H$2:$H2));"00");СТОЛБЕЦ(A3);1);"")

Количество
Код
=ЕСЛИ(F3="";"";СУММ(--(ЕСЛИ($A$4:$A$99&$B$4:$B$99=$F$2&$G$2;$A$3:$A$98&$B$3:$B$98)=F3&G3)))

Все формулы - формулы массива. Вводятся одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 04.06.2018 в 10:23
Chelovekov Дата: Понедельник, 04.06.2018, 10:36 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Огромное спасибо, буду разбираться hands
 
Ответить
СообщениеОгромное спасибо, буду разбираться hands

Автор - Chelovekov
Дата добавления - 04.06.2018 в 10:36
Chelovekov Дата: Понедельник, 04.06.2018, 11:19 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Извините пожалуйста, а можно добавить строчку, которая определяет последнею цифровую комбинацию следующая за заданной. Расчет введется с низу, вверх. Сверху последние числовые комбинации.
 
Ответить
СообщениеИзвините пожалуйста, а можно добавить строчку, которая определяет последнею цифровую комбинацию следующая за заданной. Расчет введется с низу, вверх. Сверху последние числовые комбинации.

Автор - Chelovekov
Дата добавления - 04.06.2018 в 11:19
_Boroda_ Дата: Понедельник, 04.06.2018, 11:26 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13187
Репутация: 5422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Пример в файле приложите. Текстом не очень понятно


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПример в файле приложите. Текстом не очень понятно

Автор - _Boroda_
Дата добавления - 04.06.2018 в 11:26
sboy Дата: Понедельник, 04.06.2018, 11:47 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2105
Репутация: 604 ±
Замечаний: 0% ±

Excel 2010
Если правильно понял.
Без сортировки
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$3:A$19;ЕСЛИ(СТРОКА(A1)<ПОИСКПОЗ($F$2&$G$2;$A$3:$A$19&$B$3:$B$19;);СТРОКА(A1);""));"")
К сообщению приложен файл: 5631673.xlsx(10.3 Kb)
 
Ответить
СообщениеЕсли правильно понял.
Без сортировки
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$3:A$19;ЕСЛИ(СТРОКА(A1)<ПОИСКПОЗ($F$2&$G$2;$A$3:$A$19&$B$3:$B$19;);СТРОКА(A1);""));"")

Автор - sboy
Дата добавления - 04.06.2018 в 11:47
Chelovekov Дата: Понедельник, 04.06.2018, 13:40 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Извините отходил, пример прилагаю
К сообщению приложен файл: 0697564.xlsx(11.7 Kb)
 
Ответить
СообщениеИзвините отходил, пример прилагаю

Автор - Chelovekov
Дата добавления - 04.06.2018 в 13:40
_Boroda_ Дата: Понедельник, 04.06.2018, 14:00 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13187
Репутация: 5422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ($A$4:$A$99&$B$4:$B$99=$F$2&$G$2;СТРОКА(A$3:A$98));СТРОКА(K1)));"")
К сообщению приложен файл: 0697564_1.xlsx(12.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ($A$4:$A$99&$B$4:$B$99=$F$2&$G$2;СТРОКА(A$3:A$98));СТРОКА(K1)));"")

Автор - _Boroda_
Дата добавления - 04.06.2018 в 14:00
Chelovekov Дата: Понедельник, 04.06.2018, 14:15 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Дай бог вам здоровье hands
 
Ответить
СообщениеДай бог вам здоровье hands

Автор - Chelovekov
Дата добавления - 04.06.2018 в 14:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить следующею числовую комбинацию от заданной (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!