Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ПОДСТАНОВКА ЗНАЧЕНИЯ из иного файла - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ПОДСТАНОВКА ЗНАЧЕНИЯ из иного файла (Формулы/Formulas)
ПОДСТАНОВКА ЗНАЧЕНИЯ из иного файла
bagraart Дата: Вторник, 05.06.2018, 08:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброе утро, уважаемые форумчане,

Помогите, пожалуйста , с решением задачки.

Есть два файла. Файл 1 и файл 2. Оба прилагаю ниже. В каждом из файлов есть общее для них - столбец ИНДЕКС

Необходимо, чтобы в файле 2 в столбец "зона из файла 1", который я выделил красным, прописалась собственно зона из файла 1, на основании общности индексов двух файлов

Excel как бы должен опросить файл 1 на совпадение с индексом из файла 2 и на основании этого прописать в "зона из файла 1" собственно зону.

Заранее благодарен
К сообщению приложен файл: 9715425.xls(32.0 Kb) · 0004725.xls(28.0 Kb)
 
Ответить
СообщениеДоброе утро, уважаемые форумчане,

Помогите, пожалуйста , с решением задачки.

Есть два файла. Файл 1 и файл 2. Оба прилагаю ниже. В каждом из файлов есть общее для них - столбец ИНДЕКС

Необходимо, чтобы в файле 2 в столбец "зона из файла 1", который я выделил красным, прописалась собственно зона из файла 1, на основании общности индексов двух файлов

Excel как бы должен опросить файл 1 на совпадение с индексом из файла 2 и на основании этого прописать в "зона из файла 1" собственно зону.

Заранее благодарен

Автор - bagraart
Дата добавления - 05.06.2018 в 08:17
bagraart Дата: Вторник, 05.06.2018, 08:20 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Почему-то мои файлы ,с названиями файл 1 и 2, система переименовала сама пока прикладывались. Тогда теперь перефраз нужен:

Помогите, пожалуйста , с решением задачки.

Есть два файла. Файл 9715425 и файл 0004725. Оба прилагаю ниже. В каждом из файлов есть общее для них - столбец ИНДЕКС

Необходимо, чтобы в файле 0004725 в столбец "зона из файла 1", который я выделил красным, прописалась собственно зона из файла 9715425 , на основании общности индексов двух файлов

Excel как бы должен опросить файл 9715425 на совпадение с индексом из файла 0004725 и на основании этого прописать в "зона из файла 1" собственно зону.
 
Ответить
СообщениеПочему-то мои файлы ,с названиями файл 1 и 2, система переименовала сама пока прикладывались. Тогда теперь перефраз нужен:

Помогите, пожалуйста , с решением задачки.

Есть два файла. Файл 9715425 и файл 0004725. Оба прилагаю ниже. В каждом из файлов есть общее для них - столбец ИНДЕКС

Необходимо, чтобы в файле 0004725 в столбец "зона из файла 1", который я выделил красным, прописалась собственно зона из файла 9715425 , на основании общности индексов двух файлов

Excel как бы должен опросить файл 9715425 на совпадение с индексом из файла 0004725 и на основании этого прописать в "зона из файла 1" собственно зону.

Автор - bagraart
Дата добавления - 05.06.2018 в 08:20
Pelena Дата: Вторник, 05.06.2018, 08:29 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12906
Репутация: 2843 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ВПР(B2;[9715425.xls]Лист1!$A$2:$F$30;6;0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ВПР(B2;[9715425.xls]Лист1!$A$2:$F$30;6;0)

Автор - Pelena
Дата добавления - 05.06.2018 в 08:29
bagraart Дата: Вторник, 05.06.2018, 09:02 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=ВПР(B2;[9715425.xls]Лист1!$A$2:$F$30;6;0)


Спасибо. А за что отвечает 6;0. в конце? Вставил функцию в файл и многое #Н/Д, а много прописалось

Я просто урезал файлы чтобы здесь на форуме уместить, так то оригиналы их огромны.
К сообщению приложен файл: 0185904.png(51.0 Kb)
 
Ответить
Сообщение
=ВПР(B2;[9715425.xls]Лист1!$A$2:$F$30;6;0)


Спасибо. А за что отвечает 6;0. в конце? Вставил функцию в файл и многое #Н/Д, а много прописалось

Я просто урезал файлы чтобы здесь на форуме уместить, так то оригиналы их огромны.

Автор - bagraart
Дата добавления - 05.06.2018 в 09:02
китин Дата: Вторник, 05.06.2018, 09:06 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4956
Репутация: 790 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
А за что отвечает 6;0. в конце?

а справку по ВПР почитать?
К сообщению приложен файл: 5712789.gif(23.2 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
А за что отвечает 6;0. в конце?

а справку по ВПР почитать?

Автор - китин
Дата добавления - 05.06.2018 в 09:06
Pelena Дата: Вторник, 05.06.2018, 09:17 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12906
Репутация: 2843 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
многое #Н/Д

значит, индекс не найден


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
многое #Н/Д

значит, индекс не найден

Автор - Pelena
Дата добавления - 05.06.2018 в 09:17
bagraart Дата: Вторник, 05.06.2018, 09:24 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Это то я смог интерпретировать. Но он там есть, вот в чем прикол
 
Ответить
СообщениеЭто то я смог интерпретировать. Но он там есть, вот в чем прикол

Автор - bagraart
Дата добавления - 05.06.2018 в 09:24
китин Дата: Вторник, 05.06.2018, 09:26 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4956
Репутация: 790 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну дык покажите ваш файл с ошибкой


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену дык покажите ваш файл с ошибкой

Автор - китин
Дата добавления - 05.06.2018 в 09:26
bagraart Дата: Вторник, 05.06.2018, 09:45 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Каким образом это лучше сделать? Ведь тут ограничения по 100 кб. А мои файлы оба свыше 10 мб

Могу попробовать скринами
 
Ответить
СообщениеКаким образом это лучше сделать? Ведь тут ограничения по 100 кб. А мои файлы оба свыше 10 мб

Могу попробовать скринами

Автор - bagraart
Дата добавления - 05.06.2018 в 09:45
bagraart Дата: Вторник, 05.06.2018, 09:48 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
вот так разве
К сообщению приложен файл: 9689277.png(248.4 Kb) · 8866072.png(149.5 Kb)
 
Ответить
Сообщениевот так разве

Автор - bagraart
Дата добавления - 05.06.2018 в 09:48
Pelena Дата: Вторник, 05.06.2018, 09:55 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12906
Репутация: 2843 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Оставьте строки, где, по-вашему, есть нужные индексы, но формула при этом даёт ошибку. Скорей всего, там пробелы лишние или число сохранено как текст, на скринах не видно.
Хотя, попробуйте так
Код
=ВПР(B2&"";[9715425.xls]Лист1!$A$2:$F$30;6;0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеОставьте строки, где, по-вашему, есть нужные индексы, но формула при этом даёт ошибку. Скорей всего, там пробелы лишние или число сохранено как текст, на скринах не видно.
Хотя, попробуйте так
Код
=ВПР(B2&"";[9715425.xls]Лист1!$A$2:$F$30;6;0)

Автор - Pelena
Дата добавления - 05.06.2018 в 09:55
_Boroda_ Дата: Вторник, 05.06.2018, 09:56 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12767
Репутация: 5228 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы ищете числовое значение в текстовых. Видите в первом скрине (файл 3) в столбце А зеленые такие меточки? Если подведете мышь к одной из них, то вылезет сообщение про текст. Там в этом сообщении будет возможность преобразовать все текстовые числа в нормальные
Или, чтобы не мучать себя и компьютер, выделите столбец А в файле 3 - вкладка Данные - Текст по столбцам - Готово. И то же самое на всякий случай сделайте со столбцом F в файле 4.
Или перепишите формулу так
Код
=еслиошибка(ВПР(B2;[9715425.xls]Лист1!$A$2:$F$33333;6;);ВПР(B2&"";[9715425.xls]Лист1!$A$2:$F$33333;6;))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВы ищете числовое значение в текстовых. Видите в первом скрине (файл 3) в столбце А зеленые такие меточки? Если подведете мышь к одной из них, то вылезет сообщение про текст. Там в этом сообщении будет возможность преобразовать все текстовые числа в нормальные
Или, чтобы не мучать себя и компьютер, выделите столбец А в файле 3 - вкладка Данные - Текст по столбцам - Готово. И то же самое на всякий случай сделайте со столбцом F в файле 4.
Или перепишите формулу так
Код
=еслиошибка(ВПР(B2;[9715425.xls]Лист1!$A$2:$F$33333;6;);ВПР(B2&"";[9715425.xls]Лист1!$A$2:$F$33333;6;))

Автор - _Boroda_
Дата добавления - 05.06.2018 в 09:56
sboy Дата: Вторник, 05.06.2018, 09:56 | Сообщение № 13
Группа: Проверенные
Ранг: Старожил
Сообщений: 2020
Репутация: 578 ±
Замечаний: 0% ±

Excel 2010
На скринах видно, что текст
в файле 1, выделите столбец А, кнопка "Текст по столбцам" - Готово
 
Ответить
СообщениеНа скринах видно, что текст
в файле 1, выделите столбец А, кнопка "Текст по столбцам" - Готово

Автор - sboy
Дата добавления - 05.06.2018 в 09:56
bagraart Дата: Вторник, 05.06.2018, 10:13 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=ВПР(B2;[9715425.xls]Лист1!$A$2:$F$30;6;0)

Да, действительно. Все было так просто. Когда знаешь. И так сложно для меня))

ОГРОМНООООЕ всем спасибо, ребята! Базируясь на комментарии каждого из вас лишь удалось все исправить. Будьте здоровы!
 
Ответить
Сообщение
=ВПР(B2;[9715425.xls]Лист1!$A$2:$F$30;6;0)

Да, действительно. Все было так просто. Когда знаешь. И так сложно для меня))

ОГРОМНООООЕ всем спасибо, ребята! Базируясь на комментарии каждого из вас лишь удалось все исправить. Будьте здоровы!

Автор - bagraart
Дата добавления - 05.06.2018 в 10:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ПОДСТАНОВКА ЗНАЧЕНИЯ из иного файла (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!