Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/При вводе аргументов изменяется условие запроса - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При вводе аргументов изменяется условие запроса (Формулы/Formulas)
При вводе аргументов изменяется условие запроса
Gopronotmore Дата: Пятница, 08.06.2018, 14:33 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Добрый день, подскажите, как правильно сделать пример.

Если вводить аргументы по порядку то все получается, а как модернизировать что бы начиная со 2 аргумента просил ввести 1 и 3 и так же начиная с 3 просил ввести 1 и 2
К сообщению приложен файл: task2.xlsx(8.6 Kb)
 
Ответить
СообщениеДобрый день, подскажите, как правильно сделать пример.

Если вводить аргументы по порядку то все получается, а как модернизировать что бы начиная со 2 аргумента просил ввести 1 и 3 и так же начиная с 3 просил ввести 1 и 2

Автор - Gopronotmore
Дата добавления - 08.06.2018 в 14:33
abtextime Дата: Пятница, 08.06.2018, 14:47 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 797
Репутация: 113 ±
Замечаний: 0% ±

Excel 2010
Так не подойдет?

Код
=ЕСЛИ(ЕСЛИ(A2="";$A$1;"")&ЕСЛИ(B2="";$B$1;"")&ЕСЛИ(C2="";$C$1;"")="";A2*B2*C2;"Введите данные в столбцы: "&ЕСЛИ(A2="";$A$1;"")&ЕСЛИ(B2="";$B$1;"")&ЕСЛИ(C2="";$C$1;""))
К сообщению приложен файл: 1121757.xlsx(8.5 Kb)
 
Ответить
СообщениеТак не подойдет?

Код
=ЕСЛИ(ЕСЛИ(A2="";$A$1;"")&ЕСЛИ(B2="";$B$1;"")&ЕСЛИ(C2="";$C$1;"")="";A2*B2*C2;"Введите данные в столбцы: "&ЕСЛИ(A2="";$A$1;"")&ЕСЛИ(B2="";$B$1;"")&ЕСЛИ(C2="";$C$1;""))

Автор - abtextime
Дата добавления - 08.06.2018 в 14:47
Gopronotmore Дата: Пятница, 08.06.2018, 14:56 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
abtextime, спасибо, это один из вариантов, а что бы писал по порядку т.е. заполните a, заполните с
 
Ответить
Сообщениеabtextime, спасибо, это один из вариантов, а что бы писал по порядку т.е. заполните a, заполните с

Автор - Gopronotmore
Дата добавления - 08.06.2018 в 14:56
Gopronotmore Дата: Пятница, 08.06.2018, 15:21 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Вот как нить можно их соединить ? или никак ?
К сообщению приложен файл: task3.xlsx(8.6 Kb)
 
Ответить
СообщениеВот как нить можно их соединить ? или никак ?

Автор - Gopronotmore
Дата добавления - 08.06.2018 в 15:21
abtextime Дата: Пятница, 08.06.2018, 15:35 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 797
Репутация: 113 ±
Замечаний: 0% ±

Excel 2010
Gopronotmore,

ни у кого нет желания встраивать тупую матрицу значений в формулу

Лично я бы так сделал

Код
=ЕСЛИОШИБКА(ВПР(ЕСЛИ(ЕЧИСЛО(A2);"";$A$1)&ЕСЛИ(ЕЧИСЛО(B2);"";$B$1)&ЕСЛИ(ЕЧИСЛО(C2);"";$C$1);Лист1!$A$3:$B$9;2;0);A2*B2*C2)


И настраивай свои сообщения как угодно
 
Ответить
СообщениеGopronotmore,

ни у кого нет желания встраивать тупую матрицу значений в формулу

Лично я бы так сделал

Код
=ЕСЛИОШИБКА(ВПР(ЕСЛИ(ЕЧИСЛО(A2);"";$A$1)&ЕСЛИ(ЕЧИСЛО(B2);"";$B$1)&ЕСЛИ(ЕЧИСЛО(C2);"";$C$1);Лист1!$A$3:$B$9;2;0);A2*B2*C2)


И настраивай свои сообщения как угодно

Автор - abtextime
Дата добавления - 08.06.2018 в 15:35
_Boroda_ Дата: Пятница, 08.06.2018, 19:21 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12400
Репутация: 5092 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Иван, не очень понял что Вы хотите, посмотрите такой вариант формулами, Условным форматированием и макросом небольшим
К сообщению приложен файл: task3_1.xlsm(15.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИван, не очень понял что Вы хотите, посмотрите такой вариант формулами, Условным форматированием и макросом небольшим

Автор - _Boroda_
Дата добавления - 08.06.2018 в 19:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При вводе аргументов изменяется условие запроса (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!