Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт товара за неделю - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт товара за неделю (Формулы/Formulas)
Подсчёт товара за неделю
vitek73 Дата: Суббота, 09.06.2018, 09:27 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 33
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
День добрый, такой вопрос,
как можно реализовать подсчёт?
столб "А" подсчёт количество номеров 1( или номеров 2) за неделю, но за одну неделю,и каждую новую неделю своя сумма по количеству номеров
К сообщению приложен файл: 090618.xlsx(10.6 Kb)


vitёk73
 
Ответить
СообщениеДень добрый, такой вопрос,
как можно реализовать подсчёт?
столб "А" подсчёт количество номеров 1( или номеров 2) за неделю, но за одну неделю,и каждую новую неделю своя сумма по количеству номеров

Автор - vitek73
Дата добавления - 09.06.2018 в 09:27
sboy Дата: Суббота, 09.06.2018, 09:53 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2013
Репутация: 576 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Вариант с доп.столбцом
Код
=НОМНЕДЕЛИ(--ПСТР(C4;4;10))

и формула
Код
=ЕСЛИ(D4<>D3;СЧЁТЕСЛИ($D$4:$D$61;D4);"")
К сообщению приложен файл: 2087126.xlsx(12.0 Kb)
 
Ответить
СообщениеДобрый день.
Вариант с доп.столбцом
Код
=НОМНЕДЕЛИ(--ПСТР(C4;4;10))

и формула
Код
=ЕСЛИ(D4<>D3;СЧЁТЕСЛИ($D$4:$D$61;D4);"")

Автор - sboy
Дата добавления - 09.06.2018 в 09:53
vitek73 Дата: Суббота, 09.06.2018, 10:26 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 33
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Вариант с доп.столбцом

Спасибо, я совсем забыл что ексель считает недели ,)


vitёk73
 
Ответить
Сообщение
Вариант с доп.столбцом

Спасибо, я совсем забыл что ексель считает недели ,)

Автор - vitek73
Дата добавления - 09.06.2018 в 10:26
Светлый Дата: Суббота, 09.06.2018, 11:15 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 559
Репутация: 131 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
Массивная:
Код
=ЕСЛИ(ЕОШ(1/(НОМНЕДЕЛИ(ПРАВБ(C4;9))=НОМНЕДЕЛИ(ПРАВБ(C3;9))));СЧЁТ(1/(НОМНЕДЕЛИ(ПРАВБ(C4;9))=НОМНЕДЕЛИ(ПРАВБ(C4:C98;9))));"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Массивная:
Код
=ЕСЛИ(ЕОШ(1/(НОМНЕДЕЛИ(ПРАВБ(C4;9))=НОМНЕДЕЛИ(ПРАВБ(C3;9))));СЧЁТ(1/(НОМНЕДЕЛИ(ПРАВБ(C4;9))=НОМНЕДЕЛИ(ПРАВБ(C4:C98;9))));"")

Автор - Светлый
Дата добавления - 09.06.2018 в 11:15
_Boroda_ Дата: Суббота, 09.06.2018, 19:59 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12744
Репутация: 5226 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Светлый, sboy, в 2018 году 1 января - понедельник. Повезло. А давайте посчитаем для другого года, например, для 2021?
Предлагаю такой неоптимизированный вариант
Код
=ЕСЛИ(ПРАВБ(I4;9)-ДЕНЬНЕД(ПРАВБ(I4;9);3)=ПРАВБ(0&I3;9)-ДЕНЬНЕД(ПРАВБ(0&I3;9);3);"";СУММПРОИЗВ(--(ПРАВБ(0&I$4:I$99;9)-ДЕНЬНЕД(ПРАВБ(0&I$4:I$99;9);3)=ПРАВБ(I4;9)-ДЕНЬНЕД(ПРАВБ(I4;9);3))))
К сообщению приложен файл: 090618_1.xlsx(16.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСветлый, sboy, в 2018 году 1 января - понедельник. Повезло. А давайте посчитаем для другого года, например, для 2021?
Предлагаю такой неоптимизированный вариант
Код
=ЕСЛИ(ПРАВБ(I4;9)-ДЕНЬНЕД(ПРАВБ(I4;9);3)=ПРАВБ(0&I3;9)-ДЕНЬНЕД(ПРАВБ(0&I3;9);3);"";СУММПРОИЗВ(--(ПРАВБ(0&I$4:I$99;9)-ДЕНЬНЕД(ПРАВБ(0&I$4:I$99;9);3)=ПРАВБ(I4;9)-ДЕНЬНЕД(ПРАВБ(I4;9);3))))

Автор - _Boroda_
Дата добавления - 09.06.2018 в 19:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт товара за неделю (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!