Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Назначение случайного соперника при моделировании сетки. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Назначение случайного соперника при моделировании сетки. (Формулы/Formulas)
Назначение случайного соперника при моделировании сетки.
Zerot Дата: Воскресенье, 22.07.2018, 13:34 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день, форумчане.

При организации очередного третьего любительского турнира по известной МОВА-игре, столкнулся с проблемой...что зарегистрированных команд становится слишком много.
И назначать соперника ручками становиться слишком трудоёмко.

Что нам дано:
24 команды, у каждой из которой определенное кол-во очков (столбцы A и S)
Названия команд в объединенных столбцах Z

Вопрос: как сделать так чтобы пары команд которые имеют кол-во очков больше нуля, формировались автоматически в соответсвующих полях сетки, НЕ повторяя друг друг, т.е. чтобы не было задвоений.
К сообщению приложен файл: __JST1.5-1-.xlsx(27.4 Kb)
 
Ответить
СообщениеДобрый день, форумчане.

При организации очередного третьего любительского турнира по известной МОВА-игре, столкнулся с проблемой...что зарегистрированных команд становится слишком много.
И назначать соперника ручками становиться слишком трудоёмко.

Что нам дано:
24 команды, у каждой из которой определенное кол-во очков (столбцы A и S)
Названия команд в объединенных столбцах Z

Вопрос: как сделать так чтобы пары команд которые имеют кол-во очков больше нуля, формировались автоматически в соответсвующих полях сетки, НЕ повторяя друг друг, т.е. чтобы не было задвоений.

Автор - Zerot
Дата добавления - 22.07.2018 в 13:34
dude Дата: Воскресенье, 22.07.2018, 18:38 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 12 ±
Замечаний: 20% ±

2016
что делать, если кол-во команд нечетное?
Один проигрыш равно выбытие?
 
Ответить
Сообщениечто делать, если кол-во команд нечетное?
Один проигрыш равно выбытие?

Автор - dude
Дата добавления - 22.07.2018 в 18:38
Zerot Дата: Воскресенье, 22.07.2018, 19:26 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Если нечетное - одна команда отдыхает, ей не назначается соперник.
У нас сложилось что лучше всего что у команды есть 2 очка.
Т.е. 2 поражения - выбытие.
 
Ответить
СообщениеЕсли нечетное - одна команда отдыхает, ей не назначается соперник.
У нас сложилось что лучше всего что у команды есть 2 очка.
Т.е. 2 поражения - выбытие.

Автор - Zerot
Дата добавления - 22.07.2018 в 19:26
dude Дата: Воскресенье, 22.07.2018, 20:31 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 12 ±
Замечаний: 20% ±

2016
То есть автоматом переходит в следующий круг?
 
Ответить
СообщениеТо есть автоматом переходит в следующий круг?

Автор - dude
Дата добавления - 22.07.2018 в 20:31
Zerot Дата: Воскресенье, 22.07.2018, 21:57 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
То есть автоматом переходит в следующий круг?

Всё верно
 
Ответить
Сообщение
То есть автоматом переходит в следующий круг?

Всё верно

Автор - Zerot
Дата добавления - 22.07.2018 в 21:57
dude Дата: Понедельник, 23.07.2018, 11:41 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 12 ±
Замечаний: 20% ±

2016
как-то так
в столбцах "резул" вместо формул
Код
=ЕСЛИ(ЕЧИСЛО(F4);СЛУЧМЕЖДУ(0;5);"")

нужно вводить результат
К сообщению приложен файл: 3693847.xlsx(79.1 Kb)
 
Ответить
Сообщениекак-то так
в столбцах "резул" вместо формул
Код
=ЕСЛИ(ЕЧИСЛО(F4);СЛУЧМЕЖДУ(0;5);"")

нужно вводить результат

Автор - dude
Дата добавления - 23.07.2018 в 11:41
pabchek Дата: Понедельник, 23.07.2018, 14:55 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 213 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
У меня вариант с допстолбцами. Комбинация формул
Код
=СЛУЧМЕЖДУ(1;СЧЁТЕСЛИ($AA$6:$AA$50;"*"))+(СТРОКА()/100)

Код
=РАНГ(AB6;$AB$6:$AB$37)

ну и
Код
=ИНДЕКС($AA$6:$AA$37;ПОИСКПОЗ(C3;$AC$6:$AC$37;0))

смотрите.
К сообщению приложен файл: 9790568.xlsx(28.8 Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеЗдравствуйте!
У меня вариант с допстолбцами. Комбинация формул
Код
=СЛУЧМЕЖДУ(1;СЧЁТЕСЛИ($AA$6:$AA$50;"*"))+(СТРОКА()/100)

Код
=РАНГ(AB6;$AB$6:$AB$37)

ну и
Код
=ИНДЕКС($AA$6:$AA$37;ПОИСКПОЗ(C3;$AC$6:$AC$37;0))

смотрите.

Автор - pabchek
Дата добавления - 23.07.2018 в 14:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Назначение случайного соперника при моделировании сетки. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!