Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных по дате - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных по дате (Формулы/Formulas)
Перенос данных по дате
Sany Дата: Пятница, 27.07.2018, 10:34 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток, ребят подскажите какую формулу применить к переносу данных из листа в лист по дате (точнее в вкладке "лист 2" при выборе месяца года в выпадающем списке, нужно что бы автоматически переносились данные из листа 1 (поле месяца года)
Произвести перенос просто формулой не получается так как при смене месяца года ссылка не меняется
Код
=ВПР($A8;'Лист 1'!$A:$BB;25;0)

Вопрос: как и куда добавить аргументы на даты или месяц?
К сообщению приложен файл: 3452054.xlsx(81.1 Kb)
 
Ответить
СообщениеДоброго времени суток, ребят подскажите какую формулу применить к переносу данных из листа в лист по дате (точнее в вкладке "лист 2" при выборе месяца года в выпадающем списке, нужно что бы автоматически переносились данные из листа 1 (поле месяца года)
Произвести перенос просто формулой не получается так как при смене месяца года ссылка не меняется
Код
=ВПР($A8;'Лист 1'!$A:$BB;25;0)

Вопрос: как и куда добавить аргументы на даты или месяц?

Автор - Sany
Дата добавления - 27.07.2018 в 10:34
sboy Дата: Пятница, 27.07.2018, 11:42 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2009
Репутация: 575 ±
Замечаний: 0% ±

Excel 2010
У вас в файле только один месяц на листе1
 
Ответить
СообщениеУ вас в файле только один месяц на листе1

Автор - sboy
Дата добавления - 27.07.2018 в 11:42
Sany Дата: Пятница, 27.07.2018, 11:54 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добавил месяцы по декабрь
К сообщению приложен файл: 9281579.xlsx(84.3 Kb)


Сообщение отредактировал Sany - Пятница, 27.07.2018, 11:59
 
Ответить
СообщениеДобавил месяцы по декабрь

Автор - Sany
Дата добавления - 27.07.2018 в 11:54
sboy Дата: Пятница, 27.07.2018, 12:19 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 2009
Репутация: 575 ±
Замечаний: 0% ±

Excel 2010
Вот такой вариант
Код
=ВПР($A8;'Лист 1'!$A$8:$ID$999;25+J$3-43252;0)

он же, сокращенный
Код
=ВПР($A8;'Лист 1'!$A$8:$ID$999;J$3-43227;0)
К сообщению приложен файл: 3623202.xlsx(83.0 Kb)
 
Ответить
СообщениеВот такой вариант
Код
=ВПР($A8;'Лист 1'!$A$8:$ID$999;25+J$3-43252;0)

он же, сокращенный
Код
=ВПР($A8;'Лист 1'!$A$8:$ID$999;J$3-43227;0)

Автор - sboy
Дата добавления - 27.07.2018 в 12:19
китин Дата: Пятница, 27.07.2018, 12:22 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4949
Репутация: 790 ±
Замечаний: 0% ±

Excel 2007;Excel 2010


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]Сергей а там в разделе работа

Автор - китин
Дата добавления - 27.07.2018 в 12:22
sboy Дата: Пятница, 27.07.2018, 12:27 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 2009
Репутация: 575 ±
Замечаний: 0% ±

Excel 2010
[offtop] китин, там не тусю)
 
Ответить
Сообщение[offtop] китин, там не тусю)

Автор - sboy
Дата добавления - 27.07.2018 в 12:27
Sany Дата: Пятница, 27.07.2018, 12:30 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
В примере работает отменно, спасибо!
 
Ответить
СообщениеВ примере работает отменно, спасибо!

Автор - Sany
Дата добавления - 27.07.2018 в 12:30
Sany Дата: Понедельник, 30.07.2018, 10:32 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброе утро!
Подскажите, что означает аргумент 43252 или 43227 в формуле:
Код
=ВПР($A8;'Лист 1'!$A$8:$ID$999;J$3-43227;0)

Код
=ВПР($A8;'Лист 1'!$A$8:$ID$999;25+J$3-43252;0)


Сообщение отредактировал Sany - Понедельник, 30.07.2018, 10:34
 
Ответить
СообщениеДоброе утро!
Подскажите, что означает аргумент 43252 или 43227 в формуле:
Код
=ВПР($A8;'Лист 1'!$A$8:$ID$999;J$3-43227;0)

Код
=ВПР($A8;'Лист 1'!$A$8:$ID$999;25+J$3-43252;0)

Автор - Sany
Дата добавления - 30.07.2018 в 10:32
sboy Дата: Понедельник, 30.07.2018, 11:06 | Сообщение № 9
Группа: Проверенные
Ранг: Старожил
Сообщений: 2009
Репутация: 575 ±
Замечаний: 0% ±

Excel 2010
43252 это 1 июня 2018г (с этой даты начинается ваша таблица)
25 это первый столбец с данными для ВПР
соответственно, к 25 прибавляем разницу между датами.
Математически сокращаем 43252-25=43227
 
Ответить
Сообщение43252 это 1 июня 2018г (с этой даты начинается ваша таблица)
25 это первый столбец с данными для ВПР
соответственно, к 25 прибавляем разницу между датами.
Математически сокращаем 43252-25=43227

Автор - sboy
Дата добавления - 30.07.2018 в 11:06
Sany Дата: Понедельник, 30.07.2018, 11:09 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - Sany
Дата добавления - 30.07.2018 в 11:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных по дате (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!