Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование данных с нескольких листов по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование данных с нескольких листов по условию (Формулы/Formulas)
Суммирование данных с нескольких листов по условию
klgfinn Дата: Пятница, 27.07.2018, 11:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем доброго дня.
Помогите, пожалуйста, оптимизировать формулы, если это возможно, или совсем переписать их.
По задумке на нескольких листах есть диапазоны наименований, взятые с листа Результат (Лист1:5 столбец А), и к этим наименования есть две группы числовых значений (Лист1:5 столбец В и С). Наименования в столбце А на листах 1:5 находятся в произвольном порядке, не повторяются в одном диапазоне и повторяются в разных диапазонах, на любом листе может быть несколько таких диапазонов (пример - Лист2), ячейки в В и С на листах 1:5 могут быть пустыми. На листе Результат связки функций ИНДЕКС и ПОИСКПОЗ в столбце В проходят по значениям столбцов В листов 1:5, в столбце С соответственно по С. В столбце D они суммируются и округляются. ЕСЛИОШИБКА нужна для случаев, когда на листах 1:5 есть незаполненные ячейки в В или С.
Вот формулы листа Результат и требуют оптимизации или полной переработки. Здесь в примере они работают с шестью диапазонами, а в реальной таблице диапазонов больше 30. Конечно всё оно работает и работает правильно, но хочется сделать это красивее. В идеале, что бы на листе Результат всё происходило в одном столбце, а не в трёх. Сейчас поделено на три только из-за громоздкости всей конструкции и ограничения на количество аргументов или чего-то там ещё... Суммирование двух диапазонов В и С должно происходить на листе Результат.
Работает вся эта красота под Excel 2007. При решении хочется обойтись без макросов, а вот против массивов ничего не имею.
К сообщению приложен файл: 3714639.xlsx(15.3 Kb)


Сообщение отредактировал klgfinn - Пятница, 27.07.2018, 12:59
 
Ответить
СообщениеВсем доброго дня.
Помогите, пожалуйста, оптимизировать формулы, если это возможно, или совсем переписать их.
По задумке на нескольких листах есть диапазоны наименований, взятые с листа Результат (Лист1:5 столбец А), и к этим наименования есть две группы числовых значений (Лист1:5 столбец В и С). Наименования в столбце А на листах 1:5 находятся в произвольном порядке, не повторяются в одном диапазоне и повторяются в разных диапазонах, на любом листе может быть несколько таких диапазонов (пример - Лист2), ячейки в В и С на листах 1:5 могут быть пустыми. На листе Результат связки функций ИНДЕКС и ПОИСКПОЗ в столбце В проходят по значениям столбцов В листов 1:5, в столбце С соответственно по С. В столбце D они суммируются и округляются. ЕСЛИОШИБКА нужна для случаев, когда на листах 1:5 есть незаполненные ячейки в В или С.
Вот формулы листа Результат и требуют оптимизации или полной переработки. Здесь в примере они работают с шестью диапазонами, а в реальной таблице диапазонов больше 30. Конечно всё оно работает и работает правильно, но хочется сделать это красивее. В идеале, что бы на листе Результат всё происходило в одном столбце, а не в трёх. Сейчас поделено на три только из-за громоздкости всей конструкции и ограничения на количество аргументов или чего-то там ещё... Суммирование двух диапазонов В и С должно происходить на листе Результат.
Работает вся эта красота под Excel 2007. При решении хочется обойтись без макросов, а вот против массивов ничего не имею.

Автор - klgfinn
Дата добавления - 27.07.2018 в 11:47
sboy Дата: Пятница, 27.07.2018, 12:06 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2020
Репутация: 578 ±
Замечаний: 0% ±

Excel 2010
Исправьте название темы, оно должно отражать суть вопроса
 
Ответить
СообщениеИсправьте название темы, оно должно отражать суть вопроса

Автор - sboy
Дата добавления - 27.07.2018 в 12:06
klgfinn Дата: Пятница, 27.07.2018, 12:19 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
sboy, да я с удовольствием, но на какое? Не срабатывает у меня соображалка, как обозвать тему с таким вопросом и уместить всё это в отведённое количество знаков в названии темы?
 
Ответить
Сообщениеsboy, да я с удовольствием, но на какое? Не срабатывает у меня соображалка, как обозвать тему с таким вопросом и уместить всё это в отведённое количество знаков в названии темы?

Автор - klgfinn
Дата добавления - 27.07.2018 в 12:19
sboy Дата: Пятница, 27.07.2018, 12:20 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 2020
Репутация: 578 ±
Замечаний: 0% ±

Excel 2010
Подсказка: что формула должна сделать? ;)
 
Ответить
СообщениеПодсказка: что формула должна сделать? ;)

Автор - sboy
Дата добавления - 27.07.2018 в 12:20
sboy Дата: Пятница, 27.07.2018, 13:37 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 2020
Репутация: 578 ±
Замечаний: 0% ±

Excel 2010
Вот такой лобовой вариант
Код
=СУММЕСЛИ(Лист1!$A:$A;$A2;Лист1!B:B)+СУММЕСЛИ(Лист2!$A:$A;$A2;Лист2!B:B)+СУММЕСЛИ(Лист3!$A:$A;$A2;Лист3!B:B)+СУММЕСЛИ(Лист4!$A:$A;$A2;Лист4!B:B)+СУММЕСЛИ(Лист5!$A:$A;$A2;Лист5!B:B)
К сообщению приложен файл: 4135529.xlsx(18.8 Kb)
 
Ответить
СообщениеВот такой лобовой вариант
Код
=СУММЕСЛИ(Лист1!$A:$A;$A2;Лист1!B:B)+СУММЕСЛИ(Лист2!$A:$A;$A2;Лист2!B:B)+СУММЕСЛИ(Лист3!$A:$A;$A2;Лист3!B:B)+СУММЕСЛИ(Лист4!$A:$A;$A2;Лист4!B:B)+СУММЕСЛИ(Лист5!$A:$A;$A2;Лист5!B:B)

Автор - sboy
Дата добавления - 27.07.2018 в 13:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование данных с нескольких листов по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!