Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отклонение от предыдущего периода с учетом пропусков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отклонение от предыдущего периода с учетом пропусков (Формулы/Formulas)
Отклонение от предыдущего периода с учетом пропусков
CrazyNice Дата: Воскресенье, 29.07.2018, 12:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 RUS
Добрый день!

Помогите, пожалуйста, с формулой.
В отчете нужно прописать отклонение от предыдущего периода (некоторые периоды пропущены), а в конце формула должна считать отклонение последнего периода от первого.
Формула должна учитывать возможное удаление или добавление строк.
С макросами не работаю( нужно просто формулой прописать.

Мини пример во вложении.

Заранее большое спасибо!
К сообщению приложен файл: ____.xlsx(9.1 Kb)
 
Ответить
СообщениеДобрый день!

Помогите, пожалуйста, с формулой.
В отчете нужно прописать отклонение от предыдущего периода (некоторые периоды пропущены), а в конце формула должна считать отклонение последнего периода от первого.
Формула должна учитывать возможное удаление или добавление строк.
С макросами не работаю( нужно просто формулой прописать.

Мини пример во вложении.

Заранее большое спасибо!

Автор - CrazyNice
Дата добавления - 29.07.2018 в 12:43
Светлый Дата: Воскресенье, 29.07.2018, 14:46 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 652
Репутация: 176 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Можно вот такой массивной формулой:
Код
=ЕСЛИ(C14;C14-ИНДЕКС(C:C;МАКС(ЕЧИСЛО(C$12:C13)*СТРОКА($12:13)));"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Можно вот такой массивной формулой:
Код
=ЕСЛИ(C14;C14-ИНДЕКС(C:C;МАКС(ЕЧИСЛО(C$12:C13)*СТРОКА($12:13)));"")

Автор - Светлый
Дата добавления - 29.07.2018 в 14:46
_Boroda_ Дата: Воскресенье, 29.07.2018, 15:38 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13196
Репутация: 5426 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты обычными формулами
Код
=ЕСЛИ(C14;C14-ПРОСМОТР(;-1/(C13:C$13>0);C13:C$13);"")

Код
=ЕСЛИ(C14;C14+1/ПРОСМОТР(;-1/C$13:C13);"")

Первый лучше - во втором не обязательно, но могут быть ошибки в округлении (например, не 128, а 127,9999999998)
Отклонение за весь период
Код
=СУММ(D13:D24)
К сообщению приложен файл: _1.xlsx(9.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты обычными формулами
Код
=ЕСЛИ(C14;C14-ПРОСМОТР(;-1/(C13:C$13>0);C13:C$13);"")

Код
=ЕСЛИ(C14;C14+1/ПРОСМОТР(;-1/C$13:C13);"")

Первый лучше - во втором не обязательно, но могут быть ошибки в округлении (например, не 128, а 127,9999999998)
Отклонение за весь период
Код
=СУММ(D13:D24)

Автор - _Boroda_
Дата добавления - 29.07.2018 в 15:38
Светлый Дата: Воскресенье, 29.07.2018, 16:10 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 652
Репутация: 176 ±
Замечаний: 0% ±

Excel 2010
Обычная формула:
Код
=ЕСЛИ(C14;C14-ИНДЕКС(C:C;ПОИСКПОЗ(9^9;C$1:C13));"")

И с автоопределением конца списка:
Код
=ЕСЛИ(СТРОКА(C12)=ПОИСКПОЗ(9^9;C:C);C12-C$13;ЕСЛИ(C14;C14-ИНДЕКС(C:C;ПОИСКПОЗ(9^9;C$1:C13));""))
К сообщению приложен файл: 1234.xlsx(9.9 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеОбычная формула:
Код
=ЕСЛИ(C14;C14-ИНДЕКС(C:C;ПОИСКПОЗ(9^9;C$1:C13));"")

И с автоопределением конца списка:
Код
=ЕСЛИ(СТРОКА(C12)=ПОИСКПОЗ(9^9;C:C);C12-C$13;ЕСЛИ(C14;C14-ИНДЕКС(C:C;ПОИСКПОЗ(9^9;C$1:C13));""))

Автор - Светлый
Дата добавления - 29.07.2018 в 16:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отклонение от предыдущего периода с учетом пропусков (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!