Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести число из самой нижней строки с опре-нного столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести число из самой нижней строки с опре-нного столбца (Формулы/Formulas)
Вывести число из самой нижней строки с опре-нного столбца
stalber Дата: Понедельник, 30.07.2018, 21:33 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 209
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер, извиняюсь за заголовок не могу сформулировать.

В листе идут столбцы с названиями и числами, нужно найти нужное название и от него отступить вправо 5 стобцов и вывести самое нижнее число из этого столбца.

На примере проще показать, прикрепил.

Будьте любезны помогите пожалуйста.
К сообщению приложен файл: 5144298.xlsx(12.7 Kb)
 
Ответить
СообщениеДобрый вечер, извиняюсь за заголовок не могу сформулировать.

В листе идут столбцы с названиями и числами, нужно найти нужное название и от него отступить вправо 5 стобцов и вывести самое нижнее число из этого столбца.

На примере проще показать, прикрепил.

Будьте любезны помогите пожалуйста.

Автор - stalber
Дата добавления - 30.07.2018 в 21:33
Nic70y Дата: Понедельник, 30.07.2018, 21:40 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4949
Репутация: 1070 ±
Замечаний: 0% ±

Excel 2013
Код
=ВПР(9E+307;ИНДЕКС('2'!$1:$1048576;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);1)
К сообщению приложен файл: 5184574.xlsx(13.3 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ВПР(9E+307;ИНДЕКС('2'!$1:$1048576;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);1)

Автор - Nic70y
Дата добавления - 30.07.2018 в 21:40
_Boroda_ Дата: Понедельник, 30.07.2018, 22:13 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13700
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=-ПРОСМОТР(;-(ИНДЕКС('2'!A$1:BZ999;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5)&""))

Но ВПР лучше в этом случае


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=-ПРОСМОТР(;-(ИНДЕКС('2'!A$1:BZ999;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5)&""))

Но ВПР лучше в этом случае

Автор - _Boroda_
Дата добавления - 30.07.2018 в 22:13
stalber Дата: Понедельник, 06.08.2018, 22:21 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 209
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Помогите пожалуйста, условие чуть изменилось, самое нижнее число, НО не ноль, если самое нижнее это просто 0, то нужно тогда найти выше в этом столбце число которое больше 0.

Файл прикрепил.
К сообщению приложен файл: vopros_5184574.xlsx(13.0 Kb)
 
Ответить
СообщениеПомогите пожалуйста, условие чуть изменилось, самое нижнее число, НО не ноль, если самое нижнее это просто 0, то нужно тогда найти выше в этом столбце число которое больше 0.

Файл прикрепил.

Автор - stalber
Дата добавления - 06.08.2018 в 22:21
krosav4ig Дата: Понедельник, 06.08.2018, 22:53 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1735
Репутация: 728 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Код
=ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);"[=0] "))
К сообщению приложен файл: 5657439.xlsx(13.3 Kb)


(_)Õvõ(_)
 
Ответить
Сообщение
Код
=ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);"[=0] "))

Автор - krosav4ig
Дата добавления - 06.08.2018 в 22:53
stalber Дата: Понедельник, 06.08.2018, 23:06 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 209
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Спасибо, а что такое в формуле "яяя" ?
 
Ответить
СообщениеСпасибо, а что такое в формуле "яяя" ?

Автор - stalber
Дата добавления - 06.08.2018 в 23:06
krosav4ig Дата: Понедельник, 06.08.2018, 23:41 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1735
Репутация: 728 ±
Замечаний: 0% ±

Excel 2007,2010,2013


(_)Õvõ(_)
 
Ответить
Сообщениеawaddwaawddw, можно здесь почитать Поиск последней заполненной ячейки строки/столбца и возврат её значения

Автор - krosav4ig
Дата добавления - 06.08.2018 в 23:41
stalber Дата: Четверг, 09.08.2018, 23:52 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 209
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Помогите пожалуйста.
Дополнительное условие появилось, сейчас в этой формуле:
[vba]
Код
=ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);"[=0] "))
[/vba]
Если стереть все данные к которым данная формула обращается, то пишет формула в ячейке: #Н/Д

А мне нужно вывести число например 242 при условии что на листе "2" данных нет, а как только они появляются сразу уже расчёт по формуле идёт.
К сообщению приложен файл: novoe_5657439.xlsx(11.9 Kb)


Сообщение отредактировал awaddwaawddw - Четверг, 09.08.2018, 23:53
 
Ответить
СообщениеПомогите пожалуйста.
Дополнительное условие появилось, сейчас в этой формуле:
[vba]
Код
=ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);"[=0] "))
[/vba]
Если стереть все данные к которым данная формула обращается, то пишет формула в ячейке: #Н/Д

А мне нужно вывести число например 242 при условии что на листе "2" данных нет, а как только они появляются сразу уже расчёт по формуле идёт.

Автор - stalber
Дата добавления - 09.08.2018 в 23:52
krosav4ig Дата: Пятница, 10.08.2018, 05:44 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1735
Репутация: 728 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);"[=0] "));242)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Пятница, 10.08.2018, 05:44
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);"[=0] "));242)

Автор - krosav4ig
Дата добавления - 10.08.2018 в 05:44
stalber Дата: Понедельник, 29.10.2018, 14:13 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 209
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
=ЕСЛИОШИБКА(ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);"[=0] "));242)


Вопрос: почему формула отказывается работать если нужное мне данное будет прописано сразу в формуле за место ячейки F6, то есть формула не будет обращаться к ячейке F6 а в формуле будет само название прописано.

За место этой формулы:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);"[=0] "));242)

Будет формула сразу с нужным названием: Где в ней ошибка? Как правильно её оформить?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(НазваниеОдно;'2'!$1:$1;)+5);"[=0] "));242)


Объясните пожалуйста что я не правильно сделал?
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);"[=0] "));242)


Вопрос: почему формула отказывается работать если нужное мне данное будет прописано сразу в формуле за место ячейки F6, то есть формула не будет обращаться к ячейке F6 а в формуле будет само название прописано.

За место этой формулы:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(F6;'2'!$1:$1;)+5);"[=0] "));242)

Будет формула сразу с нужным названием: Где в ней ошибка? Как правильно её оформить?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ(НазваниеОдно;'2'!$1:$1;)+5);"[=0] "));242)


Объясните пожалуйста что я не правильно сделал?

Автор - stalber
Дата добавления - 29.10.2018 в 14:13
_Boroda_ Дата: Понедельник, 29.10.2018, 14:17 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13700
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Текст в кавычки засуньте
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ("НазваниеОдно";'2'!$1:$1;)+5);"[=0] "));242)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТекст в кавычки засуньте
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9E+307;--ТЕКСТ('2'!$A$1:ИНДЕКС('2'!$A:$X;ПОИСКПОЗ("яяя";'2'!$A:$A);) ИНДЕКС('2'!$A:$X;;ПОИСКПОЗ("НазваниеОдно";'2'!$1:$1;)+5);"[=0] "));242)

Автор - _Boroda_
Дата добавления - 29.10.2018 в 14:17
stalber Дата: Пятница, 07.12.2018, 02:54 | Сообщение № 12
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 209
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Доброй ночи, помогите пожалуйста формулой.

Немного другая задача: нужно просто увидеть самой нижнее число (или текст) из столбца, если же самое нижнее число это ноль то берём выше число там где не ноль, если же во всём столбце нули только то тогда проставляется ноль.
К сообщению приложен файл: zadacha_0712201.xlsx(10.2 Kb)
 
Ответить
СообщениеДоброй ночи, помогите пожалуйста формулой.

Немного другая задача: нужно просто увидеть самой нижнее число (или текст) из столбца, если же самое нижнее число это ноль то берём выше число там где не ноль, если же во всём столбце нули только то тогда проставляется ноль.

Автор - stalber
Дата добавления - 07.12.2018 в 02:54
_Boroda_ Дата: Пятница, 07.12.2018, 09:36 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13700
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(C1:C99>0);C1:C99);)
К сообщению приложен файл: 9398850.xlsx(11.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(C1:C99>0);C1:C99);)

Автор - _Boroda_
Дата добавления - 07.12.2018 в 09:36
stalber Дата: Среда, 12.12.2018, 23:19 | Сообщение № 14
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 209
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Немного другая задача: нужно просто увидеть самой нижнее число (или текст) из столбца, если же самое нижнее число это ноль то берём выше число там где не ноль, если же во всём столбце нули только, то тогда проставляется ноль.


=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(C1:C99>0);C1:C99);)

А что нужно изменить в этой формуле чтобы вывести не последнее, а предпоследнее число.
К сообщению приложен файл: zadacha_1212.xlsx(11.1 Kb)
 
Ответить
Сообщение
Немного другая задача: нужно просто увидеть самой нижнее число (или текст) из столбца, если же самое нижнее число это ноль то берём выше число там где не ноль, если же во всём столбце нули только, то тогда проставляется ноль.


=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(C1:C99>0);C1:C99);)

А что нужно изменить в этой формуле чтобы вывести не последнее, а предпоследнее число.

Автор - stalber
Дата добавления - 12.12.2018 в 23:19
_Boroda_ Дата: Четверг, 13.12.2018, 00:32 | Сообщение № 15
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13700
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
что нужно изменить в этой формуле

Всё :D
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИБОЛЬШИЙ(ЕСЛИ(C1:C99>0;СТРОКА(C1:C99));2));)

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер

Поскольку в 2007 АРГЕГАТа нет, то и не пишу с ним формулу
К сообщению приложен файл: zadacha_1212_1.xlsx(11.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
что нужно изменить в этой формуле

Всё :D
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИБОЛЬШИЙ(ЕСЛИ(C1:C99>0;СТРОКА(C1:C99));2));)

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер

Поскольку в 2007 АРГЕГАТа нет, то и не пишу с ним формулу

Автор - _Boroda_
Дата добавления - 13.12.2018 в 00:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести число из самой нижней строки с опре-нного столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!