Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выстроить строки в определенном порядке! - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выстроить строки в определенном порядке! (Формулы/Formulas)
выстроить строки в определенном порядке!
АЛЕКСАНДР1986 Дата: Понедельник, 27.08.2018, 19:56 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 153
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем добрый вечер!
Есть изначальные данные со столбца B по столбец F (красная зона)
также промежуточные данные посчитаны в зеленой зоне
то что должно получиться представлено в синей зоне
то что у меня получилось только первая колонка в оранжевой зоне!

смысл заключается в том что все строки надо выстроить в порядке органов представленных в столбце J (вроде у меня это получилось)
но в дальнейшем нужно подтянуть данные сначала первого потом второго третьего и четвертого кварталов по соответствующему органу и т.д.
а также оставшиеся колонки
К сообщению приложен файл: ___2.xlsx(23.8 Kb)
 
Ответить
СообщениеВсем добрый вечер!
Есть изначальные данные со столбца B по столбец F (красная зона)
также промежуточные данные посчитаны в зеленой зоне
то что должно получиться представлено в синей зоне
то что у меня получилось только первая колонка в оранжевой зоне!

смысл заключается в том что все строки надо выстроить в порядке органов представленных в столбце J (вроде у меня это получилось)
но в дальнейшем нужно подтянуть данные сначала первого потом второго третьего и четвертого кварталов по соответствующему органу и т.д.
а также оставшиеся колонки

Автор - АЛЕКСАНДР1986
Дата добавления - 27.08.2018 в 19:56
Nic70y Дата: Понедельник, 27.08.2018, 20:10 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4882
Репутация: 1059 ±
Замечаний: 0% ±

Excel 2013
надоели мне массивные!
доп.столбцы + впр!
К сообщению приложен файл: _2.xlsx(23.8 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениенадоели мне массивные!
доп.столбцы + впр!

Автор - Nic70y
Дата добавления - 27.08.2018 в 20:10
_Boroda_ Дата: Понедельник, 27.08.2018, 20:39 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13489
Репутация: 5522 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В столбце Н достаточно такой формулы
Код
=ЕСЛИ(F6="";"";-ЛЕВБ(F6;ПОИСК("[";F6)-2))
Число в скобках автоматически переводится Excel-ем в отрицательное число, ставим перед ним минус - получаем положительное
Тогда заполнить таблицу можно и без дополнительных уникальных
Код
=ИНДЕКС(B:B;(1-ОСТАТ(НАИБОЛЬШИЙ(СУММЕСЛИ($B$6:$B$42;$B$6:$B$42;$H$6:$H$42)-СТРОКА(B$6:B$42)%;СТРОКА(B1));1))/1%+0,1)&""
Можно вообще без столбца "кол-во", но тогда посложнее получится
А уникальные по возрастанию так можно
Код
=ИНДЕКС(B:B;ОСТАТ(НАИБОЛЬШИЙ(СУММЕСЛИ(B$6:B$42;B$6:B$42;H$6:H$42)+СТРОКА(B$6:B$42)%;СУММ(L$5:L5)+1);1)/1%+0,1)&""


Можно еще и другими вариантами отсортировать и отуникалить. Сейчас кто-нибудь придет и еще напишет.
Наверное (с)
К сообщению приложен файл: _2_1.xlsx(27.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ столбце Н достаточно такой формулы
Код
=ЕСЛИ(F6="";"";-ЛЕВБ(F6;ПОИСК("[";F6)-2))
Число в скобках автоматически переводится Excel-ем в отрицательное число, ставим перед ним минус - получаем положительное
Тогда заполнить таблицу можно и без дополнительных уникальных
Код
=ИНДЕКС(B:B;(1-ОСТАТ(НАИБОЛЬШИЙ(СУММЕСЛИ($B$6:$B$42;$B$6:$B$42;$H$6:$H$42)-СТРОКА(B$6:B$42)%;СТРОКА(B1));1))/1%+0,1)&""
Можно вообще без столбца "кол-во", но тогда посложнее получится
А уникальные по возрастанию так можно
Код
=ИНДЕКС(B:B;ОСТАТ(НАИБОЛЬШИЙ(СУММЕСЛИ(B$6:B$42;B$6:B$42;H$6:H$42)+СТРОКА(B$6:B$42)%;СУММ(L$5:L5)+1);1)/1%+0,1)&""


Можно еще и другими вариантами отсортировать и отуникалить. Сейчас кто-нибудь придет и еще напишет.
Наверное (с)

Автор - _Boroda_
Дата добавления - 27.08.2018 в 20:39
Nic70y Дата: Понедельник, 27.08.2018, 22:05 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4882
Репутация: 1059 ±
Замечаний: 0% ±

Excel 2013
и еще
тем же способом
+ впр!
переборщил немного,
завтра отборщу (наверное)
К сообщению приложен файл: _2-1-.xlsx(24.0 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
и еще
тем же способом
+ впр!
переборщил немного,
завтра отборщу (наверное)

Автор - Nic70y
Дата добавления - 27.08.2018 в 22:05
Nic70y Дата: Вторник, 28.08.2018, 18:33 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4882
Репутация: 1059 ±
Замечаний: 0% ±

Excel 2013
отборщил
желтое для построения итоговой таблицы в общем то не нужно
К сообщению приложен файл: _2-1-1-.xlsx(24.1 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеотборщил
желтое для построения итоговой таблицы в общем то не нужно

Автор - Nic70y
Дата добавления - 28.08.2018 в 18:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выстроить строки в определенном порядке! (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!