Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ячейка зависящая от трех факторов(данных). - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ячейка зависящая от трех факторов(данных). (Формулы/Formulas)
Ячейка зависящая от трех факторов(данных).
senjanskij Дата: Вторник, 28.08.2018, 19:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго времени суток. На листе 1 имеется таблица. Необходимо сделать так, чтобы когда вводишь число в ячейку В6 или Е6 или В3 и т.д.(т.е. количество), автоматически ячейка рядом (цвет и вид разметки) умножалась на это число. В свою очередь, число которое должно умножаться на количество, должно подтягиваться из листа 2, соответственно из ячейки в 5й строке.
К сообщению приложен файл: 4722990.xlsx(10.1 Kb)
 
Ответить
СообщениеДоброго времени суток. На листе 1 имеется таблица. Необходимо сделать так, чтобы когда вводишь число в ячейку В6 или Е6 или В3 и т.д.(т.е. количество), автоматически ячейка рядом (цвет и вид разметки) умножалась на это число. В свою очередь, число которое должно умножаться на количество, должно подтягиваться из листа 2, соответственно из ячейки в 5й строке.

Автор - senjanskij
Дата добавления - 28.08.2018 в 19:02
ASWP Дата: Вторник, 28.08.2018, 20:07 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 103
Репутация: 10 ±
Замечаний: 0% ±

Excel 2007
senjanskij, Это то, что нужно?
К сообщению приложен файл: 4722990_1.xlsx(10.4 Kb)


я знаю что ничего не знаю, но другие не знают и этого
 
Ответить
Сообщениеsenjanskij, Это то, что нужно?

Автор - ASWP
Дата добавления - 28.08.2018 в 20:07
_Boroda_ Дата: Вторник, 28.08.2018, 20:12 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12984
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для произвольного количества и расположения столбцов (до z)
Код
=СУММПРОИЗВ((ПРОСМОТР("яяя";$A$4:C$4)=ПРОСМОТР(СТОЛБЕЦ(Лист2!$B:$Z);СТОЛБЕЦ(Лист2!$B:$Z)/(Лист2!$B$3:$Z$3<>"");Лист2!$B$3:$Z$3))*(Лист2!$B$4:$Z$4=C$5)*Лист2!$B5:$Z5)*ПРОСМОТР(;-1/($A$5:B$5="шт");$A6:B6)
К сообщению приложен файл: 4722990_2.xlsx(11.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля произвольного количества и расположения столбцов (до z)
Код
=СУММПРОИЗВ((ПРОСМОТР("яяя";$A$4:C$4)=ПРОСМОТР(СТОЛБЕЦ(Лист2!$B:$Z);СТОЛБЕЦ(Лист2!$B:$Z)/(Лист2!$B$3:$Z$3<>"");Лист2!$B$3:$Z$3))*(Лист2!$B$4:$Z$4=C$5)*Лист2!$B5:$Z5)*ПРОСМОТР(;-1/($A$5:B$5="шт");$A6:B6)

Автор - _Boroda_
Дата добавления - 28.08.2018 в 20:12
senjanskij Дата: Вторник, 28.08.2018, 20:25 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Это то, что нужно?

Это больше чем то что нужно. Спасибо.
 
Ответить
Сообщение
Это то, что нужно?

Это больше чем то что нужно. Спасибо.

Автор - senjanskij
Дата добавления - 28.08.2018 в 20:25
Nic70y Дата: Вторник, 28.08.2018, 20:31 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4802
Репутация: 1037 ±
Замечаний: 0% ±

Excel 2013
Это то, что нужно?
[offtop]вот блин!
вот из-за таких "приколов" зря файл скачал.
он мне оказался не нужен.
как его закачать обратно?
[/offtop]


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Это то, что нужно?
[offtop]вот блин!
вот из-за таких "приколов" зря файл скачал.
он мне оказался не нужен.
как его закачать обратно?
[/offtop]

Автор - Nic70y
Дата добавления - 28.08.2018 в 20:31
_Boroda_ Дата: Вторник, 28.08.2018, 20:38 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12984
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Как так? Это не моя цитата вроде
Цитата _Boroda_, 28.08.2018 в 20:12, в сообщении № 3 ( писал(а)):
Это то, что нужно?


Ну ладно, это неважно. Артем, так у Вас данные вправо не будут увеличиваться? Просто моя формула рассчитана на то, что столбцы с условиями еще добавляться будут


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеКак так? Это не моя цитата вроде
Цитата _Boroda_, 28.08.2018 в 20:12, в сообщении № 3 ( писал(а)):
Это то, что нужно?


Ну ладно, это неважно. Артем, так у Вас данные вправо не будут увеличиваться? Просто моя формула рассчитана на то, что столбцы с условиями еще добавляться будут

Автор - _Boroda_
Дата добавления - 28.08.2018 в 20:38
ASWP Дата: Вторник, 28.08.2018, 20:44 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 103
Репутация: 10 ±
Замечаний: 0% ±

Excel 2007
Nic70y, [offtop]а сообщение кому адресовано?
зачем качать чужое?)[/offtop]


я знаю что ничего не знаю, но другие не знают и этого

Сообщение отредактировал ASWP - Вторник, 28.08.2018, 20:46
 
Ответить
СообщениеNic70y, [offtop]а сообщение кому адресовано?
зачем качать чужое?)[/offtop]

Автор - ASWP
Дата добавления - 28.08.2018 в 20:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ячейка зависящая от трех факторов(данных). (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!