Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет и условие по дню недели. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет и условие по дню недели. (Формулы/Formulas)
Расчет и условие по дню недели.
JonnyL Дата: Воскресенье, 09.09.2018, 17:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день уважаемые пользователи данного форума.
Обращаюсь к вам со своим вопросом так как сам уже неделю голову ломаю как это сделать и пока не выходит каменный цветок))
Суть задачи:
Есть исходная таблица (дата, кол-во, сумма, паттерн) в ней указаны так называемые сделки за день (одна строчка- одна сделка) в течении дня их может быть несколько.
И так а теперь самый главный вопрос) Необходимо собрать все исходные данные в одно целое и сделать итоговоую таблицу и главное!! по дням недели !!
Необходимо сопоставить дату с днем недели как первое условие и для некоторых задач сопоставить текстовые данные с текстовыми данными!
Главная проблема в том что я не могу понять как прописать в условии ЕСЛИ соответствие даты и дня недели!
Возможно исходя из моей писанины не особо понятно, то я специльно для форума сделал файлик пример с моей задачей)
Если кто может помогите) А то уже малость запарилси)

С уважением, Евгений
К сообщению приложен файл: Example_forum.xlsx(14.0 Kb)


Сообщение отредактировал JonnyL - Воскресенье, 09.09.2018, 17:40
 
Ответить
СообщениеДобрый день уважаемые пользователи данного форума.
Обращаюсь к вам со своим вопросом так как сам уже неделю голову ломаю как это сделать и пока не выходит каменный цветок))
Суть задачи:
Есть исходная таблица (дата, кол-во, сумма, паттерн) в ней указаны так называемые сделки за день (одна строчка- одна сделка) в течении дня их может быть несколько.
И так а теперь самый главный вопрос) Необходимо собрать все исходные данные в одно целое и сделать итоговоую таблицу и главное!! по дням недели !!
Необходимо сопоставить дату с днем недели как первое условие и для некоторых задач сопоставить текстовые данные с текстовыми данными!
Главная проблема в том что я не могу понять как прописать в условии ЕСЛИ соответствие даты и дня недели!
Возможно исходя из моей писанины не особо понятно, то я специльно для форума сделал файлик пример с моей задачей)
Если кто может помогите) А то уже малость запарилси)

С уважением, Евгений

Автор - JonnyL
Дата добавления - 09.09.2018 в 17:40
ASWP Дата: Воскресенье, 09.09.2018, 18:36 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 122
Репутация: 19 ±
Замечаний: 0% ±

Excel 2007
JonnyL, Добрый день. Сделал пример подсчета общей суммы и количества.
К сообщению приложен файл: Example_forum-3.xlsx(12.7 Kb)


я знаю что ничего не знаю, но другие не знают и этого

Сообщение отредактировал ASWP - Воскресенье, 09.09.2018, 18:45
 
Ответить
СообщениеJonnyL, Добрый день. Сделал пример подсчета общей суммы и количества.

Автор - ASWP
Дата добавления - 09.09.2018 в 18:36
JonnyL Дата: Воскресенье, 09.09.2018, 18:48 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Сделал пример максимально просто,подсчет суммы и количества, а текст также по аналогии можно сделать.


Добрый день,
Спасибо за Ваше предложение, НО в вашем примере вы создали 3 дополнительных столбца. У меня такой возможности нет так как в рабочем варианте данных порядка 15 и не хочется создавать еще 3 столбца что бы они были исключительно техническими.

В любом случае спасибо! Но жду других вариантов)
 
Ответить
Сообщение
Добрый день. Сделал пример максимально просто,подсчет суммы и количества, а текст также по аналогии можно сделать.


Добрый день,
Спасибо за Ваше предложение, НО в вашем примере вы создали 3 дополнительных столбца. У меня такой возможности нет так как в рабочем варианте данных порядка 15 и не хочется создавать еще 3 столбца что бы они были исключительно техническими.

В любом случае спасибо! Но жду других вариантов)

Автор - JonnyL
Дата добавления - 09.09.2018 в 18:48
Nic70y Дата: Воскресенье, 09.09.2018, 19:13 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4888
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ((ДЕНЬНЕД($A$3:$A$32;2)=СТРОКА(L1))*($C$3:$C$32=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(L$2;"(р)";)))*$E$3:$E$32)
и т.п.
К сообщению приложен файл: 0238230.xlsx(14.7 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((ДЕНЬНЕД($A$3:$A$32;2)=СТРОКА(L1))*($C$3:$C$32=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(L$2;"(р)";)))*$E$3:$E$32)
и т.п.

Автор - Nic70y
Дата добавления - 09.09.2018 в 19:13
JonnyL Дата: Воскресенье, 09.09.2018, 19:49 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=СУММПРОИЗВ((ДЕНЬНЕД($A$3:$A$32;2)=СТРОКА(L1))*($C$3:$C$32=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(L$2;"(р)";)))*$E$3:$E$32)


Добрый вечер,
Большое спасибо. Действительно я бы со своим уровнем не дотянул бы до такого)

Можно ли Вас попросить расписать эту формулу и что там за что отвечает? Что бы по аналогии я бы смог сделать другие пункты в рабочем варианте.

С уважением, Евгений
 
Ответить
Сообщение
=СУММПРОИЗВ((ДЕНЬНЕД($A$3:$A$32;2)=СТРОКА(L1))*($C$3:$C$32=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(L$2;"(р)";)))*$E$3:$E$32)


Добрый вечер,
Большое спасибо. Действительно я бы со своим уровнем не дотянул бы до такого)

Можно ли Вас попросить расписать эту формулу и что там за что отвечает? Что бы по аналогии я бы смог сделать другие пункты в рабочем варианте.

С уважением, Евгений

Автор - JonnyL
Дата добавления - 09.09.2018 в 19:49
AlexM Дата: Воскресенье, 09.09.2018, 20:48 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3780
Репутация: 952 ±
Замечаний: 0% ±

Excel 2003
Еще вариант
Код
=СУММПРОИЗВ((ТЕКСТ($A$3:$A$32;"ДДДД")=$I3)*ЕЧИСЛО(ПОИСК($C$3:$C$32;L$2))*$E$3:$E$32)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Воскресенье, 09.09.2018, 20:53
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ((ТЕКСТ($A$3:$A$32;"ДДДД")=$I3)*ЕЧИСЛО(ПОИСК($C$3:$C$32;L$2))*$E$3:$E$32)

Автор - AlexM
Дата добавления - 09.09.2018 в 20:48
JonnyL Дата: Воскресенье, 09.09.2018, 22:23 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Еще вариант

=СУММПРОИЗВ((ТЕКСТ($A$3:$A$32;"ДДДД")=$I3)*ЕЧИСЛО(ПОИСК($C$3:$C$32;L$2))*$E$3:$E$32)


Спасибо, а если рассматривать не суммирование а счетчик? В приложенном примере указаны только суммы а в реалии есть еще пукт где нужно использовать функцию счетчик. Что тогда в этом случае лучше применить?
 
Ответить
Сообщение
Еще вариант

=СУММПРОИЗВ((ТЕКСТ($A$3:$A$32;"ДДДД")=$I3)*ЕЧИСЛО(ПОИСК($C$3:$C$32;L$2))*$E$3:$E$32)


Спасибо, а если рассматривать не суммирование а счетчик? В приложенном примере указаны только суммы а в реалии есть еще пукт где нужно использовать функцию счетчик. Что тогда в этом случае лучше применить?

Автор - JonnyL
Дата добавления - 09.09.2018 в 22:23
Nic70y Дата: Воскресенье, 09.09.2018, 22:42 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4888
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
функцию счетчик
что за функция такая?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
функцию счетчик
что за функция такая?

Автор - Nic70y
Дата добавления - 09.09.2018 в 22:42
JonnyL Дата: Воскресенье, 09.09.2018, 23:40 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
что за функция такая?


Функция СЧЁТЕСЛИ.
 
Ответить
Сообщение
что за функция такая?


Функция СЧЁТЕСЛИ.

Автор - JonnyL
Дата добавления - 09.09.2018 в 23:40
Nic70y Дата: Понедельник, 10.09.2018, 07:22 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4888
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
СУММПРОИЗВ вполне ее заменяет
диапазон ДЕНЬНЕД($A$3:$A$32;2) условия =СТРОКА(L1)
ставим -- (ИСТИНА переводим в 1, ложь в 0) и готово (считаем сколько понедельников, =СТРОКА(L2) - вторников и т.д.)
Код
=СУММПРОИЗВ(--(ДЕНЬНЕД($A$3:$A$32;2)=СТРОКА(L1)))

расписать
думаю суть понятна
(если много диапазонов (условий) перемножаем их и -- не нужны)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеСУММПРОИЗВ вполне ее заменяет
диапазон ДЕНЬНЕД($A$3:$A$32;2) условия =СТРОКА(L1)
ставим -- (ИСТИНА переводим в 1, ложь в 0) и готово (считаем сколько понедельников, =СТРОКА(L2) - вторников и т.д.)
Код
=СУММПРОИЗВ(--(ДЕНЬНЕД($A$3:$A$32;2)=СТРОКА(L1)))

расписать
думаю суть понятна
(если много диапазонов (условий) перемножаем их и -- не нужны)

Автор - Nic70y
Дата добавления - 10.09.2018 в 07:22
_Boroda_ Дата: Понедельник, 10.09.2018, 09:46 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
JonnyL, ловите одинаковыю формулу вообще для всех ячеек
Код
=СУММПРОИЗВ((ТЕКСТ($A$3:$A$32;"ДДДД")=$I3)*ЕСЛИ(ПРАВБ(J$2)=")";ЕЧИСЛО(ПОИСК($C$3:$C$32;J$2));1)*ЕСЛИ(ЕЧИСЛО(ПОИСК("-";J$2));$B$3:$B$32;$E$3:$E$32))

Пояснялка
1. ТЕКСТ($A$3:$A$32;"ДДДД") - делает из дат названия дней недели в буквенном виде.
2. ТЕКСТ($A$3:$A$32;"ДДДД")=$I3 - приравниваем п.1 к нужному дню недели, получаем массив из ИСТИНА и ЛОЖЬ

3. ПОИСК($C$3:$C$32;J$2) - ищем каждый элемент массива $C$3:$C$32 в ячейке J2. Если нашли, то будет номер вхождения, если не нашли, то ошибка. Все это, конечно, тоже в массиве
4. ЕЧИСЛО(ПОИСК($C$3:$C$32;J$2)) - если в п.3 число, то ИСТИНА, если ошибка, то ЛОЖЬ
5. ПРАВБ(J$2)=")" - ПРАВБ для неазиатских символов это то же самое, что и ПРАВСИМБ, только запись короче. Ищем один правый символ и сравниваем его с закрывающейся скобкой.
6. ЕСЛИ(ПРАВБ(J$2)=")";ЕЧИСЛО(ПОИСК($C$3:$C$32;J$2));1) - если в п.5 ИСТИНА, , то проверяем еще и на паттерн (см. п.4), если ЛОЖЬ, то это общее значение

7. ЕЧИСЛО(ПОИСК("-";J$2)) - см. пояснялку для п.4 - ищем тире в J2.
8. ЕСЛИ(ЕЧИСЛО(ПОИСК("-";J$2));$B$3:$B$32;$E$3:$E$32) - если в п.7 ИСТИНА, то это количество, если ЛОЖЬ, то сумма

9. Перемножаем массивы из пунктов 2, 6 и 8 и складываем полученное с помощью СУММПРОИЗВ
К сообщению приложен файл: Example_forum_1.xlsx(14.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеJonnyL, ловите одинаковыю формулу вообще для всех ячеек
Код
=СУММПРОИЗВ((ТЕКСТ($A$3:$A$32;"ДДДД")=$I3)*ЕСЛИ(ПРАВБ(J$2)=")";ЕЧИСЛО(ПОИСК($C$3:$C$32;J$2));1)*ЕСЛИ(ЕЧИСЛО(ПОИСК("-";J$2));$B$3:$B$32;$E$3:$E$32))

Пояснялка
1. ТЕКСТ($A$3:$A$32;"ДДДД") - делает из дат названия дней недели в буквенном виде.
2. ТЕКСТ($A$3:$A$32;"ДДДД")=$I3 - приравниваем п.1 к нужному дню недели, получаем массив из ИСТИНА и ЛОЖЬ

3. ПОИСК($C$3:$C$32;J$2) - ищем каждый элемент массива $C$3:$C$32 в ячейке J2. Если нашли, то будет номер вхождения, если не нашли, то ошибка. Все это, конечно, тоже в массиве
4. ЕЧИСЛО(ПОИСК($C$3:$C$32;J$2)) - если в п.3 число, то ИСТИНА, если ошибка, то ЛОЖЬ
5. ПРАВБ(J$2)=")" - ПРАВБ для неазиатских символов это то же самое, что и ПРАВСИМБ, только запись короче. Ищем один правый символ и сравниваем его с закрывающейся скобкой.
6. ЕСЛИ(ПРАВБ(J$2)=")";ЕЧИСЛО(ПОИСК($C$3:$C$32;J$2));1) - если в п.5 ИСТИНА, , то проверяем еще и на паттерн (см. п.4), если ЛОЖЬ, то это общее значение

7. ЕЧИСЛО(ПОИСК("-";J$2)) - см. пояснялку для п.4 - ищем тире в J2.
8. ЕСЛИ(ЕЧИСЛО(ПОИСК("-";J$2));$B$3:$B$32;$E$3:$E$32) - если в п.7 ИСТИНА, то это количество, если ЛОЖЬ, то сумма

9. Перемножаем массивы из пунктов 2, 6 и 8 и складываем полученное с помощью СУММПРОИЗВ

Автор - _Boroda_
Дата добавления - 10.09.2018 в 09:46
JonnyL Дата: Понедельник, 10.09.2018, 13:02 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое!
Данной информации более чем достаточно чтобы решить данный вопрос!

Всем удачи!
 
Ответить
СообщениеСпасибо большое!
Данной информации более чем достаточно чтобы решить данный вопрос!

Всем удачи!

Автор - JonnyL
Дата добавления - 10.09.2018 в 13:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет и условие по дню недели. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!