Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнить по рабочим дням для 3х позиций - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнить по рабочим дням для 3х позиций (Формулы/Formulas)
Заполнить по рабочим дням для 3х позиций
bobrenja Дата: Вторник, 11.09.2018, 00:32 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Имеется таблица дата и ФИО. Как решить задачу, что бы автоматически проставить дату рабочих дней для 3х ФИО? За одно число, ФИО повторяется 2 раза.
Если дату протянуть и выбрать рабочие дни, то нарушается порядок дат для ФИО.
На примере наглядно, как должно быть.
К сообщению приложен файл: data.xlsx(9.4 Kb)


Сообщение отредактировал bobrenja - Вторник, 11.09.2018, 02:32
 
Ответить
СообщениеИмеется таблица дата и ФИО. Как решить задачу, что бы автоматически проставить дату рабочих дней для 3х ФИО? За одно число, ФИО повторяется 2 раза.
Если дату протянуть и выбрать рабочие дни, то нарушается порядок дат для ФИО.
На примере наглядно, как должно быть.

Автор - bobrenja
Дата добавления - 11.09.2018 в 00:32
_Boroda_ Дата: Вторник, 11.09.2018, 09:56 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не совсем ясно что нужно
Так?
Код
=ИНДЕКС(D$3:D$17;СЧЁТЕСЛИ(C$2:C2;C3)/2+1)
К сообщению приложен файл: data-1-1.xlsx(9.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе совсем ясно что нужно
Так?
Код
=ИНДЕКС(D$3:D$17;СЧЁТЕСЛИ(C$2:C2;C3)/2+1)

Автор - _Boroda_
Дата добавления - 11.09.2018 в 09:56
bobrenja Дата: Вторник, 11.09.2018, 10:51 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Именно так ))))
Хотелось без без допов.
Графу рабдни, забыл удалить (для себя проставлял для экспериментов).

Идея была, в A3 вставить нужную дату.
Начиная с А4:А ставить только рабдни (без доп столбца)


Сообщение отредактировал bobrenja - Вторник, 11.09.2018, 10:52
 
Ответить
СообщениеИменно так ))))
Хотелось без без допов.
Графу рабдни, забыл удалить (для себя проставлял для экспериментов).

Идея была, в A3 вставить нужную дату.
Начиная с А4:А ставить только рабдни (без доп столбца)

Автор - bobrenja
Дата добавления - 11.09.2018 в 10:51
_Boroda_ Дата: Вторник, 11.09.2018, 10:55 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Хотелось без без допов.

Не получится. По-любому нужен список нерабочих будней (например, 05.11.2018) и список рабочих суббот (например, 29.12.2018)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Хотелось без без допов.

Не получится. По-любому нужен список нерабочих будней (например, 05.11.2018) и список рабочих суббот (например, 29.12.2018)

Автор - _Boroda_
Дата добавления - 11.09.2018 в 10:55
bobrenja Дата: Вторник, 11.09.2018, 11:14 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Спасибо. С доп тогда буду работать )))
Спасибо за решение
 
Ответить
СообщениеСпасибо. С доп тогда буду работать )))
Спасибо за решение

Автор - bobrenja
Дата добавления - 11.09.2018 в 11:14
bobrenja Дата: Вторник, 11.09.2018, 21:41 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
_Boroda_, как быть если нужно в В21 отсчет с другой даты??
К сообщению приложен файл: 3046525.xlsx(10.2 Kb)
 
Ответить
Сообщение_Boroda_, как быть если нужно в В21 отсчет с другой даты??

Автор - bobrenja
Дата добавления - 11.09.2018 в 21:41
bobrenja Дата: Среда, 12.09.2018, 11:06 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Пока сделал такой вариант. ФИО идут поочередно.

Код
=ИНДЕКС(D$3:D$17;(ЕСЛИ(СЧЁТЕСЛИ(H$2:H3;H3)>5;ПОИСКПОЗ(H3;D$3:D$24;0)+1;ПОИСКПОЗ(H3;D$3:D$24;0))))


Проставленные даты копирую и снова вставляю как значение. В ячейке с которой нужен отсчет с другой даты, ставлю нужную и меняю диапазон рабдней.
Как допилить условие, что бы на ФИО было не более 2х одинаковых дат?? Таблица большая, что бы не ошибиться )))
К сообщению приложен файл: 3046525-1.xlsx(12.1 Kb)
 
Ответить
СообщениеПока сделал такой вариант. ФИО идут поочередно.

Код
=ИНДЕКС(D$3:D$17;(ЕСЛИ(СЧЁТЕСЛИ(H$2:H3;H3)>5;ПОИСКПОЗ(H3;D$3:D$24;0)+1;ПОИСКПОЗ(H3;D$3:D$24;0))))


Проставленные даты копирую и снова вставляю как значение. В ячейке с которой нужен отсчет с другой даты, ставлю нужную и меняю диапазон рабдней.
Как допилить условие, что бы на ФИО было не более 2х одинаковых дат?? Таблица большая, что бы не ошибиться )))

Автор - bobrenja
Дата добавления - 12.09.2018 в 11:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнить по рабочим дням для 3х позиций (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!