Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММПРОИЗВ с несколько критерии ( суммировать по значение ) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ с несколько критерии ( суммировать по значение ) (Формулы/Formulas)
СУММПРОИЗВ с несколько критерии ( суммировать по значение )
nikaluka1 Дата: Вторник, 11.09.2018, 14:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
добрый день!
Уважаемые участники форума, подскажите пожалуйста
не как не могу сделать так, что СУММПРОИЗВ сумировал данные на конкретный период , разные критерии ( на колоне и строке)
К сообщению приложен файл: 11.xlsx(21.5 Kb)
 
Ответить
Сообщениедобрый день!
Уважаемые участники форума, подскажите пожалуйста
не как не могу сделать так, что СУММПРОИЗВ сумировал данные на конкретный период , разные критерии ( на колоне и строке)

Автор - nikaluka1
Дата добавления - 11.09.2018 в 14:53
pabchek Дата: Вторник, 11.09.2018, 15:02 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 892
Репутация: 215 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Попробуйте так:
Код
=СУММПРОИЗВ(ИНДЕКС('календарь '!$B$3:$K$7;;СТРОКА(A1)*2-1)*ИНДЕКС('календарь '!$B$3:$K$7;;СТРОКА(A1)*2))


А, пардоньте, там еще период надо...

тогда можно так:
Код
=СУММПРОИЗВ(ИНДЕКС('календарь '!$B$3:$K$7;;СТРОКА(A1)*2-1)*ИНДЕКС('календарь '!$B$3:$K$7;;СТРОКА(A1)*2)*('календарь '!$A$3:$A$7>=$F$1)*('календарь '!$A$3:$A$7<=$G$1))


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 11.09.2018, 15:08
 
Ответить
СообщениеЗдравствуйте!
Попробуйте так:
Код
=СУММПРОИЗВ(ИНДЕКС('календарь '!$B$3:$K$7;;СТРОКА(A1)*2-1)*ИНДЕКС('календарь '!$B$3:$K$7;;СТРОКА(A1)*2))


А, пардоньте, там еще период надо...

тогда можно так:
Код
=СУММПРОИЗВ(ИНДЕКС('календарь '!$B$3:$K$7;;СТРОКА(A1)*2-1)*ИНДЕКС('календарь '!$B$3:$K$7;;СТРОКА(A1)*2)*('календарь '!$A$3:$A$7>=$F$1)*('календарь '!$A$3:$A$7<=$G$1))

Автор - pabchek
Дата добавления - 11.09.2018 в 15:02
китин Дата: Вторник, 11.09.2018, 15:10 | Сообщение № 3
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5024
Репутация: 798 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
пардоньте, там еще период надо...

[s]
Код
=СУММПРОИЗВ('календарь '!$B$3:$K$20*('календарь '!$B$1:$K$1='журнал '!$A2)*('журнал '!B$1='календарь '!$B$2:$K$2)*('календарь '!$A$3:$A$20>='журнал '!$F$1)*('календарь '!$A$3:$A$20<='журнал '!$G$1))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
пардоньте, там еще период надо...

[s]
Код
=СУММПРОИЗВ('календарь '!$B$3:$K$20*('календарь '!$B$1:$K$1='журнал '!$A2)*('журнал '!B$1='календарь '!$B$2:$K$2)*('календарь '!$A$3:$A$20>='журнал '!$F$1)*('календарь '!$A$3:$A$20<='журнал '!$G$1))

Автор - китин
Дата добавления - 11.09.2018 в 15:10
_Boroda_ Дата: Вторник, 11.09.2018, 15:12 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12958
Репутация: 5330 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ('календарь '!B$3:J$20*'календарь '!C$3:K$20*('календарь '!B$1:J$1=$A2)*('календарь '!A$3:A$20>=F$1)*('календарь '!A$3:A$20<=G$1))


Не, не так. Вот так
Код
=СУММПРОИЗВ('календарь '!B$3:J$20*'календарь '!C$3:K$20*('календарь '!B$1:J$1=$A2)*('календарь '!A$3:A$20>=F$1)*('календарь '!A$3:A$20<=G$1)*('календарь '!B$2:J$2='календарь '!B$2))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ('календарь '!B$3:J$20*'календарь '!C$3:K$20*('календарь '!B$1:J$1=$A2)*('календарь '!A$3:A$20>=F$1)*('календарь '!A$3:A$20<=G$1))


Не, не так. Вот так
Код
=СУММПРОИЗВ('календарь '!B$3:J$20*'календарь '!C$3:K$20*('календарь '!B$1:J$1=$A2)*('календарь '!A$3:A$20>=F$1)*('календарь '!A$3:A$20<=G$1)*('календарь '!B$2:J$2='календарь '!B$2))

Автор - _Boroda_
Дата добавления - 11.09.2018 в 15:12
nikaluka1 Дата: Вторник, 11.09.2018, 15:13 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
большое спасибо !!!
 
Ответить
Сообщениебольшое спасибо !!!

Автор - nikaluka1
Дата добавления - 11.09.2018 в 15:13
pabchek Дата: Вторник, 11.09.2018, 15:18 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 892
Репутация: 215 ±
Замечаний: 0% ±

Excel 2007
Извиняюсь, может я не прав? Игорь, вроде как надо "...нада сделать так, чтобы сумирован не цену, а общую сумму"
Саш, а твоей формулой у меня получается 527,5. У меня ошибка?

Сам успел)))


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 11.09.2018, 15:19
 
Ответить
СообщениеИзвиняюсь, может я не прав? Игорь, вроде как надо "...нада сделать так, чтобы сумирован не цену, а общую сумму"
Саш, а твоей формулой у меня получается 527,5. У меня ошибка?

Сам успел)))

Автор - pabchek
Дата добавления - 11.09.2018 в 15:18
китин Дата: Вторник, 11.09.2018, 15:32 | Сообщение № 7
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5024
Репутация: 798 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вроде как надо "...нада сделать так, чтобы сумирован не цену, а общую сумму"

да, не прав, поспешил :'(


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
вроде как надо "...нада сделать так, чтобы сумирован не цену, а общую сумму"

да, не прав, поспешил :'(

Автор - китин
Дата добавления - 11.09.2018 в 15:32
nikaluka1 Дата: Вторник, 11.09.2018, 15:38 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
А, пардоньте, там еще период надо...

тогда можно так:


к сожалению не получается, когда меняю имя товара, данные не меняется
 
Ответить
Сообщение
А, пардоньте, там еще период надо...

тогда можно так:


к сожалению не получается, когда меняю имя товара, данные не меняется

Автор - nikaluka1
Дата добавления - 11.09.2018 в 15:38
nikaluka1 Дата: Вторник, 11.09.2018, 15:45 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
=SUMPRODUCT('календарь '!B$3:J$20*'календарь '!C$3:K$20*('календарь '!B$1:J$1=$A2)*('календарь '!A$3:A$20>=F$1)*('календарь '!A$3:A$20<=G$1)*('календарь '!B$2:J$2='календарь '!B$2))


спасибо уважаемый !!! всё работает
 
Ответить
Сообщение
=SUMPRODUCT('календарь '!B$3:J$20*'календарь '!C$3:K$20*('календарь '!B$1:J$1=$A2)*('календарь '!A$3:A$20>=F$1)*('календарь '!A$3:A$20<=G$1)*('календарь '!B$2:J$2='календарь '!B$2))


спасибо уважаемый !!! всё работает

Автор - nikaluka1
Дата добавления - 11.09.2018 в 15:45
pabchek Дата: Вторник, 11.09.2018, 15:46 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 892
Репутация: 215 ±
Замечаний: 0% ±

Excel 2007
когда меняю имя товара

а у меня привязка к строке, а не к названию. А вот у Александра, _Boroda_, привязка к названию. Пробовали его формулу?


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
Сообщение
когда меняю имя товара

а у меня привязка к строке, а не к названию. А вот у Александра, _Boroda_, привязка к названию. Пробовали его формулу?

Автор - pabchek
Дата добавления - 11.09.2018 в 15:46
nikaluka1 Дата: Вторник, 11.09.2018, 16:22 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
а у меня привязка к строке, а не к названию. А вот у Александра, _Boroda_, привязка к названию. Пробовали его формулу?


да попробовал, работает но когда добавляю столбцы, формула не работает
К сообщению приложен файл: 12.xlsx(21.4 Kb)
 
Ответить
Сообщение
а у меня привязка к строке, а не к названию. А вот у Александра, _Boroda_, привязка к названию. Пробовали его формулу?


да попробовал, работает но когда добавляю столбцы, формула не работает

Автор - nikaluka1
Дата добавления - 11.09.2018 в 16:22
nikaluka1 Дата: Вторник, 11.09.2018, 16:24 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
Не, не так. Вот так


когда добавляю столбцы, формула не работает , наверно неправильно сформулировал мои вопрос((
 
Ответить
Сообщение
Не, не так. Вот так


когда добавляю столбцы, формула не работает , наверно неправильно сформулировал мои вопрос((

Автор - nikaluka1
Дата добавления - 11.09.2018 в 16:24
nikaluka1 Дата: Вторник, 11.09.2018, 16:26 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
если удалить этот жёлтый столбец, всё работает прекрасно
 
Ответить
Сообщениеесли удалить этот жёлтый столбец, всё работает прекрасно

Автор - nikaluka1
Дата добавления - 11.09.2018 в 16:26
nikaluka1 Дата: Вторник, 11.09.2018, 16:36 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
Не, не так. Вот так

можно сделать так, чтобы формула использовал имя столбца , и когда дабавляетса нови столбец, все равно работал формула
К сообщению приложен файл: 7231880.xlsx(21.3 Kb)
 
Ответить
Сообщение
Не, не так. Вот так

можно сделать так, чтобы формула использовал имя столбца , и когда дабавляетса нови столбец, все равно работал формула

Автор - nikaluka1
Дата добавления - 11.09.2018 в 16:36
_Boroda_ Дата: Вторник, 11.09.2018, 16:40 | Сообщение № 15
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12958
Репутация: 5330 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
наверно неправильно сформулировал мои вопрос

Не то, чтобы вопрос неправильно, но уж файл-то точно неверный приложили. Как Вы попросили, так мы и сделали. Про добавление столбцов ни слова не было, вот никто и не предположил, что так может быть
Ловите
Код
=СУММПРОИЗВ(ИНДЕКС('календарь '!A$3:N$20;;СУММПРОИЗВ(('календарь '!B$1:N$1=A2)*('календарь '!B$2:N$2=B$1)*СТОЛБЕЦ('календарь '!B$1:N$1)))*ИНДЕКС('календарь '!A$3:N$20;;СУММПРОИЗВ(('календарь '!B$1:N$1=A2)*('календарь '!B$2:N$2=C$1)*СТОЛБЕЦ('календарь '!B$1:N$1)))*('календарь '!A$3:A$20>=E$1)*('календарь '!A$3:A$20<=F$1))

Названия столбцов в строке 2 внутри одного товара должны быть уникальны
К сообщению приложен файл: 12-2-1.xlsx(21.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
наверно неправильно сформулировал мои вопрос

Не то, чтобы вопрос неправильно, но уж файл-то точно неверный приложили. Как Вы попросили, так мы и сделали. Про добавление столбцов ни слова не было, вот никто и не предположил, что так может быть
Ловите
Код
=СУММПРОИЗВ(ИНДЕКС('календарь '!A$3:N$20;;СУММПРОИЗВ(('календарь '!B$1:N$1=A2)*('календарь '!B$2:N$2=B$1)*СТОЛБЕЦ('календарь '!B$1:N$1)))*ИНДЕКС('календарь '!A$3:N$20;;СУММПРОИЗВ(('календарь '!B$1:N$1=A2)*('календарь '!B$2:N$2=C$1)*СТОЛБЕЦ('календарь '!B$1:N$1)))*('календарь '!A$3:A$20>=E$1)*('календарь '!A$3:A$20<=F$1))

Названия столбцов в строке 2 внутри одного товара должны быть уникальны

Автор - _Boroda_
Дата добавления - 11.09.2018 в 16:40
nikaluka1 Дата: Вторник, 11.09.2018, 17:21 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
Названия столбцов в строке 2 внутри одного товара должны быть уникальны


блестящое решение, большое спасибо !!! всё работает прекрасно
 
Ответить
Сообщение
Названия столбцов в строке 2 внутри одного товара должны быть уникальны


блестящое решение, большое спасибо !!! всё работает прекрасно

Автор - nikaluka1
Дата добавления - 11.09.2018 в 17:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ с несколько критерии ( суммировать по значение ) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!