Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Группировка данных из строк в столбцы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Группировка данных из строк в столбцы (Формулы/Formulas)
Группировка данных из строк в столбцы
liker Дата: Вторник, 02.10.2018, 22:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Есть строки с названием тикета и ценой. Тикеты повторяются. Как их сгруппировать, чтобы были столбцы с названиями тикетов и списком цен по каждому из них?
К сообщению приложен файл: tickers.xlsx(20.8 Kb)


Сообщение отредактировал liker - Вторник, 02.10.2018, 22:23
 
Ответить
СообщениеЕсть строки с названием тикета и ценой. Тикеты повторяются. Как их сгруппировать, чтобы были столбцы с названиями тикетов и списком цен по каждому из них?

Автор - liker
Дата добавления - 02.10.2018 в 22:22
krosav4ig Дата: Вторник, 02.10.2018, 22:31 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1657
Репутация: 690 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Доп. столбец с формулой
Код
=СЧЁТЕСЛИ($A$1:A2;A2)
и сводная
К сообщению приложен файл: 6116019.xlsx(49.4 Kb)


(_)Õvõ(_)
 
Ответить
СообщениеДоп. столбец с формулой
Код
=СЧЁТЕСЛИ($A$1:A2;A2)
и сводная

Автор - krosav4ig
Дата добавления - 02.10.2018 в 22:31
Светлый Дата: Вторник, 02.10.2018, 22:51 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 652
Репутация: 176 ±
Замечаний: 0% ±

Excel 2010
Заголовки:
Код
=ЕСЛИОШИБКА(ИНДЕКС($A:$A;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A1:$A672;$A1:$A672;)=СТРОКА(1:672);СТРОКА(1:672));СТОЛБЕЦ(B1)));"")
Числа:
Код
=ЕСЛИОШИБКА(ИНДЕКС($B:$B;НАИМЕНЬШИЙ(ЕСЛИ(D$1=$A$1:$A$672;СТРОКА($1:$672));СТРОКА(D1)));"")
Массивные. Тормозит.
К сообщению приложен файл: tickers-1.xlsx(56.1 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЗаголовки:
Код
=ЕСЛИОШИБКА(ИНДЕКС($A:$A;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A1:$A672;$A1:$A672;)=СТРОКА(1:672);СТРОКА(1:672));СТОЛБЕЦ(B1)));"")
Числа:
Код
=ЕСЛИОШИБКА(ИНДЕКС($B:$B;НАИМЕНЬШИЙ(ЕСЛИ(D$1=$A$1:$A$672;СТРОКА($1:$672));СТРОКА(D1)));"")
Массивные. Тормозит.

Автор - Светлый
Дата добавления - 02.10.2018 в 22:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Группировка данных из строк в столбцы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!