Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выборка наибольших значений из области по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выборка наибольших значений из области по условию (Формулы/Formulas)
выборка наибольших значений из области по условию
UberFull Дата: Пятница, 19.10.2018, 11:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
прейду сразу к сути. есть база данных немного строк, много столбцов. Надо сделать автоматическую выборку так, что-бы в другой таблице отражались значения 5-7 столбцов с с наибольшим главным критерием. Для примера они выбраны желтым.
Как выбирать наибольшее я знаю, формулу ЕСЛИ, тоже знаю. А вот как сделать замену групп ячеек, в значении ИСТИНА - не знаю. Хотя скорее всего я ошибаюсь в предположениях.
Если еще столбцы значений будут в порядке, как в главной таблице - просто шикарно. т.е. пример "столбец 4", "столбец12", "столбец26" и соответствующие цифры под ними

[p.s.] Надеюсь понятно расписал всё
Приоритет - формулы
К сообщению приложен файл: 2591251.xlsx(12.6 Kb)
 
Ответить
Сообщениепрейду сразу к сути. есть база данных немного строк, много столбцов. Надо сделать автоматическую выборку так, что-бы в другой таблице отражались значения 5-7 столбцов с с наибольшим главным критерием. Для примера они выбраны желтым.
Как выбирать наибольшее я знаю, формулу ЕСЛИ, тоже знаю. А вот как сделать замену групп ячеек, в значении ИСТИНА - не знаю. Хотя скорее всего я ошибаюсь в предположениях.
Если еще столбцы значений будут в порядке, как в главной таблице - просто шикарно. т.е. пример "столбец 4", "столбец12", "столбец26" и соответствующие цифры под ними

[p.s.] Надеюсь понятно расписал всё
Приоритет - формулы

Автор - UberFull
Дата добавления - 19.10.2018 в 11:57
sboy Дата: Пятница, 19.10.2018, 12:15 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2198
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
И Вам здравствуйте!
Код
=ИНДЕКС($C4:$AP4;ПОИСКПОЗ(НАИБОЛЬШИЙ($C$9:$AP$9;СТОЛБЕЦ(A15));$C$9:$AP$9;))
К сообщению приложен файл: 8899625.xlsx(13.6 Kb)


Сообщение отредактировал sboy - Пятница, 19.10.2018, 12:16
 
Ответить
СообщениеИ Вам здравствуйте!
Код
=ИНДЕКС($C4:$AP4;ПОИСКПОЗ(НАИБОЛЬШИЙ($C$9:$AP$9;СТОЛБЕЦ(A15));$C$9:$AP$9;))

Автор - sboy
Дата добавления - 19.10.2018 в 12:15
_Boroda_ Дата: Пятница, 19.10.2018, 12:22 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
UberFull, Вы б руками заполнили пару столбцов, так понятнее было бы
И вопрос - могут ли значения для поиска повторяться? Например, может ли К9 равняться N9?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеUberFull, Вы б руками заполнили пару столбцов, так понятнее было бы
И вопрос - могут ли значения для поиска повторяться? Например, может ли К9 равняться N9?

Автор - _Boroda_
Дата добавления - 19.10.2018 в 12:22
sboy Дата: Пятница, 19.10.2018, 12:35 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2198
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Если еще столбцы значений будут в порядке, как в главной таблице

реализовал через PQ
К сообщению приложен файл: 6071210.xlsx(27.4 Kb)
 
Ответить
Сообщение
Если еще столбцы значений будут в порядке, как в главной таблице

реализовал через PQ

Автор - sboy
Дата добавления - 19.10.2018 в 12:35
UberFull Дата: Пятница, 19.10.2018, 14:45 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, все работает. хотя при перетягивании формулы в другую таблицу - выбирает минимальные значения. хз как это работает
 
Ответить
СообщениеСпасибо, все работает. хотя при перетягивании формулы в другую таблицу - выбирает минимальные значения. хз как это работает

Автор - UberFull
Дата добавления - 19.10.2018 в 14:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выборка наибольших значений из области по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!