Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск по части данных и перенос полных данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по части данных и перенос полных данных (Формулы/Formulas)
Поиск по части данных и перенос полных данных
33rus Дата: Понедельник, 05.11.2018, 21:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть лист с данными с разными наименованиями, на соседнем листе нужно собрать все данные по группам.
Например есть группа "форель", нам нужно найти в таблице с данными ячейки в которых содержится слово форель и перетащить их списком на соседний лист.[b]
К сообщению приложен файл: 3233937.xlsx(11.7 Kb)


Сообщение отредактировал 33rus - Понедельник, 05.11.2018, 21:53
 
Ответить
СообщениеЕсть лист с данными с разными наименованиями, на соседнем листе нужно собрать все данные по группам.
Например есть группа "форель", нам нужно найти в таблице с данными ячейки в которых содержится слово форель и перетащить их списком на соседний лист.[b]

Автор - 33rus
Дата добавления - 05.11.2018 в 21:53
AlexM Дата: Понедельник, 05.11.2018, 23:19 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3780
Репутация: 952 ±
Замечаний: 0% ±

Excel 2003
формула массива
Код
=ИНДЕКС(Данные!A:A;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(ВПР("яяя";A$2:A2;1);Данные!A$1:A$99));СТРОКА(A$1:A$99));СТРОКА(A3)-ПРОСМОТР("яяя";A$2:A2;СТРОКА(A$2:A2))))
К сообщению приложен файл: 3233937_01.xlsx(12.6 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеформула массива
Код
=ИНДЕКС(Данные!A:A;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(ВПР("яяя";A$2:A2;1);Данные!A$1:A$99));СТРОКА(A$1:A$99));СТРОКА(A3)-ПРОСМОТР("яяя";A$2:A2;СТРОКА(A$2:A2))))

Автор - AlexM
Дата добавления - 05.11.2018 в 23:19
33rus Дата: Вторник, 06.11.2018, 00:01 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
СПАСИБО ОГРОМНОЕ!!!
 
Ответить
СообщениеСПАСИБО ОГРОМНОЕ!!!

Автор - 33rus
Дата добавления - 06.11.2018 в 00:01
_Boroda_ Дата: Вторник, 06.11.2018, 10:49 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ИНДЕКС(Данные!A$2:A$99;ПОИСКПОЗ(;СЧЁТЕСЛИ(B$1:B1;ЕСЛИ(ЕЧИСЛО(ПОИСК(ВПР("яяя";A$2:A2;1);Данные!A$2:A$99));Данные!A$2:A$99;B$1));))

Если вдруг будет текст типа "кета + семга ломтки", то он перенесется только один раз. У той рыбы, что в списке на листе Список будет первой
Я, правда, не знаю, нужно ли один раз переносить или два.
К сообщению приложен файл: 3233937_1.xlsx(13.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ИНДЕКС(Данные!A$2:A$99;ПОИСКПОЗ(;СЧЁТЕСЛИ(B$1:B1;ЕСЛИ(ЕЧИСЛО(ПОИСК(ВПР("яяя";A$2:A2;1);Данные!A$2:A$99));Данные!A$2:A$99;B$1));))

Если вдруг будет текст типа "кета + семга ломтки", то он перенесется только один раз. У той рыбы, что в списке на листе Список будет первой
Я, правда, не знаю, нужно ли один раз переносить или два.

Автор - _Boroda_
Дата добавления - 06.11.2018 в 10:49
33rus Дата: Вторник, 06.11.2018, 13:46 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Подскажите как расширить диапазон поиска в листе "Данные", поиск нужно осуществлять до строчки №999
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
 
Ответить
СообщениеПодскажите как расширить диапазон поиска в листе "Данные", поиск нужно осуществлять до строчки №999
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Автор - 33rus
Дата добавления - 06.11.2018 в 13:46
_Boroda_ Дата: Вторник, 06.11.2018, 13:51 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А как Вы сами думаете? В формулах диапазоны для листа Даныые Данные!A$2:A$99, что нужно сделать, чтобы было до 999?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА как Вы сами думаете? В формулах диапазоны для листа Даныые Данные!A$2:A$99, что нужно сделать, чтобы было до 999?

Автор - _Boroda_
Дата добавления - 06.11.2018 в 13:51
33rus Дата: Вторник, 06.11.2018, 13:53 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Поменял в формуле на 999, выдает Н/Д.(((
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума


Сообщение отредактировал _Boroda_ - Вторник, 06.11.2018, 14:09
 
Ответить
СообщениеПоменял в формуле на 999, выдает Н/Д.(((
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Автор - 33rus
Дата добавления - 06.11.2018 в 13:53
_Boroda_ Дата: Вторник, 06.11.2018, 13:56 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Видите в нетронутой формуле по краям фигурные скобочки? Это означает, что это
формула массива
https://support.office.com/ru-ru....caa57c7
Она вводится одновременным нажатием Ctrl+Shift+Enter

И Вы везде поменяли? в 3-х местах?
Код
=ИНДЕКС(Данные!A$2:A$999;ПОИСКПОЗ(;СЧЁТЕСЛИ(B$1:B1;ЕСЛИ(ЕЧИСЛО(ПОИСК(ВПР("яяя";A$2:A2;1);Данные!A$2:A$999));Данные!A$2:A$999;B$1));))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВидите в нетронутой формуле по краям фигурные скобочки? Это означает, что это
формула массива
https://support.office.com/ru-ru....caa57c7
Она вводится одновременным нажатием Ctrl+Shift+Enter

И Вы везде поменяли? в 3-х местах?
Код
=ИНДЕКС(Данные!A$2:A$999;ПОИСКПОЗ(;СЧЁТЕСЛИ(B$1:B1;ЕСЛИ(ЕЧИСЛО(ПОИСК(ВПР("яяя";A$2:A2;1);Данные!A$2:A$999));Данные!A$2:A$999;B$1));))

Автор - _Boroda_
Дата добавления - 06.11.2018 в 13:56
33rus Дата: Вторник, 06.11.2018, 14:06 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
формула массива https://support.office.com/ru-ru....caa57c7 Она вводится одновременным нажатием Ctrl+Shift+Enter

СПАСИБО ОГРОМНОЕ!!! Все сделал, не знал про сочетание Ctrl+Shift+Enter
:fool:
 
Ответить
Сообщение
формула массива https://support.office.com/ru-ru....caa57c7 Она вводится одновременным нажатием Ctrl+Shift+Enter

СПАСИБО ОГРОМНОЕ!!! Все сделал, не знал про сочетание Ctrl+Shift+Enter
:fool:

Автор - 33rus
Дата добавления - 06.11.2018 в 14:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по части данных и перенос полных данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!