Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/От одной суммы чисел вычесть другую (через 5 строк) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » От одной суммы чисел вычесть другую (через 5 строк) (Формулы/Formulas)
От одной суммы чисел вычесть другую (через 5 строк)
stalber Дата: Вторник, 06.11.2018, 15:36 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Добрый день, помогите пожалуйста.

Необходимо через каждые 5 строк, вычитать из одной суммы чисел другую. Справа вверху в примере я вывел маленькую таблицу которую нужно в итоге увидеть, цвет закраски просто сделан, для понимания что нужно в конечном результате.
К сообщению приложен файл: zadacha_0711201.xlsx(12.1 Kb)
 
Ответить
СообщениеДобрый день, помогите пожалуйста.

Необходимо через каждые 5 строк, вычитать из одной суммы чисел другую. Справа вверху в примере я вывел маленькую таблицу которую нужно в итоге увидеть, цвет закраски просто сделан, для понимания что нужно в конечном результате.

Автор - stalber
Дата добавления - 06.11.2018 в 15:36
_Boroda_ Дата: Вторник, 06.11.2018, 15:51 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС($C:$R;СТРОКА(Y1)*5;(СТОЛБЕЦ(A2)-1)*2,5+1)

Код
=СУММПРОИЗВ(ИНДЕКС($F:$U;СТРОКА(Z1)*5-3;(СТОЛБЕЦ(A2)-1)*2,5+1):ИНДЕКС($G:$V;СТРОКА(Z1)*5+1;(СТОЛБЕЦ(A2)-1)*2,5+1)*{1;-1})
К сообщению приложен файл: 6082503.xlsx(12.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС($C:$R;СТРОКА(Y1)*5;(СТОЛБЕЦ(A2)-1)*2,5+1)

Код
=СУММПРОИЗВ(ИНДЕКС($F:$U;СТРОКА(Z1)*5-3;(СТОЛБЕЦ(A2)-1)*2,5+1):ИНДЕКС($G:$V;СТРОКА(Z1)*5+1;(СТОЛБЕЦ(A2)-1)*2,5+1)*{1;-1})

Автор - _Boroda_
Дата добавления - 06.11.2018 в 15:51
stalber Дата: Вторник, 06.11.2018, 17:00 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
А чтобы увеличить диапазон суммируемых ячеек, в примере у меня через 5, а например чтобы сделать через 10, что именно нужно отредактировать в формуле? и если выведу на другую страницу.
К сообщению приложен файл: zadacha_0881120.xlsx(12.1 Kb)


Сообщение отредактировал stalber - Вторник, 06.11.2018, 17:07
 
Ответить
СообщениеА чтобы увеличить диапазон суммируемых ячеек, в примере у меня через 5, а например чтобы сделать через 10, что именно нужно отредактировать в формуле? и если выведу на другую страницу.

Автор - stalber
Дата добавления - 06.11.2018 в 17:00
_Boroda_ Дата: Вторник, 06.11.2018, 17:15 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Попробуйте самостоятельно заменить 5 на 10 и в ссылки добавить названия листа Данные!$C:$R


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПопробуйте самостоятельно заменить 5 на 10 и в ссылки добавить названия листа Данные!$C:$R

Автор - _Boroda_
Дата добавления - 06.11.2018 в 17:15
stalber Дата: Вторник, 06.11.2018, 17:34 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Пытался уже, что то не получается, формула не верно данные показывает, видимо что то ещё нужно изменить.
К сообщению приложен файл: zadacha_0128811.xlsx(12.6 Kb)


Сообщение отредактировал stalber - Вторник, 06.11.2018, 17:34
 
Ответить
СообщениеПытался уже, что то не получается, формула не верно данные показывает, видимо что то ещё нужно изменить.

Автор - stalber
Дата добавления - 06.11.2018 в 17:34
_Boroda_ Дата: Вторник, 06.11.2018, 17:47 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СУММПРОИЗВ(ИНДЕКС($F:$U;СТРОКА(Z1)*10-10+2;(СТОЛБЕЦ(A2)-1)*2,5+1):ИНДЕКС($G:$V;СТРОКА(Z1)*10+1;(СТОЛБЕЦ(A2)-1)*2,5+1)*{1;-1})
К сообщению приложен файл: 5157011.xlsx(13.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ИНДЕКС($F:$U;СТРОКА(Z1)*10-10+2;(СТОЛБЕЦ(A2)-1)*2,5+1):ИНДЕКС($G:$V;СТРОКА(Z1)*10+1;(СТОЛБЕЦ(A2)-1)*2,5+1)*{1;-1})

Автор - _Boroda_
Дата добавления - 06.11.2018 в 17:47
stalber Дата: Вторник, 06.11.2018, 19:06 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Благодарю, жаль нельзя поднимать репутацию чаще 24часов, это кстати странность форума.

Вопрос, я немного видоизменил и подредактировал формулу, результат верный показывает, единственное просто у меня сомнение касаемо ячеек в формуле (A2) (A2) и (C1) (A3) я просто не понимаю за что отвечают данные ячейки, верно ли вся формула, которую я редактировал?.
Можете пожалуйста перепроверить можно ли в таком виде ею пользоваться.

Данная формула выводит рядышком названия в 1-ой строке один раз названия только выводятся:
Код
=ИНДЕКС(Данные!$C:$CAD;СТРОКА(Данные!A2)*1;(СТОЛБЕЦ(Данные!A2)-1)*5+1)


А данная формула выводит рядом результат 10-ти ячеек (снизу под названием):
Код
=СУММПРОИЗВ(ИНДЕКС(Данные!$F:$CAG;СТРОКА(C1)*10-10+2;(СТОЛБЕЦ(Данные!A3)-1)*5+1):ИНДЕКС(Данные!$G:$CAH;СТРОКА(C1)*10+1;(СТОЛБЕЦ(Данные!A3)-1)*5+1)*{1;-1})
К сообщению приложен файл: praviljnoli.xlsx(14.6 Kb)


Сообщение отредактировал stalber - Вторник, 06.11.2018, 19:09
 
Ответить
СообщениеБлагодарю, жаль нельзя поднимать репутацию чаще 24часов, это кстати странность форума.

Вопрос, я немного видоизменил и подредактировал формулу, результат верный показывает, единственное просто у меня сомнение касаемо ячеек в формуле (A2) (A2) и (C1) (A3) я просто не понимаю за что отвечают данные ячейки, верно ли вся формула, которую я редактировал?.
Можете пожалуйста перепроверить можно ли в таком виде ею пользоваться.

Данная формула выводит рядышком названия в 1-ой строке один раз названия только выводятся:
Код
=ИНДЕКС(Данные!$C:$CAD;СТРОКА(Данные!A2)*1;(СТОЛБЕЦ(Данные!A2)-1)*5+1)


А данная формула выводит рядом результат 10-ти ячеек (снизу под названием):
Код
=СУММПРОИЗВ(ИНДЕКС(Данные!$F:$CAG;СТРОКА(C1)*10-10+2;(СТОЛБЕЦ(Данные!A3)-1)*5+1):ИНДЕКС(Данные!$G:$CAH;СТРОКА(C1)*10+1;(СТОЛБЕЦ(Данные!A3)-1)*5+1)*{1;-1})

Автор - stalber
Дата добавления - 06.11.2018 в 19:06
_Boroda_ Дата: Вторник, 06.11.2018, 19:22 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
у меня сомнение касаемо ячеек в формуле (A2) (A2) и (C1) (A3) я просто не понимаю за что отвечают данные ячейки
Сами по себе ни за что, а вот вместе с функцией СТРОКА или СТОЛБЕЦ они показывают номер строки или столбца ячейки
Первую формулу можно попроще
Код
=ИНДЕКС(Данные!2:2;СТОЛБЕЦ(Данные!A2)*5-5+3)

жаль нельзя
а уж мне-то как жаль! Ничего, будет повод зайти сюда завтра


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
у меня сомнение касаемо ячеек в формуле (A2) (A2) и (C1) (A3) я просто не понимаю за что отвечают данные ячейки
Сами по себе ни за что, а вот вместе с функцией СТРОКА или СТОЛБЕЦ они показывают номер строки или столбца ячейки
Первую формулу можно попроще
Код
=ИНДЕКС(Данные!2:2;СТОЛБЕЦ(Данные!A2)*5-5+3)

жаль нельзя
а уж мне-то как жаль! Ничего, будет повод зайти сюда завтра

Автор - _Boroda_
Дата добавления - 06.11.2018 в 19:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » От одной суммы чисел вычесть другую (через 5 строк) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!