Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти определенный текст и вынести его в другую ячейку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти определенный текст и вынести его в другую ячейку (Формулы/Formulas)
Найти определенный текст и вынести его в другую ячейку
evgenyforever Дата: Среда, 07.11.2018, 05:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Уважаемые коллеги, помогите в решении следующей задачи.

1) Если текст содержит слова "отгружен" и "доставлен", то "Заказ отгружен и доставлен".
Если текст содержит слово "отгружен", то "Заказ отгружен".
Если текст содержит слово "доставлен", то "Заказ доставлен".
Моя формула работает неправильно:
[vba]
Код
=ЕСЛИ((СУММ(СЧЁТ(A2;"*"&{"отгружен"}&"*");(СУММ(СЧЁТЕСЛИ(A2;"*"&{"доставлен"}&"*")))))>0;"Заказ отгружен и доставлен.";ЕСЛИ(СУММ(СЧЁТЕСЛИ(A2;"*"&{"отгружен"}&"*"))<>СЧЁТЕСЛИ(A2;"*"&{"доставлен"}&"*");"Заказ отгружен.";ЕСЛИ(СУММ(СЧЁТЕСЛИ(A2;"*"&{"доставлен"}&"*"))<>СЧЁТЕСЛИ(A2;"*"&{"отгружен"}&"*");"Заказ доставлен.")))
[/vba]

2) Получить все слова в ячейке, начинающиеся с заглавной буквы (без учёта первого слова и без макроса). В идеале получить фамилии и имена, но думаю, что это нерешаемая задача, учитывая, что ФИО может находится в любой месте текста.

Заранее благодарен за любую помощь!
К сообщению приложен файл: 5767157.xlsx(10.7 Kb)


Сообщение отредактировал evgenyforever - Среда, 07.11.2018, 05:45
 
Ответить
СообщениеУважаемые коллеги, помогите в решении следующей задачи.

1) Если текст содержит слова "отгружен" и "доставлен", то "Заказ отгружен и доставлен".
Если текст содержит слово "отгружен", то "Заказ отгружен".
Если текст содержит слово "доставлен", то "Заказ доставлен".
Моя формула работает неправильно:
[vba]
Код
=ЕСЛИ((СУММ(СЧЁТ(A2;"*"&{"отгружен"}&"*");(СУММ(СЧЁТЕСЛИ(A2;"*"&{"доставлен"}&"*")))))>0;"Заказ отгружен и доставлен.";ЕСЛИ(СУММ(СЧЁТЕСЛИ(A2;"*"&{"отгружен"}&"*"))<>СЧЁТЕСЛИ(A2;"*"&{"доставлен"}&"*");"Заказ отгружен.";ЕСЛИ(СУММ(СЧЁТЕСЛИ(A2;"*"&{"доставлен"}&"*"))<>СЧЁТЕСЛИ(A2;"*"&{"отгружен"}&"*");"Заказ доставлен.")))
[/vba]

2) Получить все слова в ячейке, начинающиеся с заглавной буквы (без учёта первого слова и без макроса). В идеале получить фамилии и имена, но думаю, что это нерешаемая задача, учитывая, что ФИО может находится в любой месте текста.

Заранее благодарен за любую помощь!

Автор - evgenyforever
Дата добавления - 07.11.2018 в 05:30
Светлый Дата: Среда, 07.11.2018, 07:42 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 755
Репутация: 201 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Код
="Заказ "&ЕСЛИ(СЧЁТ(ПОИСК("отгружен";A2));"отгружен";"")&ЕСЛИ(СЧЁТ(ПОИСК("доставлен";A2));ЕСЛИ(СЧЁТ(ПОИСК("отгружен";A2));" и ";"")&"доставлен";"")&"."
Фамилию можно извлекать после слова "менеджер". Всегда ли такая формулировка предложений?
*Или так:
Код
="Заказ "&ВЫБОР(СЧЁТ(ПОИСК("отгружен";A2))+СЧЁТ(ПОИСК("доставлен";A2))*2+1;"";"отгружен";"доставлен";"отгружен и доставлен")&"."
**Фамилия:
Удалено администрацией - это другой вопрос


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 07.11.2018, 08:45
 
Ответить
СообщениеЗдравствуйте!
Код
="Заказ "&ЕСЛИ(СЧЁТ(ПОИСК("отгружен";A2));"отгружен";"")&ЕСЛИ(СЧЁТ(ПОИСК("доставлен";A2));ЕСЛИ(СЧЁТ(ПОИСК("отгружен";A2));" и ";"")&"доставлен";"")&"."
Фамилию можно извлекать после слова "менеджер". Всегда ли такая формулировка предложений?
*Или так:
Код
="Заказ "&ВЫБОР(СЧЁТ(ПОИСК("отгружен";A2))+СЧЁТ(ПОИСК("доставлен";A2))*2+1;"";"отгружен";"доставлен";"отгружен и доставлен")&"."
**Фамилия:
Удалено администрацией - это другой вопрос

Автор - Светлый
Дата добавления - 07.11.2018 в 07:42
_Boroda_ Дата: Среда, 07.11.2018, 09:17 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13698
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- п.4 Правил форума: один вопрос - одна тема
По поводу фамилии создайте новую. С учетом вопроса
Цитата Светлый, 07.11.2018 в 07:42, в сообщении № 2 ()
Фамилию можно извлекать после слова "менеджер". Всегда ли такая формулировка предложений?
- всегде ли "Кузнецов" после "менеджер" и всегда ли "менеджер" перед Кузнецовым"?

По заказам такой вариант (не показывает текст "Заказ ." где не нужно)
Код
=ТЕКСТ(ВПР(СУММПРОИЗВ(СЧЁТЕСЛИ(A2;{"*отгружен*":"*доставлен*"})*{1:2});{0;0:1;"отгружен":2;"доставлен":3;"отгружен и доставлен"};2);";;;""Заказ ""@"".""")

Или без извращений
Код
=ВПР(СУММПРОИЗВ(СЧЁТЕСЛИ(A2;{"*отгружен*":"*доставлен*"})*{1:2});{0;0:1;"Заказ отгружен.":2;"Заказ доставлен.":3;"Заказ отгружен и доставлен."};2)
К сообщению приложен файл: 5767157_1.xlsx(11.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- п.4 Правил форума: один вопрос - одна тема
По поводу фамилии создайте новую. С учетом вопроса
Цитата Светлый, 07.11.2018 в 07:42, в сообщении № 2 ()
Фамилию можно извлекать после слова "менеджер". Всегда ли такая формулировка предложений?
- всегде ли "Кузнецов" после "менеджер" и всегда ли "менеджер" перед Кузнецовым"?

По заказам такой вариант (не показывает текст "Заказ ." где не нужно)
Код
=ТЕКСТ(ВПР(СУММПРОИЗВ(СЧЁТЕСЛИ(A2;{"*отгружен*":"*доставлен*"})*{1:2});{0;0:1;"отгружен":2;"доставлен":3;"отгружен и доставлен"};2);";;;""Заказ ""@"".""")

Или без извращений
Код
=ВПР(СУММПРОИЗВ(СЧЁТЕСЛИ(A2;{"*отгружен*":"*доставлен*"})*{1:2});{0;0:1;"Заказ отгружен.":2;"Заказ доставлен.":3;"Заказ отгружен и доставлен."};2)

Автор - _Boroda_
Дата добавления - 07.11.2018 в 09:17
evgenyforever Дата: Среда, 07.11.2018, 17:09 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, _Boroda_, Спасибо! Это то, что нужно!
 
Ответить
СообщениеСветлый, _Boroda_, Спасибо! Это то, что нужно!

Автор - evgenyforever
Дата добавления - 07.11.2018 в 17:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти определенный текст и вынести его в другую ячейку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!