Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула месяц что б было пусто если не стоит дата - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула месяц что б было пусто если не стоит дата (Формулы/Formulas)
Формула месяц что б было пусто если не стоит дата
lenacia Дата: Пятница, 16.11.2018, 11:58 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день. Подскажете пожалуйста, как правильно прописать формулу в столбце "Месяц", что б было пусто если не стоит дата? (см пример)
К сообщению приложен файл: 4332532.xls(26.5 Kb)
 
Ответить
СообщениеДобрый день. Подскажете пожалуйста, как правильно прописать формулу в столбце "Месяц", что б было пусто если не стоит дата? (см пример)

Автор - lenacia
Дата добавления - 16.11.2018 в 11:58
_Boroda_ Дата: Пятница, 16.11.2018, 12:23 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13681
Репутация: 5580 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ТЕКСТ(B3;"ММММ;;")

Ну или просто с ЕСЛИ
Код
=если(B3="";"";ТЕКСТ(B3;"ММММ"))
К сообщению приложен файл: 4332532_1.xls(35.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ТЕКСТ(B3;"ММММ;;")

Ну или просто с ЕСЛИ
Код
=если(B3="";"";ТЕКСТ(B3;"ММММ"))

Автор - _Boroda_
Дата добавления - 16.11.2018 в 12:23
lenacia Дата: Пятница, 16.11.2018, 12:40 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, вот скопировав вашу ссылку на формулу у меня получилось, спасибо.
Но вот я перед тем как написать сообщение на форум пробовала этот вариант. Почему-то не получилось)))
 
Ответить
Сообщение_Boroda_, вот скопировав вашу ссылку на формулу у меня получилось, спасибо.
Но вот я перед тем как написать сообщение на форум пробовала этот вариант. Почему-то не получилось)))

Автор - lenacia
Дата добавления - 16.11.2018 в 12:40
Никанор Дата: Пятница, 16.11.2018, 16:12 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 371
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте lenacia – Елена!
Предложу свои варианты.
Я написал на основе формулы – шаблона – заготовки
=ЕСЛИ(B3<>"";формула;"")
где вместо ТЕКСТа формула нужно ввести необходимую формулу.
Я всегда пользуюсь этим шаблоном.

Тогда Результат будет пустая ячейка. А вместо В3 поставить нужную ячейку.

1 вариант:
Код
=ЕСЛИ(B3<>"";ТЕКСТ(B3;"ММММ;");"")
– результат названия месяца с большой буквы – «Сентябрь»

2 вариант:
Код
=ЕСЛИ(B3<>"";ТЕКСТ(B3;"ММММ;@");"")
тоже результат названия месяца с большой буквы– «Сентябрь»

3 вариант:
Код
=ЕСЛИ(B3<>"";ТЕКСТ(ДАТАМЕС(B3;0);"[$-F419]ММММ");"")
– результат названия месяца с маленькой буквы – «сентябрь»

4 вариант:
Код
=ЕСЛИ(B3<>"";ТЕКСТ(ДАТАМЕС(B3;0);"[$-FC19]ММММ");"")
– результат склонение названия месяца с маленькой буквы – «сентября»

5 вариант:
Код
=ЕСЛИ(B3<>"";ПРОПНАЧ(ТЕКСТ(B3;"[$-FC19] ММММ"));"")
– результат склонение названия месяца с большой буквы – «Сентября»

Я только не знаю: 1. как написать формулу склонение название месяца с большой буквы – «Сентября», что бы в формуле не было ПРОПНАЧ. что бы формула была короче.

Формула в варианте ММММ даёт результат только название месяца.
И я не знаю: 2 как подправить мои формулы что бы после названия месяца был год.
Пробовал написать после ММММ – четыре буквы ГГГГ, но год почему то не в результате не получается.


Мои варианты формулы может подправить или сократить если что то неправильно я написал _Boroda_ – Александр.
У меня, наверное, много лишних точек с запятой (;) или нет.


Но формулы «работают» – ЕСЛИ пустая ячейка B3 – результат пустая ячейка.

Елена!
Напишите пожалуйста подошли ли Вам мои варианты формул и шаблон.


Сообщение отредактировал Никанор - Пятница, 16.11.2018, 16:22
 
Ответить
СообщениеЗдравствуйте lenacia – Елена!
Предложу свои варианты.
Я написал на основе формулы – шаблона – заготовки
=ЕСЛИ(B3<>"";формула;"")
где вместо ТЕКСТа формула нужно ввести необходимую формулу.
Я всегда пользуюсь этим шаблоном.

Тогда Результат будет пустая ячейка. А вместо В3 поставить нужную ячейку.

1 вариант:
Код
=ЕСЛИ(B3<>"";ТЕКСТ(B3;"ММММ;");"")
– результат названия месяца с большой буквы – «Сентябрь»

2 вариант:
Код
=ЕСЛИ(B3<>"";ТЕКСТ(B3;"ММММ;@");"")
тоже результат названия месяца с большой буквы– «Сентябрь»

3 вариант:
Код
=ЕСЛИ(B3<>"";ТЕКСТ(ДАТАМЕС(B3;0);"[$-F419]ММММ");"")
– результат названия месяца с маленькой буквы – «сентябрь»

4 вариант:
Код
=ЕСЛИ(B3<>"";ТЕКСТ(ДАТАМЕС(B3;0);"[$-FC19]ММММ");"")
– результат склонение названия месяца с маленькой буквы – «сентября»

5 вариант:
Код
=ЕСЛИ(B3<>"";ПРОПНАЧ(ТЕКСТ(B3;"[$-FC19] ММММ"));"")
– результат склонение названия месяца с большой буквы – «Сентября»

Я только не знаю: 1. как написать формулу склонение название месяца с большой буквы – «Сентября», что бы в формуле не было ПРОПНАЧ. что бы формула была короче.

Формула в варианте ММММ даёт результат только название месяца.
И я не знаю: 2 как подправить мои формулы что бы после названия месяца был год.
Пробовал написать после ММММ – четыре буквы ГГГГ, но год почему то не в результате не получается.


Мои варианты формулы может подправить или сократить если что то неправильно я написал _Boroda_ – Александр.
У меня, наверное, много лишних точек с запятой (;) или нет.


Но формулы «работают» – ЕСЛИ пустая ячейка B3 – результат пустая ячейка.

Елена!
Напишите пожалуйста подошли ли Вам мои варианты формул и шаблон.

Автор - Никанор
Дата добавления - 16.11.2018 в 16:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула месяц что б было пусто если не стоит дата (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!