Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/2-х мерный поиск до определенной строчки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » 2-х мерный поиск до определенной строчки (Формулы/Formulas)
2-х мерный поиск до определенной строчки
33rus Дата: Среда, 21.11.2018, 12:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Просьба подсказать, как осуществить 2-х мерный поиск до определенной строчки. Есть адрес, под ним все поставляемые продукты, далее другой адрес и все поставляемы продукты, и т.д.
Все данны нужно аккумулировать на другом листе, где адреса будут в одну строчку, а продукты в одном столбце. Адрес и продукты проставляются вручную, данные переносятся через формулу, наподобие ВПР.
К сообщению приложен файл: 2-__.xlsx(11.9 Kb)
 
Ответить
СообщениеПросьба подсказать, как осуществить 2-х мерный поиск до определенной строчки. Есть адрес, под ним все поставляемые продукты, далее другой адрес и все поставляемы продукты, и т.д.
Все данны нужно аккумулировать на другом листе, где адреса будут в одну строчку, а продукты в одном столбце. Адрес и продукты проставляются вручную, данные переносятся через формулу, наподобие ВПР.

Автор - 33rus
Дата добавления - 21.11.2018 в 12:26
_Boroda_ Дата: Среда, 21.11.2018, 12:56 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13698
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ((ПРОСМОТР(СТРОКА('Данные отчет'!$A$1:$A$99);СТРОКА('Данные отчет'!$A$1:$A$99)/('Данные отчет'!$B$1:$B$99="");'Данные отчет'!$A$1:$A$99)=B$1)*('Данные отчет'!$A$1:$A$99=$A2)*'Данные отчет'!$B$1:$B$99)
К сообщению приложен файл: 2-1.xlsx(13.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ((ПРОСМОТР(СТРОКА('Данные отчет'!$A$1:$A$99);СТРОКА('Данные отчет'!$A$1:$A$99)/('Данные отчет'!$B$1:$B$99="");'Данные отчет'!$A$1:$A$99)=B$1)*('Данные отчет'!$A$1:$A$99=$A2)*'Данные отчет'!$B$1:$B$99)

Автор - _Boroda_
Дата добавления - 21.11.2018 в 12:56
33rus Дата: Среда, 21.11.2018, 13:13 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
ОГРОМНОЕ СПАСИБО!!!
 
Ответить
СообщениеОГРОМНОЕ СПАСИБО!!!

Автор - 33rus
Дата добавления - 21.11.2018 в 13:13
Светлый Дата: Среда, 21.11.2018, 13:16 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 754
Репутация: 201 ±
Замечаний: 0% ±

Excel 2010
Предложу массивную формулу:
Код
=ВПР($A2;ЕСЛИ(ПОИСКПОЗ(B$1;'Данные отчет'!$A$1:$A$99;)<СТРОКА($1:$99);'Данные отчет'!$A$1:$B$99;);2;0)
Но при неполных исходных данных может выбрать из следующего магазина.
Эта формула лучше:
Код
=ВПР($A2;ЕСЛИ((ПОИСКПОЗ(B$1;'Данные отчет'!$A$1:$A$99;)<СТРОКА($1:$99))*ЕСЛИ(C1="";99;ПОИСКПОЗ(C$1;'Данные отчет'!$A$1:$A$99;)>СТРОКА($1:$99));'Данные отчет'!$A$1:$B$99;);2;0)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеПредложу массивную формулу:
Код
=ВПР($A2;ЕСЛИ(ПОИСКПОЗ(B$1;'Данные отчет'!$A$1:$A$99;)<СТРОКА($1:$99);'Данные отчет'!$A$1:$B$99;);2;0)
Но при неполных исходных данных может выбрать из следующего магазина.
Эта формула лучше:
Код
=ВПР($A2;ЕСЛИ((ПОИСКПОЗ(B$1;'Данные отчет'!$A$1:$A$99;)<СТРОКА($1:$99))*ЕСЛИ(C1="";99;ПОИСКПОЗ(C$1;'Данные отчет'!$A$1:$A$99;)>СТРОКА($1:$99));'Данные отчет'!$A$1:$B$99;);2;0)

Автор - Светлый
Дата добавления - 21.11.2018 в 13:16
_Boroda_ Дата: Среда, 21.11.2018, 13:49 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13698
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Светлый, там звездочки в названиях
Допустим, на листе Данные есть значения
Кальмар филе г/к 1*3
Кальмар филе г/к 1*33
К сообщению приложен файл: 2-2.xlsx(14.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСветлый, там звездочки в названиях
Допустим, на листе Данные есть значения
Кальмар филе г/к 1*3
Кальмар филе г/к 1*33

Автор - _Boroda_
Дата добавления - 21.11.2018 в 13:49
Светлый Дата: Среда, 21.11.2018, 17:30 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 754
Репутация: 201 ±
Замечаний: 0% ±

Excel 2010
там звездочки в названиях

Верно. Не обратил на это внимания. Можно подкорректировать:
Код
=ВПР(ПОДСТАВИТЬ($A2;"*";"~*");ЕСЛИ((ПОИСКПОЗ(C$1;'Данные отчет'!$A$1:$A$99;)<СТРОКА($1:$99))*ЕСЛИ(D1="";99;ПОИСКПОЗ(D$1;'Данные отчет'!$A$1:$A$99;)>СТРОКА($1:$99));'Данные отчет'!$A$1:$B$99;);2;0)


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
там звездочки в названиях

Верно. Не обратил на это внимания. Можно подкорректировать:
Код
=ВПР(ПОДСТАВИТЬ($A2;"*";"~*");ЕСЛИ((ПОИСКПОЗ(C$1;'Данные отчет'!$A$1:$A$99;)<СТРОКА($1:$99))*ЕСЛИ(D1="";99;ПОИСКПОЗ(D$1;'Данные отчет'!$A$1:$A$99;)>СТРОКА($1:$99));'Данные отчет'!$A$1:$B$99;);2;0)

Автор - Светлый
Дата добавления - 21.11.2018 в 17:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » 2-х мерный поиск до определенной строчки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!