Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование даных с использованием формул ИНДЕКС и ПОИСКПОЗ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование даных с использованием формул ИНДЕКС и ПОИСКПОЗ (Формулы/Formulas)
Суммирование даных с использованием формул ИНДЕКС и ПОИСКПОЗ
Zhora Дата: Среда, 21.11.2018, 13:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени ВАМ форумчане Модераторы, Админы, Старожилы и Прохожие.
Столкнулся с трудностью.
При использовании формул ИНДЕКС и ПОИСКПОЗ, не могу добиться требуемого результата.
А именно ПОИСК ПОЗИЦИИ по Ф.И.О. и СУММИРОВАНИЕ этих нескольких значений которые находятся в столбце [u]НАЧислены ЗА ЧАСЫ и соответственно другие значения.[/u]. Эти данные должны согласно указанной Фамилии в листе ПРОБНЫЙ (В2) выписываться из листов ЯНВ. ФЕВ.МАРТ по месяцам в строку на ПРОБНОМ листе.
И так за год или энное число месяцев которые человек отработал.
Моё решение не дало результата.
%) :'( :(
Пример во вложении.
ЗАРАНЕЕ БЛАГОДАРЮ.
К сообщению приложен файл: 1__Excelword-2.xls(94.5 Kb)
 
Ответить
СообщениеДоброго времени ВАМ форумчане Модераторы, Админы, Старожилы и Прохожие.
Столкнулся с трудностью.
При использовании формул ИНДЕКС и ПОИСКПОЗ, не могу добиться требуемого результата.
А именно ПОИСК ПОЗИЦИИ по Ф.И.О. и СУММИРОВАНИЕ этих нескольких значений которые находятся в столбце [u]НАЧислены ЗА ЧАСЫ и соответственно другие значения.[/u]. Эти данные должны согласно указанной Фамилии в листе ПРОБНЫЙ (В2) выписываться из листов ЯНВ. ФЕВ.МАРТ по месяцам в строку на ПРОБНОМ листе.
И так за год или энное число месяцев которые человек отработал.
Моё решение не дало результата.
%) :'( :(
Пример во вложении.
ЗАРАНЕЕ БЛАГОДАРЮ.

Автор - Zhora
Дата добавления - 21.11.2018 в 13:18
Светлый Дата: Среда, 21.11.2018, 13:45 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 749
Репутация: 199 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Можно так:
Код
=СУММПРОИЗВ(($B2='ЯнварьВ-ЛЯЩ'!$B3:$B9)*(F2='ЯнварьВ-ЛЯЩ'!$L$2:$AR$2)*'ЯнварьВ-ЛЯЩ'!$L3:$AR9)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Можно так:
Код
=СУММПРОИЗВ(($B2='ЯнварьВ-ЛЯЩ'!$B3:$B9)*(F2='ЯнварьВ-ЛЯЩ'!$L$2:$AR$2)*'ЯнварьВ-ЛЯЩ'!$L3:$AR9)

Автор - Светлый
Дата добавления - 21.11.2018 в 13:45
_Boroda_ Дата: Среда, 21.11.2018, 13:53 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13681
Репутация: 5580 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММЕСЛИ('ЯнварьВ-ЛЯЩ'!$B$3:$B$9;$B$2;ИНДЕКС('ЯнварьВ-ЛЯЩ'!$L$3:$Z$9;;ПОИСКПОЗ(F$2;'ЯнварьВ-ЛЯЩ'!$L$2:$Z$2;)))

Длинее, но теоретически должна быть быстрее


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММЕСЛИ('ЯнварьВ-ЛЯЩ'!$B$3:$B$9;$B$2;ИНДЕКС('ЯнварьВ-ЛЯЩ'!$L$3:$Z$9;;ПОИСКПОЗ(F$2;'ЯнварьВ-ЛЯЩ'!$L$2:$Z$2;)))

Длинее, но теоретически должна быть быстрее

Автор - _Boroda_
Дата добавления - 21.11.2018 в 13:53
Светлый Дата: Среда, 21.11.2018, 14:19 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 749
Репутация: 199 ±
Замечаний: 0% ±

Excel 2010
И протягиваемая по всем месяцам:
Код
=СУММПРОИЗВ(($B$2=ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ'!B3:B9"))*(F$2=ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ'!L2:AR2"))*Ч(+ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ'!L3:AR9")))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИ протягиваемая по всем месяцам:
Код
=СУММПРОИЗВ(($B$2=ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ'!B3:B9"))*(F$2=ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ'!L2:AR2"))*Ч(+ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ'!L3:AR9")))

Автор - Светлый
Дата добавления - 21.11.2018 в 14:19
китин Дата: Среда, 21.11.2018, 14:49 | Сообщение № 5
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5149
Репутация: 817 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а мне показалось, что надо со всех листов
Код
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ"&"'!$L$3:$Z$9");ПОИСКПОЗ($B$2;ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ"&"'!$B$3:$B$9");0);ПОИСКПОЗ(F$2;ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ"&"'!$L$2:$AR$2");0));"")
К сообщению приложен файл: Zhora.xlsx(49.2 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа мне показалось, что надо со всех листов
Код
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ"&"'!$L$3:$Z$9");ПОИСКПОЗ($B$2;ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ"&"'!$B$3:$B$9");0);ПОИСКПОЗ(F$2;ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ"&"'!$L$2:$AR$2");0));"")

Автор - китин
Дата добавления - 21.11.2018 в 14:49
Zhora Дата: Четверг, 22.11.2018, 06:36 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброе утро. Прошу огромного извинения я наверно не правильно смог донести свою мысль.
Число находящиеся в ячейке например 2880 это не правильно. (это мой вариант решения к сожалению неправильного).
в G3 должно 9072=2880+2520+3672 (это из листа Янв) и т.д. построчно и в каждом столбце свои значения за соответствующие оплаченные работы.
Но так же ВОЗМОЖНО что преподавателю начисляется не по 3 ставкам а по одному как в примере с "Бернгардт Галина Ивановна" (она выделена зеленной заливкой) лист ЯНВ.ФЕВ.МАРТ.
ЕСЛИ это НЕОБХОДИМО ВОЗМОЖНО НЕЗНАЧИТЕЛЬНОЕ ПЕРЕМЕЩЕНИЕ СТОЛБЦОВ. НО С ЗЕЛЕНЫМИ ШАПКАМИ СТОЛБЦЫ ЭТО ЗНАЧЕНИЕ КОТОРЫЕ НАДО СКЛАДЫВАТЬ.
Также на примере ПЕРЕГОРОДОВА О.И. ОНА и преподаватель и библиотекарь и её начисления за работу надо все сложить.В примере она выделена желтой заливкой.
Кажется ВСЕ. надеюсь что смог донести вам мысль своей проблемы.
ФАЙЛ ПРИКРЕПИЛ.
К сообщению приложен файл: 9928643.xls(95.5 Kb)
 
Ответить
СообщениеДоброе утро. Прошу огромного извинения я наверно не правильно смог донести свою мысль.
Число находящиеся в ячейке например 2880 это не правильно. (это мой вариант решения к сожалению неправильного).
в G3 должно 9072=2880+2520+3672 (это из листа Янв) и т.д. построчно и в каждом столбце свои значения за соответствующие оплаченные работы.
Но так же ВОЗМОЖНО что преподавателю начисляется не по 3 ставкам а по одному как в примере с "Бернгардт Галина Ивановна" (она выделена зеленной заливкой) лист ЯНВ.ФЕВ.МАРТ.
ЕСЛИ это НЕОБХОДИМО ВОЗМОЖНО НЕЗНАЧИТЕЛЬНОЕ ПЕРЕМЕЩЕНИЕ СТОЛБЦОВ. НО С ЗЕЛЕНЫМИ ШАПКАМИ СТОЛБЦЫ ЭТО ЗНАЧЕНИЕ КОТОРЫЕ НАДО СКЛАДЫВАТЬ.
Также на примере ПЕРЕГОРОДОВА О.И. ОНА и преподаватель и библиотекарь и её начисления за работу надо все сложить.В примере она выделена желтой заливкой.
Кажется ВСЕ. надеюсь что смог донести вам мысль своей проблемы.
ФАЙЛ ПРИКРЕПИЛ.

Автор - Zhora
Дата добавления - 22.11.2018 в 06:36
Zhora Дата: Четверг, 22.11.2018, 06:59 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
УРАААААА. БЛАГОДАРЮ ЗА ПОМОЩЬ.
ВАС СВЕТЛЫЙ (ваше решение дало искомое значение но еще я не делал протягивание)
и ВАС BORODA (ваше решение тоже дало искомое значение но еще я не делал протягивание)
и ВАС КИТИН вы правильно подумали. (возможен вариант решения вашего подуманной мысли) так интересно 3 человека и 3 варианта решения КЛААСС

Ну теперь попробую дальше САМ. Но если что можно снова обратиться.
 
Ответить
СообщениеУРАААААА. БЛАГОДАРЮ ЗА ПОМОЩЬ.
ВАС СВЕТЛЫЙ (ваше решение дало искомое значение но еще я не делал протягивание)
и ВАС BORODA (ваше решение тоже дало искомое значение но еще я не делал протягивание)
и ВАС КИТИН вы правильно подумали. (возможен вариант решения вашего подуманной мысли) так интересно 3 человека и 3 варианта решения КЛААСС

Ну теперь попробую дальше САМ. Но если что можно снова обратиться.

Автор - Zhora
Дата добавления - 22.11.2018 в 06:59
_Boroda_ Дата: Четверг, 22.11.2018, 09:50 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13681
Репутация: 5580 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если протягивать вниз по месяцам нужно, то вот так еще можно
Код
=СУММЕСЛИ(ДВССЫЛ(ТЕКСТ($B3;"'МММ""*'!B3:B9"""));$B$2;ИНДЕКС(ДВССЫЛ(ТЕКСТ($B3;"'МММ""*'!L3:Z9"""));;ПОИСКПОЗ(F$2;ДВССЫЛ(ТЕКСТ($B3;"'МММ""*'!L2:Z2"""));)))

Код
=СУММПРОИЗВ(($B$2=ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ'!B3:B9"))*(F$2=ДВССЫЛ(ТЕКСТ($B3;"'МММ""*'!L2:Z2""")))*ДВССЫЛ(ТЕКСТ($B3;"'МММ""*'!L3:Z9""")))
К сообщению приложен файл: 1_Excelword-2_2.xls(96.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли протягивать вниз по месяцам нужно, то вот так еще можно
Код
=СУММЕСЛИ(ДВССЫЛ(ТЕКСТ($B3;"'МММ""*'!B3:B9"""));$B$2;ИНДЕКС(ДВССЫЛ(ТЕКСТ($B3;"'МММ""*'!L3:Z9"""));;ПОИСКПОЗ(F$2;ДВССЫЛ(ТЕКСТ($B3;"'МММ""*'!L2:Z2"""));)))

Код
=СУММПРОИЗВ(($B$2=ДВССЫЛ("'"&ТЕКСТ($B3;"ММММ")&"В-ЛЯЩ'!B3:B9"))*(F$2=ДВССЫЛ(ТЕКСТ($B3;"'МММ""*'!L2:Z2""")))*ДВССЫЛ(ТЕКСТ($B3;"'МММ""*'!L3:Z9""")))

Автор - _Boroda_
Дата добавления - 22.11.2018 в 09:50
Zhora Дата: Суббота, 08.12.2018, 11:30 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго дня.
Обрадовался я рано.
Стал подстраивать в своем. ВЫХОДИТ страшное слово ССЫЛКА.
это у меня попытка. Абсолютные ссылки я пока еще не трогал.
=СУММПРОИЗВ(($B$2=ДВССЫЛ("'"&ТЕКСТ($B5;"ММММ")&"Лященко!B3:B99"))*(C$2=ДВССЫЛ("'"&ТЕКСТ($B5;"ММММ")&"Лященко!AE2:BL2"))*Ч(+ДВССЫЛ("'"&ТЕКСТ($B5;"ММММ")&"Лященко!AE3:BL99")))
ВОТ скрин шот. (Если еше я его правильно поставил)


эх какие ваши рекомендации будут. :( :( :(


Сообщение отредактировал Zhora - Суббота, 08.12.2018, 11:31
 
Ответить
СообщениеДоброго дня.
Обрадовался я рано.
Стал подстраивать в своем. ВЫХОДИТ страшное слово ССЫЛКА.
это у меня попытка. Абсолютные ссылки я пока еще не трогал.
=СУММПРОИЗВ(($B$2=ДВССЫЛ("'"&ТЕКСТ($B5;"ММММ")&"Лященко!B3:B99"))*(C$2=ДВССЫЛ("'"&ТЕКСТ($B5;"ММММ")&"Лященко!AE2:BL2"))*Ч(+ДВССЫЛ("'"&ТЕКСТ($B5;"ММММ")&"Лященко!AE3:BL99")))
ВОТ скрин шот. (Если еше я его правильно поставил)


эх какие ваши рекомендации будут. :( :( :(

Автор - Zhora
Дата добавления - 08.12.2018 в 11:30
Pelena Дата: Суббота, 08.12.2018, 13:52 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 13300
Репутация: 2927 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Zhora, оформите формулу тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеZhora, оформите формулу тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 08.12.2018 в 13:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование даных с использованием формул ИНДЕКС и ПОИСКПОЗ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!