Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Системы Счисления. Из любой в 10-ю. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Системы Счисления. Из любой в 10-ю. (Формулы/Formulas)
Системы Счисления. Из любой в 10-ю.
Globy Дата: Среда, 21.11.2018, 20:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток. Я студентка 1 курса института. На одной из дисциплин задали задание в Excel. Написать формулы для перевода любого числа с любым основанием (2-я;8-я;16-я и т.п.) в 10-ю систему счисления. Условие: число не больше 8 разрядов. Я составила для всех систем кроме 16-ой т.к. 16-ая включает в себя буквы: A; B;C;D;E;F. Поэтому прошу о помощи, мне бы хотя бы понять, как преобразовать буквы в числа. Заранее благодарю.
К сообщению приложен файл: decialyy.xlsx(10.0 Kb)
 
Ответить
СообщениеДоброго времени суток. Я студентка 1 курса института. На одной из дисциплин задали задание в Excel. Написать формулы для перевода любого числа с любым основанием (2-я;8-я;16-я и т.п.) в 10-ю систему счисления. Условие: число не больше 8 разрядов. Я составила для всех систем кроме 16-ой т.к. 16-ая включает в себя буквы: A; B;C;D;E;F. Поэтому прошу о помощи, мне бы хотя бы понять, как преобразовать буквы в числа. Заранее благодарю.

Автор - Globy
Дата добавления - 21.11.2018 в 20:13
bmv98rus Дата: Среда, 21.11.2018, 21:11 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1417
Репутация: 238 ±
Замечаний: 0% ±

Excel 2013/2016
Globy, Есть масса вариантов например
Код
=CODE(A1)-55
Код
=LOOKUP(a1;{"A";"B";"C";"D";"E";"F"};{10;11;12;13;14;15})
Код
=FIND(a1;"ABCDEF")+9

Для надежности на случай abcdef добавить
Код
=CODE(UPPEER(A1))-55

И самое смешное
Код
=HEX2DEC(a1)
:D


Сообщение отредактировал bmv98rus - Среда, 21.11.2018, 21:12
 
Ответить
СообщениеGloby, Есть масса вариантов например
Код
=CODE(A1)-55
Код
=LOOKUP(a1;{"A";"B";"C";"D";"E";"F"};{10;11;12;13;14;15})
Код
=FIND(a1;"ABCDEF")+9

Для надежности на случай abcdef добавить
Код
=CODE(UPPEER(A1))-55

И самое смешное
Код
=HEX2DEC(a1)
:D

Автор - bmv98rus
Дата добавления - 21.11.2018 в 21:11
_Boroda_ Дата: Среда, 21.11.2018, 21:17 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13681
Репутация: 5580 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно примерно вот так
Код
=ЕСЛИОШИБКА(--B15;КОДСИМВ(B15)-КОДСИМВ("A")+10)

Итоговый расчет в файле

И для 2-8-16 в Excel есть специальные формулы. Посмотрите в категории "Инженерные"
Все это одной формулой
Код
=СУММ(ЕСЛИОШИБКА(ТЕКСТ(ПСТР($B13;ДЛСТР($B13)-СТРОКА(1:8)+1;1);"0;;;"""&КОДСИМВ(ПСТР($B13;ДЛСТР($B13)-СТРОКА(1:8)+1;1))-55&"""");)*$D13^(ДЛСТР($B13)-СТРОКА(1:8)))

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Понятное дело, что это до тридцатишестиричной системы (включительно) - 26 латинских букв и 10 цифр

*Файл перевложил
К сообщению приложен файл: decialyy_1.xlsx(10.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно примерно вот так
Код
=ЕСЛИОШИБКА(--B15;КОДСИМВ(B15)-КОДСИМВ("A")+10)

Итоговый расчет в файле

И для 2-8-16 в Excel есть специальные формулы. Посмотрите в категории "Инженерные"
Все это одной формулой
Код
=СУММ(ЕСЛИОШИБКА(ТЕКСТ(ПСТР($B13;ДЛСТР($B13)-СТРОКА(1:8)+1;1);"0;;;"""&КОДСИМВ(ПСТР($B13;ДЛСТР($B13)-СТРОКА(1:8)+1;1))-55&"""");)*$D13^(ДЛСТР($B13)-СТРОКА(1:8)))

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Понятное дело, что это до тридцатишестиричной системы (включительно) - 26 латинских букв и 10 цифр

*Файл перевложил

Автор - _Boroda_
Дата добавления - 21.11.2018 в 21:17
Globy Дата: Четверг, 22.11.2018, 18:41 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо огромное всем за помощь!)
 
Ответить
СообщениеСпасибо огромное всем за помощь!)

Автор - Globy
Дата добавления - 22.11.2018 в 18:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Системы Счисления. Из любой в 10-ю. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!